summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/miro/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/miro/PKGBUILD')
-rw-r--r--abs/extra-testing/miro/PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/abs/extra-testing/miro/PKGBUILD b/abs/extra-testing/miro/PKGBUILD
index 121304d..b882d51 100644
--- a/abs/extra-testing/miro/PKGBUILD
+++ b/abs/extra-testing/miro/PKGBUILD
@@ -1,14 +1,14 @@
-# $Id: PKGBUILD 29632 2009-03-10 19:36:59Z ronald $
+# $Id: PKGBUILD 35621 2009-04-14 18:07:17Z ronald $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
pkgname=miro
-pkgver=2.0.2
-pkgrel=1
+pkgver=2.0.4
+pkgrel=3
pkgdesc="The free and open source internet TV platform"
arch=('i686' 'x86_64')
url="http://www.getmiro.com"
license=('GPL2')
-depends=('xine-lib>=1.1.16.1' 'boost>=1.37.0' 'gnome-python-extras>=2.19.1'
+depends=('xine-lib>=1.1.16.1' 'boost>=1.37.0' 'gnome-python-extras>=2.25.3'
'dbus-python>=0.82.4' 'pyrex' 'xulrunner>=1.9.0.1' 'gtk2' 'nspr')
makedepends=('pkgconfig' 'pm-utils' 'qt3')
optdepends=('gstreamer0.10-python: gstreamer backend (potentially unstable)' 'gstreamer0.10: gstreamer backend (potentially unstable')
@@ -16,10 +16,16 @@ install=miro.install
conflicts=('democracy')
replaces=('democracy')
provides=('democracy')
-source=(http://ftp.osuosl.org/pub/pculture.org/miro/src/Miro-${pkgver}.tar.gz)
-md5sums=('ac72878d2faa0f62f96aca2e6d229cb9')
+source=(http://ftp.osuosl.org/pub/pculture.org/miro/src/Miro-${pkgver}.tar.gz
+ miro.exec.patch)
+md5sums=('e6cf48252496b2bddd290f375fc0ca33'
+ '355648eac790d52c51ccb014736f90fc')
build() {
cd ${srcdir}/Miro-${pkgver}/platform/gtk-x11
python setup.py install --root=${pkgdir} || return 1
+
+ # Fix FS#14196
+ cd ${pkgdir}
+ patch -Np0 -i ${srcdir}/miro.exec.patch || return 1
}