summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/pygtk/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/pygtk/PKGBUILD')
-rw-r--r--abs/extra-testing/pygtk/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/pygtk/PKGBUILD b/abs/extra-testing/pygtk/PKGBUILD
new file mode 100644
index 0000000..434af1c
--- /dev/null
+++ b/abs/extra-testing/pygtk/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 16726 2008-10-22 02:50:46Z allan $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
+
+pkgname=pygtk
+pkgver=2.13.0
+pkgrel=2
+pkgdesc="Python bindings for the GTK widget set"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('libglade>=2.6.3' 'pycairo>=1.6.4' 'pygobject>=2.15.4' 'python-numeric>=24.2-2')
+options=('!libtool')
+url="http://www.pygtk.org/"
+source=(http://ftp.gnome.org/pub/gnome/sources/pygtk/2.13/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('e1513921bfd3790b456899c483fceaea')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m644 gtk/gtk-extrafuncs.defs "${pkgdir}/usr/share/pygtk/2.0/defs/" || return 1
+}