summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/consolekit/PKGBUILD7
-rw-r--r--abs/extra-testing/consolekit/add_since_option.patch220
-rw-r--r--abs/extra-testing/libffi/PKGBUILD24
-rw-r--r--abs/extra-testing/libffi/libffi.install18
-rw-r--r--abs/extra-testing/openjpeg/30_fix_build_for_debian.dpatch70
-rw-r--r--abs/extra-testing/openjpeg/PKGBUILD27
-rw-r--r--abs/extra-testing/openslp/PKGBUILD23
-rwxr-xr-xabs/extra-testing/openslp/rc.slpd38
-rw-r--r--abs/extra-testing/poppler-data/PKGBUILD22
-rw-r--r--abs/extra-testing/poppler/PKGBUILD67
10 files changed, 514 insertions, 2 deletions
diff --git a/abs/extra-testing/consolekit/PKGBUILD b/abs/extra-testing/consolekit/PKGBUILD
index e034fa1..10a1f7f 100644
--- a/abs/extra-testing/consolekit/PKGBUILD
+++ b/abs/extra-testing/consolekit/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 86890 2010-08-06 20:24:41Z ibiru $
+# $Id: PKGBUILD 87085 2010-08-10 18:29:16Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: onestep_ua <onestep@ukr.net>
pkgname=consolekit
pkgver=0.4.1
-pkgrel=3
+pkgrel=4
pkgdesc="A framework for defining and tracking users, login sessions, and seats"
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/ConsoleKit"
@@ -16,17 +16,20 @@ source=(http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-${pkgver}
pam-foreground-compat.ck
nodaemon.patch
reorder-initialization.patch
+ add_since_option.patch
consolekit.logrotate)
md5sums=('48eda4483cc97841d5f88e8e003eb6d7'
'a8a4de71d9b0549b8143e5f6c2a36fc7'
'a5bfd56bc89411ff5bb18276a68cb212'
'99fa8cb1bf232050cc0c076378e216c5'
+ 'bd5e72397fe2d42a933a897d28d58155'
'6fefa451d9fe2fc6d6269629d3529793')
build() {
cd "${srcdir}/ConsoleKit-${pkgver}"
patch -Np1 -i "${srcdir}/nodaemon.patch"
patch -Np1 -i "${srcdir}/reorder-initialization.patch"
+ patch -Np1 -i "${srcdir}/add_since_option.patch"
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
diff --git a/abs/extra-testing/consolekit/add_since_option.patch b/abs/extra-testing/consolekit/add_since_option.patch
new file mode 100644
index 0000000..50c1421
--- /dev/null
+++ b/abs/extra-testing/consolekit/add_since_option.patch
@@ -0,0 +1,220 @@
+From c9f2292339540d4b9d8940bcef16b7485480c8d9 Mon Sep 17 00:00:00 2001
+From: William Jon McCann <jmccann@redhat.com>
+Date: Fri, 11 Jun 2010 19:53:22 +0000
+Subject: Add a --since option to show entries in a time window
+
+Doesn't load any history files it doesn't need to which should
+help performance on systems with long histories.
+
+https://bugs.freedesktop.org/show_bug.cgi?id=25660
+---
+diff --git a/tools/ck-history.c b/tools/ck-history.c
+index 606106c..d02caaa 100644
+--- a/tools/ck-history.c
++++ b/tools/ck-history.c
+@@ -62,8 +62,8 @@ typedef enum {
+
+ static GList *all_events = NULL;
+
+-static gboolean
+-process_event_line (const char *line)
++static CkLogEvent *
++parse_event_line (const char *line)
+ {
+ GString *str;
+ CkLogEvent *event;
+@@ -72,47 +72,80 @@ process_event_line (const char *line)
+ event = ck_log_event_new_from_string (str);
+ g_string_free (str, TRUE);
+
+- if (event != NULL) {
+- all_events = g_list_prepend (all_events, event);
+- }
+-
+- return TRUE;
++ return event;
+ }
+
+ static gboolean
+-process_log_gzstream (gzFile *fstream)
++process_log_gzstream (gzFile *fstream,
++ GTimeVal *since)
+ {
+- char line[MAX_LINE_LEN];
++ char line[MAX_LINE_LEN];
++ gboolean hit_since;
++ GList *events;
+
++ events = NULL;
++ hit_since = FALSE;
+ while (gzgets (fstream, line, sizeof (line)) != Z_NULL) {
++ CkLogEvent *event;
++
+ if (strlen (line) == sizeof (line) - 1) {
+ g_warning ("Log line truncated");
+ }
+
+- process_event_line (line);
++ event = parse_event_line (line);
++ if (event == NULL) {
++ continue;
++ }
++
++ if (since == NULL || event->timestamp.tv_sec >= since->tv_sec) {
++ events = g_list_prepend (events, event);
++ } else {
++ hit_since = TRUE;
++ }
+ }
+
+- return TRUE;
++ all_events = g_list_concat (all_events, events);
++
++ return !hit_since;
+ }
+
+ static gboolean
+-process_log_stream (FILE *fstream)
++process_log_stream (FILE *fstream,
++ GTimeVal *since)
+ {
+- char line[MAX_LINE_LEN];
++ char line[MAX_LINE_LEN];
++ gboolean hit_since;
++ GList *events;
+
++ events = NULL;
++ hit_since = FALSE;
+ while (fgets (line, sizeof (line), fstream) != NULL) {
++ CkLogEvent *event;
++
+ if (strlen (line) == sizeof (line) - 1) {
+ g_warning ("Log line truncated");
+ }
+
+- process_event_line (line);
++ event = parse_event_line (line);
++ if (event == NULL) {
++ continue;
++ }
++
++ if (since == NULL || event->timestamp.tv_sec >= since->tv_sec) {
++ events = g_list_prepend (events, event);
++ } else {
++ hit_since = TRUE;
++ }
+ }
+
+- return TRUE;
++ all_events = g_list_concat (all_events, events);
++
++ return !hit_since;
+ }
+
+ static gboolean
+-process_log_file (const char *filename)
++process_log_file (const char *filename,
++ GTimeVal *since)
+ {
+ gboolean ret;
+
+@@ -131,7 +164,7 @@ process_log_file (const char *filename)
+ errmsg);
+ return FALSE;
+ }
+- ret = process_log_gzstream (f);
++ ret = process_log_gzstream (f, since);
+ gzclose (f);
+ } else {
+ FILE *f;
+@@ -143,7 +176,7 @@ process_log_file (const char *filename)
+ g_strerror (errno));
+ return FALSE;
+ }
+- ret = process_log_stream (f);
++ ret = process_log_stream (f, since);
+ fclose (f);
+ }
+
+@@ -180,11 +213,14 @@ get_log_file_list (void)
+ files = g_list_prepend (files, filename);
+ };
+
++ /* Return the list in reverse time order, newest first */
++ files = g_list_reverse (files);
++
+ return files;
+ }
+
+ static gboolean
+-process_logs (void)
++process_logs (GTimeVal *since)
+ {
+ gboolean ret;
+ GList *files;
+@@ -199,8 +235,7 @@ process_logs (void)
+ char *filename;
+
+ filename = l->data;
+-
+- res = process_log_file (filename);
++ res = process_log_file (filename, since);
+ if (! res) {
+ goto out;
+ }
+@@ -843,6 +878,8 @@ main (int argc,
+ GError *error = NULL;
+ int report_type;
+ int uid;
++ GTimeVal timestamp;
++ gboolean use_since;
+ static gboolean do_version = FALSE;
+ static gboolean report_last_compat = FALSE;
+ static gboolean report_last = FALSE;
+@@ -851,6 +888,7 @@ main (int argc,
+ static char *username = NULL;
+ static char *seat = NULL;
+ static char *session_type = NULL;
++ static char *since = NULL;
+ static GOptionEntry entries [] = {
+ { "version", 'V', 0, G_OPTION_ARG_NONE, &do_version, N_("Version of this application"), NULL },
+ { "frequent", 0, 0, G_OPTION_ARG_NONE, &report_frequent, N_("Show listing of frequent users"), NULL },
+@@ -860,6 +898,7 @@ main (int argc,
+ { "seat", 's', 0, G_OPTION_ARG_STRING, &seat, N_("Show entries for the specified seat"), N_("SEAT") },
+ { "session-type", 't', 0, G_OPTION_ARG_STRING, &session_type, N_("Show entries for the specified session type"), N_("TYPE") },
+ { "user", 'u', 0, G_OPTION_ARG_STRING, &username, N_("Show entries for the specified user"), N_("NAME") },
++ { "since", 0, 0, G_OPTION_ARG_STRING, &since, N_("Show entries since the specified time (ISO 8601 format)"), N_("DATETIME") },
+ { NULL }
+ };
+
+@@ -880,6 +919,15 @@ main (int argc,
+ exit (1);
+ }
+
++ use_since = FALSE;
++ if (since != NULL) {
++ use_since = g_time_val_from_iso8601 (since, &timestamp);
++ if (! use_since) {
++ g_warning ("Invalid ISO 8601 time value");
++ exit (1);
++ }
++ }
++
+ if (report_last_compat) {
+ report_type = REPORT_TYPE_LAST_COMPAT;
+ } else if (report_last) {
+@@ -902,7 +950,11 @@ main (int argc,
+ uid = -1;
+ }
+
+- process_logs ();
++ if (use_since) {
++ process_logs (&timestamp);
++ } else {
++ process_logs (NULL);
++ }
+ generate_report (report_type, uid, seat, session_type);
+ free_events ();
+
+--
+cgit v0.8.3-6-g21f6
diff --git a/abs/extra-testing/libffi/PKGBUILD b/abs/extra-testing/libffi/PKGBUILD
new file mode 100644
index 0000000..555f0eb
--- /dev/null
+++ b/abs/extra-testing/libffi/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 72255 2010-03-13 20:43:14Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libffi
+pkgver=3.0.9
+pkgrel=1
+pkgdesc="A portable, high level programming interface to various calling conventions."
+arch=('i686' 'x86_64')
+license=('MIT')
+url="http://sourceware.org/libffi"
+depends=('glibc' 'texinfo')
+options=('!libtool' 'force')
+install=libffi.install
+source=(ftp://sourceware.org/pub/libffi/libffi-${pkgver}.tar.gz)
+md5sums=('1f300a7a7f975d4046f51c3022fa5ff1')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+}
diff --git a/abs/extra-testing/libffi/libffi.install b/abs/extra-testing/libffi/libffi.install
new file mode 100644
index 0000000..151b79b
--- /dev/null
+++ b/abs/extra-testing/libffi/libffi.install
@@ -0,0 +1,18 @@
+infodir=/usr/share/info
+filelist=(libffi.info.gz)
+
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
diff --git a/abs/extra-testing/openjpeg/30_fix_build_for_debian.dpatch b/abs/extra-testing/openjpeg/30_fix_build_for_debian.dpatch
new file mode 100644
index 0000000..afd9950
--- /dev/null
+++ b/abs/extra-testing/openjpeg/30_fix_build_for_debian.dpatch
@@ -0,0 +1,70 @@
+
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 30_fix_build_for_debian.dpatch by <robin.cornelius@gmail.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Dont apply the -s strip flag to the shared lib debian will do it for us
+## DP: where necessary
+## DP: Remove unnecessary linkage on lstdc++ and lm and add missing linkage for -lm
+
+@DPATCH@
+
+Index: ./Makefile
+===================================================================
+--- ./Makefile (revision 96)
++++ ./Makefile (working copy)
+@@ -18,8 +18,7 @@
+ # Converts cr/lf to just lf
+ DOS2UNIX = dos2unix
+
+-COMPILERFLAGS = -Wall -O3 -ffast-math -std=c99 -fPIC
+-LIBRARIES = -lstdc++
++COMPILERFLAGS = -Wall -O3 -ffast-math -std=c99 -fPIC -g $(EXTRA_CFLAGS)
+
+ MODULES = $(SRCS:.c=.o)
+ CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
+@@ -54,7 +53,7 @@
+ $(AR) r $@ $(MODULES)
+
+ $(SHAREDLIB): $(MODULES)
+- $(CC) -s -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) $(LIBRARIES)
++ $(CC) -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) -lm
+
+ install: OpenJPEG
+ install -d '$(DESTDIR)$(INSTALL_LIBDIR)' '$(DESTDIR)$(INSTALL_INCLUDE)'
+
+Index: ./indexer_JPIP/Makefile
+===================================================================
+--- ./indexer_JPIP/Makefile (revision 95)
++++ ./indexer_JPIP/Makefile (working copy)
+@@ -1,7 +1,6 @@
+ CC = gcc
+
+-LDFLAGS = -lm
+-CFLAGS = -Wall
++CFLAGS = -Wall $(EXTRA_CFLAGS)
+
+ all: index_create
+
+Index: ./codec/Makefile
+===================================================================
+--- ./codec/Makefile (revision 96)
++++ ./codec/Makefile (working copy)
+@@ -1,13 +1,13 @@
+ # Makefile for the main OpenJPEG codecs: j2k_to_image and image_to_j2k
+
+-CFLAGS = -O3 -lstdc++ # -g -p -pg
++CFLAGS = $(EXTRA_CFLAGS) # -g -p -pg
+
+ all: j2k_to_image image_to_j2k
+
+-j2k_to_image: j2k_to_image.c ../libopenjpeg.a
++j2k_to_image: j2k_to_image.c
+ gcc $(CFLAGS) compat/getopt.c index.c convert.c j2k_to_image.c -o j2k_to_image -L.. -lopenjpeg -I ../libopenjpeg/ -lm -ltiff
+
+-image_to_j2k: image_to_j2k.c ../libopenjpeg.a
++image_to_j2k: image_to_j2k.c
+ gcc $(CFLAGS) compat/getopt.c index.c convert.c image_to_j2k.c -o image_to_j2k -L.. -lopenjpeg -I ../libopenjpeg/ -lm -ltiff
+
+ clean:
+
diff --git a/abs/extra-testing/openjpeg/PKGBUILD b/abs/extra-testing/openjpeg/PKGBUILD
new file mode 100644
index 0000000..087da2f
--- /dev/null
+++ b/abs/extra-testing/openjpeg/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=openjpeg
+pkgver=1.3
+_pkgver=v1_3
+pkgrel=3
+pkgdesc="An open source JPEG 2000 codec"
+arch=(i686 x86_64)
+license=('BSD')
+url="http://www.openjpeg.org"
+depends=('glibc')
+source=(http://www.openjpeg.org/openjpeg_${_pkgver}.tar.gz
+ 30_fix_build_for_debian.dpatch)
+md5sums=('f9a3ccfa91ac34b589e9bf7577ce8ff9'
+ '2557f485513e77f6dcea77f4741c4fa1')
+
+build() {
+ cd "${srcdir}/OpenJPEG_${_pkgver}"
+ patch -Np1 -i "${srcdir}/30_fix_build_for_debian.dpatch" || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/usr/share/licenses/openjpeg"
+ tr '\r' '\n' < license.txt > "${pkgdir}/usr/share/licenses/openjpeg/license.txt" || return 1
+ chmod 644 "${pkgdir}/usr/share/licenses/openjpeg/license.txt" || return 1
+ ln -s libopenjpeg.so.2 "${pkgdir}/usr/lib/libopenjpeg.so" || return 1
+}
diff --git a/abs/extra-testing/openslp/PKGBUILD b/abs/extra-testing/openslp/PKGBUILD
new file mode 100644
index 0000000..9ba1f94
--- /dev/null
+++ b/abs/extra-testing/openslp/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 75251 2010-04-01 04:53:24Z allan $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+pkgname=openslp
+pkgver=1.2.1
+pkgrel=3
+pkgdesc="Open-source implementation of Service Location Protocol"
+arch=(i686 x86_64)
+url="http://www.openslp.org"
+license=('BSD')
+depends=('glibc' 'bash' 'openssl')
+backup=('etc/slp.conf' 'etc/slp.reg' 'etc/slp.spi')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz rc.slpd)
+md5sums=('ff9999d1b44017281dd00ed2c4d32330' '4f6889a5944894b8be2c01404a9566d2')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} DOC_DIR=/usr/share/doc/openslp-${pkgver} install || return 1
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m755 ../rc.slpd ${pkgdir}/etc/rc.d/slpd
+}
diff --git a/abs/extra-testing/openslp/rc.slpd b/abs/extra-testing/openslp/rc.slpd
new file mode 100755
index 0000000..4330c37
--- /dev/null
+++ b/abs/extra-testing/openslp/rc.slpd
@@ -0,0 +1,38 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/slpd`
+case "$1" in
+ start)
+ stat_busy "Starting SLPD"
+ [ -z "$PID" ] && /usr/sbin/slpd
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ echo $PID > /var/run/slpd.pid
+ add_daemon slpd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping SLPD"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm /var/run/slpd.pid
+ rm_daemon slpd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/abs/extra-testing/poppler-data/PKGBUILD b/abs/extra-testing/poppler-data/PKGBUILD
new file mode 100644
index 0000000..6b22ea3
--- /dev/null
+++ b/abs/extra-testing/poppler-data/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 22380 2008-12-26 16:33:15Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=poppler-data
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="Encoding data for the poppler PDF rendering library"
+arch=(any)
+license=('custom' 'GPL2')
+conflicts=('poppler<0.10.5')
+url="http://poppler.freedesktop.org/"
+source=(http://poppler.freedesktop.org/${pkgname}-${pkgver}.tar.gz)
+md5sums=('2d648047e5d0b315df1571b460ee6a96')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make prefix=/usr DESTDIR="${pkgdir}" install
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING COPYING.adobe \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/abs/extra-testing/poppler/PKGBUILD b/abs/extra-testing/poppler/PKGBUILD
new file mode 100644
index 0000000..092abab
--- /dev/null
+++ b/abs/extra-testing/poppler/PKGBUILD
@@ -0,0 +1,67 @@
+# $Id: PKGBUILD 83716 2010-06-22 17:55:04Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgbase=poppler
+pkgname=('poppler' 'poppler-glib' 'poppler-qt')
+pkgver=0.14.0
+pkgrel=2
+arch=(i686 x86_64)
+license=('GPL')
+makedepends=('libjpeg>=8.0.2' 'gcc-libs>=4.5.0' 'cairo>=1.8.10' 'libxml2>=2.7.7' 'fontconfig>=2.8.0' 'openjpeg>=1.3-3' 'gtk2>=2.20.1' 'qt>=4.6.3' 'pkgconfig' 'lcms>=1.18')
+options=('!libtool')
+url="http://poppler.freedesktop.org/"
+source=(http://poppler.freedesktop.org/${pkgname}-${pkgver}.tar.gz)
+md5sums=('76f003b8fa2b905674088c306aa857c5')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export CPPFLAGS=" $CPPFLAGS -I /usr/include/gdk -I /usr/include/glib-2.0 -I /usr/lib/glib/include/ -I /usr/include/cairo -I /usr/include/gtk-2.0/gdk/"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --enable-cairo-output \
+ --enable-xpdf-headers \
+ --enable-libjpeg --enable-zlib \
+ --enable-poppler-qt4 \
+ --enable-poppler-glib
+ make
+}
+
+package_poppler() {
+ pkgdesc="PDF rendering library based on xpdf 3.0"
+ depends=('libjpeg>=8.0.2' 'gcc-libs>=4.5.0' 'cairo>=1.8.10' 'libxml2>=2.7.7' 'fontconfig>=2.8.0' 'openjpeg>=1.3-3' 'lcms>=1.18' 'poppler-data>=0.4.2')
+ conflicts=("poppler-qt3<${pkgver}")
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}"/usr/include/poppler/{glib,qt4}
+ rm -f "${pkgdir}"/usr/lib/libpoppler-{glib,qt4}.so*
+ rm -f "${pkgdir}"/usr/lib/pkgconfig/poppler-{glib,qt4}.pc
+ rm -rf "${pkgdir}/usr/share/gtk-doc"
+}
+
+package_poppler-glib() {
+ pkgdesc="Poppler glib bindings"
+ depends=("poppler=${pkgver}" 'gtk2>=2.20.1')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}/poppler"
+ make DESTDIR="${pkgdir}" install-libLTLIBRARIES
+ cd "${srcdir}/${pkgbase}-${pkgver}/glib"
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/lib/pkgconfig"
+ install -m644 ../poppler-glib.pc "${pkgdir}/usr/lib/pkgconfig/"
+ rm -f "${pkgdir}"/usr/lib/libpoppler.*
+}
+
+package_poppler-qt() {
+ pkgdesc="Poppler Qt bindings"
+ depends=("poppler=${pkgver}" 'qt>=4.6.3')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}/poppler"
+ make DESTDIR="${pkgdir}" install-libLTLIBRARIES
+ cd "${srcdir}/${pkgbase}-${pkgver}/qt4"
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/lib/pkgconfig"
+ install -m644 ../poppler-qt4.pc "${pkgdir}/usr/lib/pkgconfig/"
+ rm -f "${pkgdir}"/usr/lib/libpoppler.*
+}