summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/community/foldingathome/PKGBUILD16
-rw-r--r--abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff110
-rw-r--r--[-rwxr-xr-x]abs/extra-testing/community/foldingathome/foldingathome.install61
-rw-r--r--abs/extra-testing/community/foldingathome/run26
-rw-r--r--abs/extra-testing/gd/PKGBUILD2
-rw-r--r--abs/extra-testing/pyorbit/PKGBUILD2
-rw-r--r--abs/extra-testing/rrdtool/PKGBUILD6
-rw-r--r--abs/extra-testing/shepherd/PKGBUILD2
-rw-r--r--abs/extra-testing/xine-lib/PKGBUILD8
-rw-r--r--abs/extra-testing/xulrunner/PKGBUILD3
-rw-r--r--abs/extra-testing/xulrunner/xulrunner.install11
11 files changed, 95 insertions, 152 deletions
diff --git a/abs/extra-testing/community/foldingathome/PKGBUILD b/abs/extra-testing/community/foldingathome/PKGBUILD
index 411702c..bb93407 100644
--- a/abs/extra-testing/community/foldingathome/PKGBUILD
+++ b/abs/extra-testing/community/foldingathome/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=foldingathome
pkgver=6.02
-pkgrel=1
+pkgrel=6
pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
arch=('i686')
url="http://folding.stanford.edu/"
@@ -13,16 +13,14 @@ depends=('bash')
backup=('etc/conf.d/foldingathome')
install=foldingathome.install
source=(http://www.stanford.edu/group/pandegroup/folding/release/FAH$pkgver-Linux.tgz
- archpatch_foldingathome.diff)
+ run)
md5sums=('112b3d66909050f1bb990993a1464cb9'
- '02f4ca64d552b442d484c51fa5f4228a')
+ '61eb4617e7363d586a05dde980ad1c14')
build() {
cd $startdir/src/
- patch -p1 <archpatch_foldingathome.diff
- install -D -c -m755 fah6 $startdir/pkg/opt/fah/fah6 || return 1
- install -D -c -m755 $startdir/src/foldingathome.rc.d $startdir/pkg/etc/rc.d/foldingathome || return 1
- install -D -c -m644 $startdir/src/foldingathome.conf.d $startdir/pkg/etc/conf.d/foldingathome || return 1
- install -D -m644 foldingathome.license $startdir/pkg/usr/share/licenses/$pkgname/COPYING
-
+
+ # At this stage, the mpiexec is not included because it requires x86_64.
+ install -D -c -m755 fah6 $startdir/pkg/usr/bin/fah6 || return 1
+ install -D -m755 run $startdir/pkg/etc/sv/fah/run
}
diff --git a/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff b/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff
deleted file mode 100644
index 73410f1..0000000
--- a/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff
+++ /dev/null
@@ -1,110 +0,0 @@
-diff -Naur blank/foldingathome.conf.d 6.02-1/foldingathome.conf.d
---- blank/foldingathome.conf.d 1969-12-31 16:00:00.000000000 -0800
-+++ 6.02-1/foldingathome.conf.d 2008-08-21 16:59:05.000000000 -0700
-@@ -0,0 +1,12 @@
-+#
-+# Optional user settings for foldingathome daemon
-+#
-+# If you prefer not to run fah as root then you can identifer a current or
-+# specially created user here.
-+
-+FAH_USER=""
-+
-+# If you wish to associate this user with a specific group you can enter the
-+# group name here. If left blank the default is "users".
-+
-+FAH_GRP=""
-diff -Naur blank/foldingathome.license 6.02-1/foldingathome.license
---- blank/foldingathome.license 1969-12-31 16:00:00.000000000 -0800
-+++ 6.02-1/foldingathome.license 2008-08-21 16:59:27.000000000 -0700
-@@ -0,0 +1,26 @@
-+Folding@Home distributed computing client
-+Copyright 2001-2007. Stanford University. All Rights Reserved.
-+
-+License Agreement:
-+
-+Please carefully read the following terms and conditions before using this software. Use of this software
-+indicates acceptance of this license agreement and disclaimer of all warranties.
-+
-+Disclaimer of Warranty:
-+
-+IN NO EVENT SHALL STANFORD UNIVERSITY BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL,
-+OR CONSEQUENTIAL DAMAGES, INCLUDING LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS
-+DOCUMENTATION, EVEN IF STANFORD UNIVERSITY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-+STANFORD UNIVERSITY SPECIFICALLY DISCLAIMS ANY WARRANTIES, INCLUDING, BUT NOTLIMITED TO, THE IMPLIED
-+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE AND ACCOMPANYING
-+DOCUMENTATION PROVIDED HEREUNDER IS PROVIDED "AS IS". Folding@home HAS NO OBLIGATION TO PROVIDE
-+MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS.
-+
-+Restrictions:
-+
-+You may use this software on a computer system only if you own the system or have the permission of the owner.
-+You may not alter the software or associated data files.
-+You may only use unmodified versions of Folding@home obtained through authorized distributors to connect
-+to the Folding@Home servers. Use of other software to connect to the Folding@home servers is strictly prohibited.
-+Distribution of this software is prohibited. It may only be obtained by downloading from Stanford's web site
-+(http://folding.stanford.edu and pages linked therein) or the web site of one of our commercial partners (Sony, NVIDIA, and ATI).
-diff -Naur blank/foldingathome.rc.d 6.02-1/foldingathome.rc.d
---- blank/foldingathome.rc.d 1969-12-31 16:00:00.000000000 -0800
-+++ 6.02-1/foldingathome.rc.d 2008-08-21 17:00:48.000000000 -0700
-@@ -0,0 +1,60 @@
-+#!/bin/bash
-+#/etc/rc.d/foldingathome
-+#
-+# Starts the Folding@Home client in the background
-+
-+. /etc/rc.conf
-+. /etc/rc.d/functions
-+. /etc/conf.d/foldingathome
-+
-+PID=`pidof -o %PPID /opt/fah/fah6`
-+case "$1" in
-+ start)
-+ stat_busy "Starting Folding@Home"
-+ if [ -z "$PID" ]; then
-+ if [ ! -z "$FAH_USER" ] ; then
-+ if [ ! -d "/opt/fah/$FAH_USER" ] ; then
-+ mkdir /opt/fah/$FAH_USER
-+ chown $FAH_USER /opt/fah/$FAH_USER
-+ if [ ! -z "$FAH_GRP" ] ; then
-+ chgrp $FAH_GRP /opt/fah/$FAH_USER
-+ else
-+ chgrp users /opt/fah/$FAH_USER
-+ fi
-+ fi
-+ cd /opt/fah/$FAH_USER
-+ su $FAH_USER -c "nice --adjustment 19 /opt/fah/fah6 -verbosity 9 > /opt/fah/$FAH_USER/myfah.log" &
-+ else
-+ cd /opt/fah
-+ nice --adjustment 19 /opt/fah/fah6 -verbosity 9 > /opt/fah/myfah.log &
-+ fi
-+ fi
-+ if [ ! -z "$PID" -o $? -gt 0 ]; then
-+ stat_fail
-+ else
-+ add_daemon foldingathome
-+ stat_done
-+ fi
-+ ;;
-+
-+ stop)
-+ stat_busy "Stopping Folding@Home"
-+ [ ! -z "$PID" ]&& kill $PID &> /dev/null
-+ if [ $? -gt 0 ]; then
-+ stat_fail
-+ else
-+ rm_daemon foldingathome
-+ stat_done
-+ fi
-+ ;;
-+
-+ restart)
-+ $0 stop
-+ sleep 1
-+ $0 start
-+ ;;
-+
-+ *)
-+ echo $"Usage: $0 {start|stop|restart}"
-+esac
-+
diff --git a/abs/extra-testing/community/foldingathome/foldingathome.install b/abs/extra-testing/community/foldingathome/foldingathome.install
index 8eedb6c..20e48d1 100755..100644
--- a/abs/extra-testing/community/foldingathome/foldingathome.install
+++ b/abs/extra-testing/community/foldingathome/foldingathome.install
@@ -1,30 +1,47 @@
-# arg 1: the new package version
post_install() {
- cat << 'EOM'
- --> Please cd to /opt/fah/ and execute ./fah6 -smp -configonly
- --> to configure your settings. Then add "foldingathome" to the list
- --> of daemons in /etc/rc.conf. If you would like to join the Arch
- --> Linux team, use team number 45032. To check current progress,
- --> point your browser to file://opt/fah/MyFolding.html
-
- --> It is strongly recommended that you run foldingathome as a user other
- --> than root. You can identify a user in /etc/conf.d/foldingathome.
- --> A directory called /opt/fah/$FAH_USER will be created."
+ # Check for an R5.5 fah installation.
+ r5_fah_dir=/myth/folding@home
+ r6_fah_dir=/myth/foldingathome/$(hostname)
+ if [ -d "$r5_fah_dir" ] ; then
+ if [ -d "$r6_fah_dir" ] ; then
+ cat << 'EOM'
+ --> You have an R5.5 and an R6 folding directory at the same time!
+ --> you should manually delete the R5.5 directory:
+ --> $r5_fah_dir
+ --> The directroy used on R6 will be:
+ --> $r6_fah_dir
EOM
-}
+ else
+ mkdir -p /myth/foldingathome
+ mv $r5_fah_dir $r6_fah_dir
+ fi
+ else
+ if [ ! -d "$r6_fah_dir" ] ; then
+ mkdir -p $r6_fah_dir
+ cat > $r6_fah_dir/client.cfg << 'EOM'
+[settings]
+username=LinHES
+team=50975
+passkey=
+asknet=no
+bigpackets=normal
+machineid=1
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install $1
+[http]
+active=no
+host=localhost
+port=8080
+EOM
+ fi
+ fi
+ rm -fr $r6_fah_dir/index.html
+ ln -s $r6_fah_dir/MyFolding.html $r6_fah_dir/index.html
+ ln -s $r6_fah_dir /data/srv/httpd/htdocs/foldingathome
+ /sbin/add_service.sh fah
}
-# arg 1: the old package version
pre_remove() {
- /bin/true
+ sv stop fah
+ /sbin/remove_service.sh fah
}
-op=$1
-shift
-
-$op $*
diff --git a/abs/extra-testing/community/foldingathome/run b/abs/extra-testing/community/foldingathome/run
new file mode 100644
index 0000000..ede51f2
--- /dev/null
+++ b/abs/extra-testing/community/foldingathome/run
@@ -0,0 +1,26 @@
+#!/bin/sh
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting folding@home"
+
+FOLDING_DIR=/myth/foldingathome/$(hostname)
+
+if [ -d $FOLDING_DIR ] ; then
+ cd $FOLDING_DIR
+ # Ensure that the client configuration file has the same details as /etc/systemconfig
+
+ source /etc/systemconfig
+
+ if [ -n "$foldingusername" ] ; then
+ sed -i 's/username=.*$/username='$foldingusername'/g' $FOLDING_DIR/client.cfg
+ fi
+
+ if [ -n "$foldingworksize" ] ; then
+ sed -i 's/bigpackets=.*$/bigpackets='$foldingworksize'/g' $FOLDING_DIR/client.cfg
+ fi
+
+ # No need to direct output to a log file becase a log file
+ # will automatically be placed in $FOLDING_DIR
+ exec /usr/bin/fah6 -verbosity 9 &> /dev/null < /dev/null
+fi
diff --git a/abs/extra-testing/gd/PKGBUILD b/abs/extra-testing/gd/PKGBUILD
index 11e2929..3df77a1 100644
--- a/abs/extra-testing/gd/PKGBUILD
+++ b/abs/extra-testing/gd/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gd
pkgver=2.0.35
-pkgrel=1
+pkgrel=2
pkgdesc="Library for the dynamic creation of images by programmers"
arch=('i686' 'x86_64')
url="http://www.libgd.org/"
diff --git a/abs/extra-testing/pyorbit/PKGBUILD b/abs/extra-testing/pyorbit/PKGBUILD
index ac9f7c0..60f8f34 100644
--- a/abs/extra-testing/pyorbit/PKGBUILD
+++ b/abs/extra-testing/pyorbit/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pyorbit
pkgver=2.24.0
-pkgrel=2
+pkgrel=3
pkgdesc="Python bindings for ORBit2"
arch=(i686 x86_64)
license=('LGPL')
diff --git a/abs/extra-testing/rrdtool/PKGBUILD b/abs/extra-testing/rrdtool/PKGBUILD
index b2c42e3..6050e5c 100644
--- a/abs/extra-testing/rrdtool/PKGBUILD
+++ b/abs/extra-testing/rrdtool/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=rrdtool
pkgver=1.3.6
-pkgrel=1
+pkgrel=2
pkgdesc="Data logging and graphing application"
arch=('i686' 'x86_64')
url="http://www.rrdtool.org"
license=('GPL')
-depends=('libart-lgpl' 'libpng' 'freetype2' 'libxml2' 'pango')
-makedepends=('ruby' 'python' 'tcl')
+depends=('libart-lgpl' 'libpng' 'freetype2' 'libxml2' 'pango' 'ruby')
+makedepends=('python' 'tcl')
optdepends=('tcl, python and/or ruby: to use corresponding binding')
options=('!libtool' '!emptydirs')
source=(http://oss.oetiker.ch/rrdtool/pub/rrdtool-${pkgver}.tar.gz)
diff --git a/abs/extra-testing/shepherd/PKGBUILD b/abs/extra-testing/shepherd/PKGBUILD
index 28b2005..f7b3048 100644
--- a/abs/extra-testing/shepherd/PKGBUILD
+++ b/abs/extra-testing/shepherd/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Greg Frost <gregfrost1@bigpond.com>
pkgname=shepherd
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Australian EPG Grabber."
arch=i686
depends=(perl-pathtools perl-digest-sha1 perl-algorithm-diff perl-javascript perl-list-compare)
diff --git a/abs/extra-testing/xine-lib/PKGBUILD b/abs/extra-testing/xine-lib/PKGBUILD
index 1cc9e2b..aa15b8f 100644
--- a/abs/extra-testing/xine-lib/PKGBUILD
+++ b/abs/extra-testing/xine-lib/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=xine-lib
-pkgver=1.1.16.2
-pkgrel=3
+pkgver=1.1.16.3
+pkgrel=4
pkgdesc="A free video player for Unix"
arch=('i686' 'x86_64')
url="http://xinehq.de/"
@@ -17,8 +17,8 @@ makedepends=('pkgconfig' 'libtool' 'imagemagick' 'smbclient' 'mesa' 'alsa-lib'
options=('!libtool')
source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.bz2
xine-lib-1.1.1-configure-no-mcpu-march.patch)
-md5sums=('336dd1f6266e9f943430ca6009b7aa7e' '9776df4eb54d2f1f68d8268adbc3b5c2')
-sha1sums=('faa3d9207d911a535161a3cd5660aa9e6b904c28' '121a8358d7919b2e51067412373f52848290338a')
+md5sums=('4f508abf088cf427a731f85634c8260d'
+ '9776df4eb54d2f1f68d8268adbc3b5c2')
optiona=(!emptydir)
build() {
diff --git a/abs/extra-testing/xulrunner/PKGBUILD b/abs/extra-testing/xulrunner/PKGBUILD
index 84d6734..da6d8cd 100644
--- a/abs/extra-testing/xulrunner/PKGBUILD
+++ b/abs/extra-testing/xulrunner/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xulrunner
pkgver=1.9.1.1
_ffoxver=3.5.1
-pkgrel=2
+pkgrel=5
pkgdesc="Mozilla Runtime Environment"
arch=(i686 x86_64)
license=('MPL' 'GPL' 'LGPL')
@@ -18,6 +18,7 @@ source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
mozconfig)
md5sums=('18169e189785d680827d4fce94524449'
'6509d12e6b17bfc51c09e1dc35259035')
+install=xulrunner.install
build() {
cd ${startdir}/src/mozilla-1.9.1
diff --git a/abs/extra-testing/xulrunner/xulrunner.install b/abs/extra-testing/xulrunner/xulrunner.install
new file mode 100644
index 0000000..0b4cf9c
--- /dev/null
+++ b/abs/extra-testing/xulrunner/xulrunner.install
@@ -0,0 +1,11 @@
+post_install() {
+ # Ensure that the ld.so.conf file contains the xulrunner libs.
+ cp -f /etc/ld.so.conf /tmp/ld.so.conf
+ grep -v xulrunner /tmp/ld.so.conf > /etc/ld.so.conf
+ echo /usr/lib/xulrunner-1.9.1.1 >> /etc/ld.so.conf
+ /sbin/ldconfig
+}
+
+post_upgrade() {
+ post_install $*
+}