summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/strace/PKGBUILD21
-rw-r--r--abs/extra-testing/strace/no_linux_socket_h.patch22
-rw-r--r--abs/extra-testing/xscreensaver/PKGBUILD15
3 files changed, 46 insertions, 12 deletions
diff --git a/abs/extra-testing/strace/PKGBUILD b/abs/extra-testing/strace/PKGBUILD
new file mode 100644
index 0000000..c965f24
--- /dev/null
+++ b/abs/extra-testing/strace/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 13699 2008-09-27 22:25:37Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+pkgname=strace
+pkgver=4.5.18
+pkgrel=1
+pkgdesc="A useful diagnositic, instructional, and debugging tool"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://sourceforge.net/projects/strace/"
+depends=('glibc')
+source=(http://downloads.sourceforge.net/sourceforge/strace/strace-$pkgver.tar.bz2)
+md5sums=('e9449fcee97e6a8ed73934c883c870e0')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -Dm644 COPYRIGHT ${startdir}/pkg/usr/share/licenses/strace/COPYRIGHT
+}
diff --git a/abs/extra-testing/strace/no_linux_socket_h.patch b/abs/extra-testing/strace/no_linux_socket_h.patch
new file mode 100644
index 0000000..f1c3598
--- /dev/null
+++ b/abs/extra-testing/strace/no_linux_socket_h.patch
@@ -0,0 +1,22 @@
+--- strace-4.5.12.orig/configure.ac
++++ strace-4.5.12/configure.ac
+@@ -193,8 +193,7 @@
+
+ AC_CHECK_FUNCS(sigaction strerror strsignal pread sys_siglist _sys_siglist getdents mctl prctl sendmsg inet_ntop if_indextoname)
+ AC_CHECK_HEADERS([sys/reg.h sys/filio.h sys/acl.h sys/asynch.h sys/door.h stropts.h sys/conf.h sys/stream.h sys/tihdr.h sys/tiuser.h sys/sysconfig.h ioctls.h sys/ioctl.h sys/ptrace.h termio.h linux/ptrace.h asm/reg.h sys/uio.h sys/aio.h poll.h sys/poll.h sys/vfs.h asm/sysmips.h linux/utsname.h sys/nscsys.h mqueue.h sys/epoll.h libaio.h], [], [])
+-AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
+- [], [], [#include <linux/socket.h>])
++AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h])
+ AC_CHECK_HEADERS([asm/sigcontext.h], [], [], [#include <signal.h>])
+ AC_CHECK_HEADERS([netinet/tcp.h netinet/udp.h],,, [#include <netinet/in.h>])
+
+--- strace-4.5.12.orig/configure
++++ strace-4.5.12/configure
+@@ -6945,7 +6945,6 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <linux/socket.h>
+
+ #include <$ac_header>
+ _ACEOF
diff --git a/abs/extra-testing/xscreensaver/PKGBUILD b/abs/extra-testing/xscreensaver/PKGBUILD
index 975d1cf..a384886 100644
--- a/abs/extra-testing/xscreensaver/PKGBUILD
+++ b/abs/extra-testing/xscreensaver/PKGBUILD
@@ -1,10 +1,6 @@
-# $Id: PKGBUILD 23065 2009-01-02 07:24:36Z eric $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: Sean Middleditch <elanthis@awesomeplay.com>
-
pkgname=xscreensaver
pkgver=5.08
-pkgrel=1
+pkgrel=2
pkgdesc="Screen saver and locker for the X Window System"
arch=('i686' 'x86_64')
url="http://www.jwz.org/xscreensaver/"
@@ -12,13 +8,8 @@ license=('BSD')
depends=('libxxf86misc' 'libglade' 'mesa' 'pam' 'xorg-res-utils')
makedepends=('bc')
backup=('etc/pam.d/xscreensaver')
-source=(http://www.jwz.org/xscreensaver/${pkgname}-${pkgver}.tar.gz \
- xscreensaver.pam LICENSE)
-md5sums=('79dea708c915341f205e00318a699be9' '367a3538f54db71f108b34cfa31088ac'\
- '5e7f3f2a63d20a484742f5b4cb5d572c')
-sha1sums=('4e6889d7171eaf18b856c484a87d5701787e5dc6'
- '106635aa1aae51d6f0668b1853f6c49a4fe9d3d8'
- '4209ea586b204fd1d81c382a0522c654f9fd9134')
+#source=(http://www.jwz.org/xscreensaver/${pkgname}-${pkgver}.tar.gz \
+source=(http://www.tienza.es/crux/src/www.jwz.org/xscreensaver/${pkgname}-${pkgver}.tar.gz xscreensaver.pam LICENSE)
build() {
cd ${srcdir}/${pkgname}-${pkgver}