summaryrefslogtreecommitdiffstats
path: root/abs/extra/bluez/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/bluez/PKGBUILD')
-rw-r--r--abs/extra/bluez/PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index 3ea45a0..db1044c 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -5,29 +5,20 @@
pkgbase=bluez
pkgname=('bluez' 'bluez-utils' 'bluez-libs' 'bluez-cups' 'bluez-hid2hci' 'bluez-plugins')
-pkgver=5.27
+pkgver=5.39
pkgrel=1
url="http://www.bluez.org/"
arch=('i686' 'x86_64')
license=('GPL2')
makedepends=('dbus' 'libical' 'systemd')
-source=(http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.xz
- 0001-Allow-using-obexd-without-systemd-in-the-user-session.patch
+source=(http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.{xz,sign}
bluetooth.modprobe)
# see https://www.kernel.org/pub/linux/bluetooth/sha256sums.asc
-sha256sums=('fbf33cebc76f8c81f28f0d67c71a8a1ec4b04b087460ec7353f7e0c207a1f981'
- '896a1403d9b7258c4fb0d41f3a6f70fd51eaa1115ab3f4259f3dbbe02b55766b'
+sha256sums=('21d1bc9150d3576296595217efb98a746b592389d25d5637e8bee5da7272593b'
+ 'SKIP'
'46c021be659c9a1c4e55afd04df0c059af1f3d98a96338236412e449bf7477b4')
validpgpkeys=('E932D120BC2AEC444E558F0106CA9F5D1DCF2659') # Marcel Holtmann <marcel@holtmann.org>
-prepare() {
- cd $pkgname-$pkgver
- # patch not upstreamable for obex file transfer - FS#37773 taken from FC
- # http://www.hadess.net/2013/11/bluetooth-file-sharing-obexpush-in.html
- patch -Np1 -i ${srcdir}/0001-Allow-using-obexd-without-systemd-in-the-user-session.patch
- autoreconf -vfi
-}
-
build() {
cd ${pkgname}-${pkgver}
./configure \
@@ -44,7 +35,7 @@ build() {
check() {
cd $pkgname-$pkgver
- #make check
+ make check
}
@@ -75,11 +66,14 @@ package_bluez() {
# fix module loading errors
install -dm755 ${pkgdir}/usr/lib/modprobe.d
install -Dm644 ${srcdir}/bluetooth.modprobe ${pkgdir}/usr/lib/modprobe.d/bluetooth-usb.conf
+
+ # fix obex file transfer - https://bugs.archlinux.org/task/45816
+ ln -fs /usr/lib/systemd/user/obex.service ${pkgdir}/usr/lib/systemd/user/dbus-org.bluez.obex.service
}
package_bluez-utils() {
pkgdesc="Development and debugging utilities for the bluetooth protocol stack"
- depends=('dbus' 'systemd')
+ depends=('dbus' 'systemd' 'glib2')
conflicts=('bluez-hcidump')
provides=('bluez-hcidump')
replaces=('bluez-hcidump' 'bluez<=4.101')