summaryrefslogtreecommitdiffstats
path: root/abs/extra/bluez/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/bluez/PKGBUILD')
-rw-r--r--abs/extra/bluez/PKGBUILD83
1 files changed, 0 insertions, 83 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
deleted file mode 100644
index c1f675a..0000000
--- a/abs/extra/bluez/PKGBUILD
+++ /dev/null
@@ -1,83 +0,0 @@
-# $Id$
-# Maintainer: Tom Gundersen <teg@jklm.no>
-# Contributor: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
-
-pkgname=bluez
-pkgver=4.99
-pkgrel=2
-pkgdesc="Libraries and tools for the Bluetooth protocol stack"
-url="http://www.bluez.org/"
-arch=('i686' 'x86_64')
-license=('GPL2')
-depends=('dbus-core' 'python2' 'udev')
-makedepends=('gstreamer0.10-base' 'libusb-compat' 'libsndfile')
-optdepends=("gstreamer0.10-base: bluetooth GStreamer support"
- "alsa-lib: Audio bluetooth devices support"
- "dbus-python: to run bluez-simple-agent"
- "pygobject: to run bluez-simple-agent"
- "libusb-compat: USB adapters support"
- "cups: CUPS backend")
-conflicts=('bluez-libs' 'bluez-utils')
-provides=('bluez-libs' 'bluez-utils')
-replaces=('bluez-libs' 'bluez-utils')
-options=('!libtool')
-backup=(etc/bluetooth/{main,rfcomm,audio,network,input,serial}.conf
- 'etc/conf.d/bluetooth' 'etc/dbus-1/system.d/bluetooth.conf')
-install='bluez.install'
-source=("http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.bz2"
- 'bluetooth.conf.d')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/lib \
- --enable-gstreamer \
- --enable-alsa \
- --enable-usb \
- --enable-tools \
- --enable-bccmd \
- --enable-dfutool \
- --enable-hid2hci \
- --enable-hidd \
- --enable-pand \
- --enable-dund \
- --disable-cups \
- --enable-wiimote \
- --disable-test
- make
-}
-
-package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
-
-# install -Dm755 ${srcdir}/rc.bluetooth ${pkgdir}/etc/rc.d/bluetooth
-
- install -d ${pkgdir}/etc/bluetooth
- install -m644 network/network.conf \
- input/input.conf \
- audio/audio.conf \
- serial/serial.conf \
- ${pkgdir}/etc/bluetooth/
-
- install -Dm644 ${srcdir}/bluetooth.conf.d \
- ${pkgdir}/etc/conf.d/bluetooth
-
- # FS#27630
- install -Dm755 test/simple-agent "${pkgdir}"/usr/bin/bluez-simple-agent
- install -Dm755 test/test-device "${pkgdir}"/usr/bin/bluez-test-device
- install -Dm755 test/test-input "${pkgdir}"/usr/bin/bluez-test-input
- sed -i 's#/usr/bin/python#/usr/bin/python2#' \
- "${pkgdir}"/usr/bin/bluez-simple-agent \
- "${pkgdir}"/usr/bin/bluez-test-device \
- "${pkgdir}"/usr/bin/bluez-test-input
-
- # http://mailman.archlinux.org/pipermail/arch-general/2011-April/019787.html
-# rm "${pkgdir}"/usr/lib/udev/rules.d/97-bluetooth.rules
-}
-md5sums=('2387053eb5a7b02f37df4871df022a02'
- '7412982b440f29fa7f76a41a87fef985')