summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/chromium/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/chromium/PKGBUILD')
-rw-r--r--abs/extra/community/chromium/PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/abs/extra/community/chromium/PKGBUILD b/abs/extra/community/chromium/PKGBUILD
index 013f1cc..e5518e9 100644
--- a/abs/extra/community/chromium/PKGBUILD
+++ b/abs/extra/community/chromium/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium
-pkgver=12.0.742.112
+pkgver=13.0.782.112
pkgrel=1
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
arch=('i686' 'x86_64')
@@ -15,19 +15,17 @@ depends=('gtk2' 'dbus-glib' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent'
'libxss' 'libxtst' 'ttf-dejavu' 'desktop-file-utils'
'hicolor-icon-theme')
makedepends=('python2' 'perl' 'gperf' 'yasm' 'mesa' 'libgnome-keyring')
+optdepends=('mozplugger-chromium: A Mozilla multimedia plugin for Chromium')
provides=('chromium-browser')
conflicts=('chromium-browser')
+replaces=('firefox' 'firefox-i18n' 'mozplugger')
install=chromium.install
source=(http://build.chromium.org/official/chromium-$pkgver.tar.bz2
chromium.desktop
chromium.sh
gcc-4.6.patch
- glibc-2.14.patch)
-md5sums=('8a5b7b4b30f5fe8de10fcf7d984321b8'
- '075c3c2fa5902e16b8547dd31d437191'
- '096a46ef386817988250d2d7bddd1b34'
- '0ea28c80c49a0a4440786e05b5251678'
- '543a32b09f138fd47858b9a4a7c82dfb')
+ glibc-2.14.patch
+ make-hash-tools-use-if-instead-of-switch.patch)
build() {
cd "$srcdir/chromium-$pkgver"
@@ -42,6 +40,10 @@ build() {
# http://code.google.com/p/chromium/issues/detail?id=86646
patch -Np2 -i "$srcdir/glibc-2.14.patch"
+# Fix build with Perl 5.14
+ patch -d third_party/WebKit -Np2 -i \
+ "$srcdir/make-hash-tools-use-if-instead-of-switch.patch"
+
### Configure
# Use Python 2
@@ -126,3 +128,9 @@ package() {
}
# vim:set ts=2 sw=2 et:
+md5sums=('a0ddccb65b0075419d089087a9de785c'
+ '075c3c2fa5902e16b8547dd31d437191'
+ '096a46ef386817988250d2d7bddd1b34'
+ '690f2be42bf2a31755753a466653eb33'
+ '543a32b09f138fd47858b9a4a7c82dfb'
+ '9d9e66c8365d7333e55305796b49fd77')