summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/chromium
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/chromium')
-rw-r--r--abs/extra/community/chromium/PKGBUILD145
-rw-r--r--abs/extra/community/chromium/__changelog2
-rw-r--r--abs/extra/community/chromium/chromium-media-no-sse-r0.patch17
-rw-r--r--abs/extra/community/chromium/chromium.desktop113
-rw-r--r--abs/extra/community/chromium/chromium.install12
-rwxr-xr-xabs/extra/community/chromium/chromium.sh4
-rw-r--r--abs/extra/community/chromium/gcc-4.6.patch99
-rw-r--r--abs/extra/community/chromium/nacl-cflags-remove-fstack-protector.patch17
8 files changed, 0 insertions, 409 deletions
diff --git a/abs/extra/community/chromium/PKGBUILD b/abs/extra/community/chromium/PKGBUILD
deleted file mode 100644
index df239af..0000000
--- a/abs/extra/community/chromium/PKGBUILD
+++ /dev/null
@@ -1,145 +0,0 @@
-# $Id: PKGBUILD 150259 2012-02-16 02:37:46Z foutrelis $
-# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
-# Contributor: Pierre Schmitz <pierre@archlinux.de>
-# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
-# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
-
-# Building for x86_64 requires lib32-glibc & lib32-zlib from [multilib]. These
-# libraries are linked from the NaCl toolchain, and are only needed during
-# build time.
-
-pkgname=chromium
-pkgver=17.0.963.56
-pkgrel=2
-pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
-arch=('i686' 'x86_64')
-url="http://www.chromium.org/"
-license=('BSD')
-depends=('gtk2' 'dbus-glib' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent'
- 'libxss' 'libgcrypt' 'ttf-dejavu' 'desktop-file-utils'
- 'hicolor-icon-theme')
-makedepends=('python2' 'perl' 'gperf' 'yasm' 'mesa' 'libgnome-keyring'
- 'elfutils')
-optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
- 'mozplugger-chromium: A Mozilla multimedia plugin for Chromium')
-# Needed for the NaCl toolchain
-[[ $CARCH == x86_64 ]] && makedepends+=('lib32-zlib')
-provides=('chromium-browser')
-conflicts=('chromium-browser')
-replaces=('firefox' 'firefox-i18n' 'mozplugger')
-install=chromium.install
-source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.bz2
- http://commondatastorage.googleapis.com/nativeclient-mirror/nacl/nacl_sdk/nacl_sdk.zip
- chromium.desktop
- chromium.sh
- gcc-4.6.patch
- nacl-cflags-remove-fstack-protector.patch
- chromium-media-no-sse-r0.patch)
-sha256sums=('270be138d499c6c2092644af69acab8310cb05c3d06c3afe7891e488c29b020f'
- '964fe3a5ec56f2505649aba00f900abe4205674b7fdaa16772647d347173bb01'
- '09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
- 'c53bfc4db9dde684fbaed6a4bbecb207e3e7a0a2703233426fe076a6d3c557f3'
- '9c5e0803904d1a0e71ab7444c92a7046a34a9518eeba7a70f2eec7abecb8bf4e'
- '59e732880314333d6e9acf6ac99de467c98e8a92aa5c5292ae808a805e0f8d76'
- '71751bf5913da1eec3c88c433044224c869b0abd5a29172cf239bddbb4eff761')
-
-build() {
- cd "$srcdir/chromium-$pkgver"
-
- # Fix build with gcc 4.6
- # http://code.google.com/p/chromium/issues/detail?id=80071
- patch -Np0 -i "$srcdir/gcc-4.6.patch"
-
- # Filter -fstack-protector out of cflags for nacl_helper_bootstrap
- # http://code.google.com/p/chromium/issues/detail?id=104569
- patch -d native_client -Np1 -i \
- "$srcdir/nacl-cflags-remove-fstack-protector.patch"
-
- # Remove unconditional use of SSE3 (patch from Gentoo)
- patch -Np0 -i "$srcdir/chromium-media-no-sse-r0.patch"
-
- # Use Python 2
- find . -type f -exec sed -i -r \
- -e 's|/usr/bin/python$|&2|g' \
- -e 's|(/usr/bin/python2)\.4$|\1|g' \
- {} +
- # There are still a lot of relative calls which need a workaround
- mkdir "$srcdir/python2-path"
- ln -s /usr/bin/python2 "$srcdir/python2-path/python"
- export PATH="$srcdir/python2-path:$PATH"
-
- pushd "$srcdir/nacl_sdk"
- ./naclsdk update pepper_16
- popd
-
- ln -s "$srcdir/nacl_sdk/pepper_16/toolchain/linux_x86_newlib" \
- native_client/toolchain/linux_x86_newlib
-
- # We need to disable system_ssl until "next protocol negotiation" support is
- # available in our nss package.
- # (See https://bugzilla.mozilla.org/show_bug.cgi?id=547312)
-
- # CFLAGS are passed through release_extra_cflags below
- export -n CFLAGS CXXFLAGS
-
- build/gyp_chromium -f make build/all.gyp --depth=. \
- -Dno_strict_aliasing=1 \
- -Dwerror= \
- -Dlinux_sandbox_path=/usr/lib/chromium/chromium-sandbox \
- -Dlinux_strip_binary=1 \
- -Drelease_extra_cflags="$CFLAGS" \
- -Dffmpeg_branding=Chrome \
- -Dproprietary_codecs=1 \
- -Duse_system_bzip2=1 \
- -Duse_system_ffmpeg=0 \
- -Duse_system_libevent=1 \
- -Duse_system_libjpeg=0 \
- -Duse_system_libpng=1 \
- -Duse_system_libxml=0 \
- -Duse_system_ssl=0 \
- -Duse_system_yasm=1 \
- -Duse_system_zlib=1 \
- -Duse_gconf=0 \
- $([[ $CARCH == i686 ]] && echo '-Ddisable_sse2=1')
-
- make chrome chrome_sandbox BUILDTYPE=Release
-}
-
-package() {
- cd "$srcdir/chromium-$pkgver"
-
- install -D out/Release/chrome ${pkgdir}/usr/lib/chromium/chromium
-
- install -Dm4755 -o root -g root out/Release/chrome_sandbox \
- "$pkgdir/usr/lib/chromium/chromium-sandbox"
-
- cp out/Release/{{chrome,resources}.pak,libffmpegsumo.so} \
- out/Release/nacl_helper{,_bootstrap} \
- out/Release/{libppGoogleNaClPluginChrome.so,nacl_irt_x86_*.nexe} \
- "$pkgdir/usr/lib/chromium/"
-
- # These links are only needed when building with system ffmpeg
- #ln -s /usr/lib/libavcodec.so.52 ${pkgdir}/usr/lib/chromium/
- #ln -s /usr/lib/libavformat.so.52 ${pkgdir}/usr/lib/chromium/
- #ln -s /usr/lib/libavutil.so.50 ${pkgdir}/usr/lib/chromium/
-
- cp -a out/Release/locales out/Release/resources "$pkgdir/usr/lib/chromium/"
-
- find "$pkgdir/usr/lib/chromium/" -name '*.d' -type f -delete
-
- install -Dm644 out/Release/chrome.1 "$pkgdir/usr/share/man/man1/chromium.1"
-
- install -Dm644 "$srcdir/chromium.desktop" \
- "$pkgdir/usr/share/applications/chromium.desktop"
-
- for size in 16 22 24 32 48 64 128 256; do
- install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
- "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
- done
-
- install -D "$srcdir/chromium.sh" "$pkgdir/usr/bin/chromium"
-
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/community/chromium/__changelog b/abs/extra/community/chromium/__changelog
deleted file mode 100644
index 0b5b4c8..0000000
--- a/abs/extra/community/chromium/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-* Add replaces=('firefox' 'firefox-i18n' 'mozplugger') array
-* Add optdepends=('mozplugger-chromium: A Mozilla multimedia plugin for Chromium')
diff --git a/abs/extra/community/chromium/chromium-media-no-sse-r0.patch b/abs/extra/community/chromium/chromium-media-no-sse-r0.patch
deleted file mode 100644
index 07cda2d..0000000
--- a/abs/extra/community/chromium/chromium-media-no-sse-r0.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- media/media.gyp.orig 2012-02-02 10:03:41.000000000 +0100
-+++ media/media.gyp 2012-02-02 10:04:09.000000000 +0100
-@@ -467,14 +467,6 @@
- [ 'os_posix == 1 and OS != "mac" and OS != "android"', {
- 'cflags': [
- '-msse2',
-- '-msse3',
-- '-mssse3',
-- ],
-- }],
-- [ 'OS == "openbsd"', {
-- # OpenBSD's gcc (4.2.1) does not support -mssse3
-- 'cflags!': [
-- '-mssse3',
- ],
- }],
- [ 'OS == "mac"', {
diff --git a/abs/extra/community/chromium/chromium.desktop b/abs/extra/community/chromium/chromium.desktop
deleted file mode 100644
index 18446d4..0000000
--- a/abs/extra/community/chromium/chromium.desktop
+++ /dev/null
@@ -1,113 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=Chromium
-# Only KDE 4 seems to use GenericName, so we reuse the KDE strings.
-# From Ubuntu's language-pack-kde-XX-base packages, version 9.04-20090413.
-GenericName=Web Browser
-GenericName[ar]=متصفح الشبكة
-GenericName[bg]=Уеб браузър
-GenericName[ca]=Navegador web
-GenericName[cs]=WWW prohlížeč
-GenericName[da]=Browser
-GenericName[de]=Web-Browser
-GenericName[el]=Περιηγητής ιστού
-GenericName[en_GB]=Web Browser
-GenericName[es]=Navegador web
-GenericName[et]=Veebibrauser
-GenericName[fi]=WWW-selain
-GenericName[fr]=Navigateur Web
-GenericName[gu]=વેબ બ્રાઉઝર
-GenericName[he]=דפדפן אינטרנט
-GenericName[hi]=वेब ब्राउज़र
-GenericName[hu]=Webböngésző
-GenericName[it]=Browser Web
-GenericName[ja]=ウェブブラウザ
-GenericName[kn]=ಜಾಲ ವೀಕ್ಷಕ
-GenericName[ko]=웹 브라우저
-GenericName[lt]=Žiniatinklio naršyklė
-GenericName[lv]=Tīmekļa pārlūks
-GenericName[ml]=വെബ് ബ്രൌസര്‍
-GenericName[mr]=वेब ब्राऊजर
-GenericName[nb]=Nettleser
-GenericName[nl]=Webbrowser
-GenericName[pl]=Przeglądarka WWW
-GenericName[pt]=Navegador Web
-GenericName[pt_BR]=Navegador da Internet
-GenericName[ro]=Navigator de Internet
-GenericName[ru]=Веб-браузер
-GenericName[sl]=Spletni brskalnik
-GenericName[sv]=Webbläsare
-GenericName[ta]=இணைய உலாவி
-GenericName[th]=เว็บเบราว์เซอร์
-GenericName[tr]=Web Tarayıcı
-GenericName[uk]=Навігатор Тенет
-GenericName[zh_CN]=网页浏览器
-GenericName[zh_HK]=網頁瀏覽器
-GenericName[zh_TW]=網頁瀏覽器
-# Not translated in KDE, from Epiphany 2.26.1-0ubuntu1.
-GenericName[bn]=ওয়েব ব্রাউজার
-GenericName[fil]=Web Browser
-GenericName[hr]=Web preglednik
-GenericName[id]=Browser Web
-GenericName[or]=ଓ୍ବେବ ବ୍ରାଉଜର
-GenericName[sk]=WWW prehliadač
-GenericName[sr]=Интернет прегледник
-GenericName[te]=మహాతల అన్వేషి
-GenericName[vi]=Bộ duyệt Web
-# Gnome and KDE 3 uses Comment.
-Comment=Access the Internet
-Comment[ar]=الدخول إلى الإنترنت
-Comment[bg]=Достъп до интернет
-Comment[bn]=ইন্টারনেটটি অ্যাক্সেস করুন
-Comment[ca]=Accedeix a Internet
-Comment[cs]=Přístup k internetu
-Comment[da]=Få adgang til internettet
-Comment[de]=Internetzugriff
-Comment[el]=Πρόσβαση στο Διαδίκτυο
-Comment[en_GB]=Access the Internet
-Comment[es]=Accede a Internet.
-Comment[et]=Pääs Internetti
-Comment[fi]=Käytä internetiä
-Comment[fil]=I-access ang Internet
-Comment[fr]=Accéder à Internet
-Comment[gu]=ઇંટરનેટ ઍક્સેસ કરો
-Comment[he]=גישה אל האינטרנט
-Comment[hi]=इंटरनेट तक पहुंच स्थापित करें
-Comment[hr]=Pristup Internetu
-Comment[hu]=Internetelérés
-Comment[id]=Akses Internet
-Comment[it]=Accesso a Internet
-Comment[ja]=インターネットにアクセス
-Comment[kn]=ಇಂಟರ್ನೆಟ್ ಅನ್ನು ಪ್ರವೇಶಿಸಿ
-Comment[ko]=인터넷 연결
-Comment[lt]=Interneto prieiga
-Comment[lv]=Piekļūt internetam
-Comment[ml]=ഇന്റര്‍‌നെറ്റ് ആക്‌സസ് ചെയ്യുക
-Comment[mr]=इंटरनेटमध्ये प्रवेश करा
-Comment[nb]=Gå til Internett
-Comment[nl]=Verbinding maken met internet
-Comment[or]=ଇଣ୍ଟର୍ନେଟ୍ ପ୍ରବେଶ କରନ୍ତୁ
-Comment[pl]=Skorzystaj z internetu
-Comment[pt]=Aceder à Internet
-Comment[pt_BR]=Acessar a internet
-Comment[ro]=Accesaţi Internetul
-Comment[ru]=Доступ в Интернет
-Comment[sk]=Prístup do siete Internet
-Comment[sl]=Dostop do interneta
-Comment[sr]=Приступите Интернету
-Comment[sv]=Gå ut på Internet
-Comment[ta]=இணையத்தை அணுகுதல்
-Comment[te]=ఇంటర్నెట్‌ను ఆక్సెస్ చెయ్యండి
-Comment[th]=เข้าถึงอินเทอร์เน็ต
-Comment[tr]=İnternet'e erişin
-Comment[uk]=Доступ до Інтернету
-Comment[vi]=Truy cập Internet
-Comment[zh_CN]=访问互联网
-Comment[zh_HK]=連線到網際網路
-Comment[zh_TW]=連線到網際網路
-Exec=chromium %U
-Terminal=false
-Icon=chromium
-Type=Application
-Categories=GTK;Network;WebBrowser;
-MimeType=text/html;text/xml;application/xhtml+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
diff --git a/abs/extra/community/chromium/chromium.install b/abs/extra/community/chromium/chromium.install
deleted file mode 100644
index d43ea7c..0000000
--- a/abs/extra/community/chromium/chromium.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- xdg-icon-resource forceupdate --theme hicolor &>/dev/null
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
diff --git a/abs/extra/community/chromium/chromium.sh b/abs/extra/community/chromium/chromium.sh
deleted file mode 100755
index e1c3388..0000000
--- a/abs/extra/community/chromium/chromium.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-export CHROME_WRAPPER=/usr/lib/chromium/chromium
-export CHROME_DESKTOP=chromium.desktop
-exec /usr/lib/chromium/chromium "$@"
diff --git a/abs/extra/community/chromium/gcc-4.6.patch b/abs/extra/community/chromium/gcc-4.6.patch
deleted file mode 100644
index b5e61dc..0000000
--- a/abs/extra/community/chromium/gcc-4.6.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-diff -u -r chrome/browser/search_engines/template_url_prepopulate_data.h chrome/browser/search_engines/template_url_prepopulate_data.h
---- chrome/browser/search_engines/template_url_prepopulate_data.h 2011-04-13 13:23:41.000000000 +0400
-+++ chrome/browser/search_engines/template_url_prepopulate_data.h 2011-04-20 19:32:58.000000000 +0400
-@@ -7,6 +7,7 @@
- #pragma once
-
- #include <vector>
-+#include <cstddef>
-
- class GURL;
- class PrefService;
-diff -u -r gpu/command_buffer/common/types.h gpu/command_buffer/common/types.h
---- gpu/command_buffer/common/types.h 2011-04-13 13:22:57.000000000 +0400
-+++ gpu/command_buffer/common/types.h 2011-04-20 19:32:58.000000000 +0400
-@@ -11,6 +11,7 @@
- #include <stdint.h>
- #endif
- #include <string>
-+#include <cstddef>
-
- typedef signed char schar;
- typedef signed char int8;
-diff -u -r ppapi/cpp/paint_aggregator.h ppapi/cpp/paint_aggregator.h
---- ppapi/cpp/paint_aggregator.h 2011-04-13 13:22:58.000000000 +0400
-+++ ppapi/cpp/paint_aggregator.h 2011-04-20 20:11:44.000000000 +0400
-@@ -9,6 +9,7 @@
-
- #include "ppapi/cpp/point.h"
- #include "ppapi/cpp/rect.h"
-+#include <cstddef>
-
- namespace pp {
-
-diff -u -r third_party/ots/src/os2.cc third_party/ots/src/os2.cc
---- third_party/ots/src/os2.cc 2011-04-13 13:24:06.000000000 +0400
-+++ third_party/ots/src/os2.cc 2011-04-20 19:45:44.000000000 +0400
-@@ -5,6 +5,7 @@
- #include "os2.h"
-
- #include "head.h"
-+#include <cstddef>
-
- // OS/2 - OS/2 and Windows Metrics
- // http://www.microsoft.com/opentype/otspec/os2.htm
-diff -u -r third_party/tcmalloc/chromium/src/base/stl_allocator.h third_party/tcmalloc/chromium/src/base/stl_allocator.h
---- third_party/tcmalloc/chromium/src/base/stl_allocator.h 2011-04-13 13:23:04.000000000 +0400
-+++ third_party/tcmalloc/chromium/src/base/stl_allocator.h 2011-04-20 19:32:58.000000000 +0400
-@@ -38,6 +38,7 @@
- #include <config.h>
-
- #include <limits>
-+#include <cstddef>
-
- #include "base/basictypes.h"
- #include "base/logging.h"
-diff -u -r third_party/tcmalloc/chromium/src/base/vdso_support.h third_party/tcmalloc/chromium/src/base/vdso_support.h
---- third_party/tcmalloc/chromium/src/base/vdso_support.h 2011-04-13 13:23:04.000000000 +0400
-+++ third_party/tcmalloc/chromium/src/base/vdso_support.h 2011-04-20 19:32:58.000000000 +0400
-@@ -37,6 +37,7 @@
-
- #define HAVE_VDSO_SUPPORT 1
-
-+#include <cstddef>
- #include <stdlib.h> // for NULL
- #include <link.h> // for ElfW
- #include "base/basictypes.h"
-diff -u -r third_party/tcmalloc/chromium/src/common.cc third_party/tcmalloc/chromium/src/common.cc
---- third_party/tcmalloc/chromium/src/common.cc 2011-04-13 13:23:04.000000000 +0400
-+++ third_party/tcmalloc/chromium/src/common.cc 2011-04-20 19:32:58.000000000 +0400
-@@ -34,6 +34,7 @@
- #include "config.h"
- #include "common.h"
- #include "system-alloc.h"
-+#include <cstddef>
-
- namespace tcmalloc {
-
-diff -u -r third_party/tcmalloc/chromium/src/symbolize.h third_party/tcmalloc/chromium/src/symbolize.h
---- third_party/tcmalloc/chromium/src/symbolize.h 2011-04-13 13:23:04.000000000 +0400
-+++ third_party/tcmalloc/chromium/src/symbolize.h 2011-04-20 19:32:58.000000000 +0400
-@@ -38,6 +38,7 @@
- #include <stdint.h> // for uintptr_t
- #endif
- #include <map>
-+#include <cstddef>
-
- using std::map;
-
-diff -u -r ui/gfx/codec/jpeg_codec.h ui/gfx/codec/jpeg_codec.h
---- ui/gfx/codec/jpeg_codec.h 2011-04-13 13:23:45.000000000 +0400
-+++ ui/gfx/codec/jpeg_codec.h 2011-04-20 19:32:58.000000000 +0400
-@@ -7,6 +7,7 @@
- #pragma once
-
- #include <vector>
-+#include <cstddef>
-
- class SkBitmap;
-
diff --git a/abs/extra/community/chromium/nacl-cflags-remove-fstack-protector.patch b/abs/extra/community/chromium/nacl-cflags-remove-fstack-protector.patch
deleted file mode 100644
index 0e4f7cf..0000000
--- a/abs/extra/community/chromium/nacl-cflags-remove-fstack-protector.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: src/trusted/service_runtime/linux/nacl_bootstrap.gyp
-diff --git a/src/trusted/service_runtime/linux/nacl_bootstrap.gyp b/src/trusted/service_runtime/linux/nacl_bootstrap.gyp
-index 66d95ca4dc98653219c965b899dbd5ad35d2960c..083e3fdd24ff4562d2037f8d17a06540e05357b8 100644
---- a/src/trusted/service_runtime/linux/nacl_bootstrap.gyp
-+++ b/src/trusted/service_runtime/linux/nacl_bootstrap.gyp
-@@ -84,6 +84,11 @@
- '-fasan',
- '-faddress-sanitizer',
- '-w',
-+ # We filter these out because release_extra_cflags or another
-+ # such thing might be adding them in, and those options wind up
-+ # coming after the -fno-stack-protector we added above.
-+ '-fstack-protector',
-+ '-fstack-protector-all',
- ],
- 'conditions': [
- ['clang==1', {