summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/js/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/js/PKGBUILD')
-rw-r--r--abs/extra/community/js/PKGBUILD60
1 files changed, 26 insertions, 34 deletions
diff --git a/abs/extra/community/js/PKGBUILD b/abs/extra/community/js/PKGBUILD
index 35db2db..d55295c 100644
--- a/abs/extra/community/js/PKGBUILD
+++ b/abs/extra/community/js/PKGBUILD
@@ -1,39 +1,31 @@
-# $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
pkgname=js
-pkgver=1.8.5
-pkgrel=3
-pkgdesc="JavaScript interpreter and libraries"
-arch=(i686 x86_64)
-url="https://developer.mozilla.org/En/SpiderMonkey/1.8.5"
-license=('GPL2')
-depends=('nspr' 'gcc-libs')
-makedepends=('python2' 'zip')
+pkgver=1.7.0
+pkgrel=1
+epoch=1
+pkgdesc="Mozilla's C implementation of JavaScript."
+arch=("i686" "x86_64")
+url="http://www.mozilla.org/js/spidermonkey/"
+license=('MPL' 'GPL' 'LGPL')
+depends=('nspr')
+options=('!makeflags')
replaces=('spidermonkey')
conflicts=('spidermonkey')
-source=(http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
- js185-destdir.patch)
-md5sums=('a4574365938222adca0a6bd33329cb32'
- '364834a8391888642c53d78c3a949d94')
-build() {
- cd "$srcdir/$pkgname-$pkgver/js/src"
-
- patch -Np0 -i $srcdir/js185-destdir.patch
-
- ./configure --prefix=/usr --with-system-nspr \
- --enable-threadsafe
-
- make
-}
+source=("http://ftp.mozilla.org/pub/mozilla.org/js/js-$pkgver.tar.gz" \
+ "spidermonkey-1.7-threadsafe.patch" "spidermonkey-Makefile.patch")
+md5sums=('5571134c3863686b623ebe4e6b1f6fe6'
+ 'b2ef9be017b6aa1857354b5223975a4f'
+ '161d4c0f2c604d15cba29dab60b1f7a7')
-package() {
- cd "$srcdir/$pkgname-$pkgver/js/src"
- make DESTDIR="$pkgdir" install
-
- install -m 0755 shell/js ${pkgdir}/usr/bin
-
- #cleanup
- rm -f "${pkgdir}/usr/lib/libmozjs185-1.0.a"
+build() {
+ cd "$srcdir/js/src"
+ patch -p0 < "$srcdir/spidermonkey-Makefile.patch" || return 1
+ sed -i 's|include|include/js|' rules.mk || return 1
+ # fix for the lib location
+ [ "$CARCH" = "x86_64" ] && (sed -i -e "s:lib64:lib:g" config.mk || return 1)
+ # patch Makefile for threadsafe support with native nspr
+ patch -p2 -i "$srcdir/spidermonkey-1.7-threadsafe.patch" || return 1
+ # FS#16673
+ export CFLAGS="${CFLAGS} -DJS_C_STRINGS_ARE_UTF8"
+ # build - threadsafe
+ make -f Makefile.ref BUILD_OPT=1 JS_THREADSAFE=1 DIST="$pkgdir/usr" all export || return 1
}
-
-# vim:set ts=2 sw=2 et: