summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/zvbi
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/zvbi')
-rw-r--r--abs/extra/community/zvbi/PKGBUILD25
-rw-r--r--abs/extra/community/zvbi/fix-includes.patch36
2 files changed, 0 insertions, 61 deletions
diff --git a/abs/extra/community/zvbi/PKGBUILD b/abs/extra/community/zvbi/PKGBUILD
deleted file mode 100644
index 9bc150c..0000000
--- a/abs/extra/community/zvbi/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# $Id$
-# Maintainer:
-# Contributor: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: dorphell <dorphell@archlinux.org>
-pkgname=zvbi
-pkgver=0.2.33
-pkgrel=3
-pkgdesc="VBI capture and decoding library"
-url="http://zapping.sourceforge.net/cgi-bin/view/ZVBI/WebHome"
-arch=(i686 x86_64)
-depends=('libpng' 'libx11')
-license=('GPL')
-options=('!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/zapping/${pkgname}-${pkgver}.tar.bz2
- fix-includes.patch)
-md5sums=('1741a6045c3eedfb611d645f2da69ac8'
- '38766bc59e1571133d0399f0102da653')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/fix-includes.patch"
- ./configure --prefix=/usr --disable-static --mandir=/usr/share/man
- make
- make DESTDIR="${pkgdir}" install
-}
diff --git a/abs/extra/community/zvbi/fix-includes.patch b/abs/extra/community/zvbi/fix-includes.patch
deleted file mode 100644
index 2825264..0000000
--- a/abs/extra/community/zvbi/fix-includes.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Add proper #includes so that we do not get undef errors to S_ISCHR
-during linking.
-
-Signed-off-by: Alex Chiang <achiang@canonical.com>
----
---- zvbi-0.2.33.orig/src/io-dvb.c
-+++ zvbi-0.2.33/src/io-dvb.c
-@@ -29,6 +29,8 @@
- #include <errno.h>
- #include <sys/select.h>
- #include <sys/ioctl.h>
-+#include <sys/types.h>
-+#include <sys/stat.h>
-
- #ifndef HAVE_S64_U64
- /* Linux 2.6.x asm/types.h defines __s64 and __u64 only
---- zvbi-0.2.33.orig/src/io-v4l.c
-+++ zvbi-0.2.33/src/io-v4l.c
-@@ -42,6 +42,7 @@ static const char rcsid [] =
- #include <assert.h>
- #include <sys/time.h> /* timeval */
- #include <sys/types.h> /* fd_set, uid_t */
-+#include <sys/stat.h> /* S_ISCHR */
- #include <sys/ioctl.h> /* for (_)videodev.h */
- #include <pthread.h>
-
---- zvbi-0.2.33.orig/contrib/ntsc-cc.c
-+++ zvbi-0.2.33/contrib/ntsc-cc.c
-@@ -34,6 +34,7 @@
- #include <locale.h>
- #include <sys/ioctl.h>
- #include <sys/types.h>
-+#include <sys/stat.h>
- #include <sys/time.h>
- #ifdef HAVE_GETOPT_LONG
- # include <getopt.h>