summaryrefslogtreecommitdiffstats
path: root/abs/extra/conky/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/conky/PKGBUILD')
-rw-r--r--abs/extra/conky/PKGBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/abs/extra/conky/PKGBUILD b/abs/extra/conky/PKGBUILD
deleted file mode 100644
index d542937..0000000
--- a/abs/extra/conky/PKGBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# $Id$
-# Contributor: Giovanni Scafora <giovanni@archlinux.org>
-# Contributor: James Rayner <james@archlinux.org>
-# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
-
-pkgname=conky
-pkgver=1.8.1
-pkgrel=3
-pkgdesc='An advanced, highly configurable system monitor for X based on torsmo'
-arch=('i686' 'x86_64')
-url='http://conky.sourceforge.net/'
-license=('custom')
-replaces=('torsmo')
-makedepends=('pkg-config')
-depends=('alsa-lib' 'libxml2' 'curl' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2')
-backup=('etc/conky/conky.conf' 'etc/conky/conky_no_x11.conf')
-source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- 'current-power.patch')
-
-sha1sums=('06bbe9b7eed8603fa7a971b27c5c61f38424ac6f'
- '2eeef0cc5a0b612826b2a7f0b43b7a3b7e10bf0b')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- patch -p1 < ../current-power.patch # See FS#21984
-
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --enable-ibm \
- --enable-curl \
- --enable-rss \
- --enable-weather-xoap \
- --enable-imlib2 \
- --disable-lua \
- --enable-wlan \
-
- make
-}
-
-package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}