summaryrefslogtreecommitdiffstats
path: root/abs/extra/gd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/gd/PKGBUILD')
-rw-r--r--abs/extra/gd/PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/abs/extra/gd/PKGBUILD b/abs/extra/gd/PKGBUILD
index f0337ba..7d0d9b0 100644
--- a/abs/extra/gd/PKGBUILD
+++ b/abs/extra/gd/PKGBUILD
@@ -1,21 +1,21 @@
-# $Id$
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=gd
-pkgver=2.2.5
+pkgver=2.3.0
pkgrel=1
pkgdesc="Library for the dynamic creation of images by programmers"
arch=('x86_64')
-url="http://www.libgd.org/"
+url="https://libgd.github.io/"
license=('custom')
depends=('fontconfig' 'libxpm' 'libwebp')
optdepends=('perl: bdftogd script')
checkdepends=('ttf-liberation')
source=("https://github.com/libgd/libgd/releases/download/gd-${pkgver}/libgd-${pkgver}.tar.xz")
-md5sums=('8d8d6a6189513ecee6e893b1fb109bf8')
+sha1sums=('ec75c84aa6326a7ade3302d5c18471f440b2ca1e')
build() {
cd libgd-${pkgver}
+
./configure \
--prefix=/usr \
--disable-rpath
@@ -24,12 +24,13 @@ build() {
check() {
cd libgd-${pkgver}
- # see https://github.com/libgd/libgd/issues/302
- [[ ${CARCH} == 'i686' ]] || FREETYPE_PROPERTIES='truetype:interpreter-version=35' make check
+
+ make check
}
package() {
cd libgd-${pkgver}
+
make DESTDIR="${pkgdir}" install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}