summaryrefslogtreecommitdiffstats
path: root/abs/extra/glances/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/glances/PKGBUILD')
-rw-r--r--abs/extra/glances/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/extra/glances/PKGBUILD b/abs/extra/glances/PKGBUILD
new file mode 100644
index 0000000..16562fa
--- /dev/null
+++ b/abs/extra/glances/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+
+pkgname=glances
+pkgver=3.0.2
+pkgrel=1
+pkgdesc='CLI curses-based monitoring tool'
+arch=('any')
+url='https://github.com/nicolargo/glances'
+license=('LGPL')
+makedepends=('git')
+depends=('python' 'python-psutil' 'python-setuptools')
+optdepends=('hddtemp: HDD temperature monitoring support'
+ 'python-bottle: web server support'
+ 'python-docker: for the Docker monitoring support'
+ 'python-matplotlib: for graphical/chart support'
+ 'python-netifaces: for the IP plugin'
+ 'python-zeroconf: for the autodiscover mode')
+source=("https://github.com/nicolargo/glances/archive/v${pkgver}.tar.gz"
+ 'glances.service')
+sha512sums=('f86aa285e803c38a852eca6782642c0a854fdb14ae938e22482288d39045d2e6b42040409f5ba323784d3bd9a32386b90964b074d5a65cd03d904bde0ec941d3'
+ '49f0d185a37a5c5837e5beb463770c943ede40b2f1b8405e338129e897e97d9fc58373a8586fabc506266e6343cfea3c91b9787ac6832cc97a1ab63d6ad058d4')
+
+package() {
+ cd "glances-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ install -Dm644 "${srcdir}"/glances.service \
+ "${pkgdir}"/usr/lib/systemd/system/glances.service
+}
+
+# vim:set ts=2 sw=2 et: