summaryrefslogtreecommitdiffstats
path: root/abs/extra/gtk3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/gtk3/PKGBUILD')
-rw-r--r--abs/extra/gtk3/PKGBUILD106
1 files changed, 57 insertions, 49 deletions
diff --git a/abs/extra/gtk3/PKGBUILD b/abs/extra/gtk3/PKGBUILD
index 15dc342..bd062d0 100644
--- a/abs/extra/gtk3/PKGBUILD
+++ b/abs/extra/gtk3/PKGBUILD
@@ -1,74 +1,82 @@
-# $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgbase=gtk3
pkgname=(gtk3 gtk-update-icon-cache)
-pkgver=3.18.6
-pkgrel=2
+pkgver=3.24.4+15+g80b5024239
+pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit"
-arch=(i686 x86_64)
-url="http://www.gtk.org/"
-depends=(atk cairo libcups libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
- libxcomposite libxdamage pango shared-mime-info colord at-spi2-atk wayland libxkbcommon
- adwaita-icon-theme json-glib rest librsvg)
-makedepends=(gobject-introspection libcanberra)
+arch=(x86_64)
+url="https://www.gtk.org/"
+depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 dconf
+ libxcomposite libxdamage pango shared-mime-info at-spi2-atk wayland libxkbcommon
+ adwaita-icon-theme json-glib librsvg wayland-protocols desktop-file-utils mesa
+ cantarell-fonts colord rest libcups libcanberra)
+makedepends=(gobject-introspection gtk-doc git glib2-docs sassc)
license=(LGPL)
-source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
- 0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
- 0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
- settings.ini)
-sha256sums=('78cabf0fd5a662f8723f62d5ac633072c76c557c1d700454c9c3deaa37e441ef'
- '0402c3b7801810beb0f24ad20e4fb2eb7519cf3984f39e093a6e2752a0f7d9de'
- '94722b06284e76f628fc8933617ac19c14f6775a5250fe3c382defab63d7b10e'
- '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202')
+_commit=80b5024239ee358ede8203666dfe9ea790a29b70 # gtk-3-24
+source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
+ settings.ini
+ gtk-query-immodules-3.0.hook
+ gtk-update-icon-cache.hook
+ gtk-update-icon-cache.script)
+sha256sums=('SKIP'
+ '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
+ 'de46e5514ff39a7a65e01e485e874775ab1c0ad20b8e94ada43f4a6af1370845'
+ '496064a9dd6214bd58f689dd817dbdc4d7f17d42a8c9940a87018c3f829ce308'
+ 'f1d3a0dbfd82f7339301abecdbe5f024337919b48bd0e09296bb0e79863b2541')
-prepare() {
- cd gtk+-$pkgver
+pkgver() {
+ cd gtk
+ git describe --tags | sed 's/-/+/g'
+}
- # Fix zoom in/out cursors in GTK3 builds of Firefox
- # https://bugzilla.gnome.org/show_bug.cgi?id=760141
- patch -Np1 -i ../0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
- patch -Np1 -i ../0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
+prepare() {
+ cd gtk
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "gtk+-$pkgver"
+ cd gtk
- CXX=/bin/false ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-schemas-compile \
- --enable-x11-backend \
- --enable-broadway-backend \
- --enable-wayland-backend
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-schemas-compile \
+ --enable-x11-backend \
+ --enable-broadway-backend \
+ --enable-wayland-backend \
+ --disable-gtk-doc
- #https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ make
}
package_gtk3() {
- depends+=(gtk-update-icon-cache)
- optdepends=('libcanberra: gtk3-widget-factory demo')
- install=gtk3.install
+ depends+=(gtk-update-icon-cache)
+ provides=(gtk3-print-backends)
+ conflicts=(gtk3-print-backends)
+ replaces=("gtk3-print-backends<=3.22.26-1")
+ install=gtk3.install
+
+ DESTDIR="$pkgdir" make -C gtk install
- cd "gtk+-$pkgver"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
+ install -Dt "$pkgdir/usr/share/gtk-3.0" -m644 settings.ini
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-query-immodules-3.0.hook
- # split this out to use with gtk2 too
- rm "$pkgdir/usr/bin/gtk-update-icon-cache"
+ # split this out to use with gtk2 too
+ mv "$pkgdir/usr/bin/gtk-update-icon-cache" "$srcdir"
}
package_gtk-update-icon-cache() {
- pkgdesc="GTK+ icon cache updater"
- depends=(gdk-pixbuf2 hicolor-icon-theme)
- install=gtk-update-icon-cache.install
+ pkgdesc="GTK+ icon cache updater"
+ depends=(gdk-pixbuf2 librsvg hicolor-icon-theme)
- cd gtk+-$pkgver/gtk
- install -Dm755 gtk-update-icon-cache "$pkgdir/usr/bin/gtk-update-icon-cache"
+ install -Dt "$pkgdir/usr/bin" gtk-update-icon-cache
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-update-icon-cache.hook
+ install -D gtk-update-icon-cache.script "$pkgdir/usr/share/libalpm/scripts/gtk-update-icon-cache"
}
-# vim:set et sw=4:
+# vim:set ts=2 sw=2 et: