summaryrefslogtreecommitdiffstats
path: root/abs/extra/guile/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/guile/PKGBUILD')
-rw-r--r--abs/extra/guile/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/guile/PKGBUILD b/abs/extra/guile/PKGBUILD
new file mode 100644
index 0000000..3721e3f
--- /dev/null
+++ b/abs/extra/guile/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 23033 2009-01-01 17:11:52Z jgc $
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=guile
+pkgver=1.8.6
+pkgrel=1
+pkgdesc="Guile is a portable, embeddable Scheme implementation written in C"
+url="http://www.gnu.org/software/guile/"
+arch=(i686 x86_64)
+license=('GPL')
+depends=('gmp' 'libtool' 'ncurses>=5.6-7' 'texinfo')
+install=guile.install
+source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+options=('!libtool')
+md5sums=('9e23d3dbea0e89bab8a9acc6880150de')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-networking \
+ --disable-error-on-warning || return 1
+ make LDFLAGS+="-lpthread" || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ rm -f "${pkgdir}/usr/share/info/dir"
+ gzip "${pkgdir}/usr/share/info"/* || return 1
+}