summaryrefslogtreecommitdiffstats
path: root/abs/extra/libaio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libaio/PKGBUILD')
-rw-r--r--abs/extra/libaio/PKGBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/abs/extra/libaio/PKGBUILD b/abs/extra/libaio/PKGBUILD
deleted file mode 100644
index 08d74db..0000000
--- a/abs/extra/libaio/PKGBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# $Id$
-# Maintainer: Bartłomiej Piotrowski <barthalion@gmail.com>
-# Contributor: Thomas S Hatch <thatch45 at gmail dot com>
-
-pkgname=libaio
-pkgver=0.3.110
-pkgrel=1
-pkgdesc="The Linux-native asynchronous I/O facility (aio) library"
-arch=('i686' 'x86_64')
-url="http://lse.sourceforge.net/io/aio.html"
-license=('LGPL')
-source=(http://ftp.de.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz)
-md5sums=('2a35602e43778383e2f4907a4ca39ab8')
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- # AIO library is a thin wrapper around kernel syscalls, it does not use stdlib
- # and other helpers like stack protection libraries
- CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe"
- make
-}
-
-check() {
- cd "$srcdir/$pkgname-$pkgver"
- make partcheck
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- make prefix="$pkgdir/usr" install
-}
-