summaryrefslogtreecommitdiffstats
path: root/abs/extra/libgda
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libgda')
-rw-r--r--abs/extra/libgda/Changelog2
-rw-r--r--abs/extra/libgda/PKGBUILD23
-rw-r--r--abs/extra/libgda/bdb43.patch18
-rw-r--r--abs/extra/libgda/libgda.install16
4 files changed, 59 insertions, 0 deletions
diff --git a/abs/extra/libgda/Changelog b/abs/extra/libgda/Changelog
new file mode 100644
index 0000000..88ba942
--- /dev/null
+++ b/abs/extra/libgda/Changelog
@@ -0,0 +1,2 @@
+4.0.2 5/2/09
+Added path for jni headers in configure.
diff --git a/abs/extra/libgda/PKGBUILD b/abs/extra/libgda/PKGBUILD
new file mode 100644
index 0000000..c4350b7
--- /dev/null
+++ b/abs/extra/libgda/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 36066 2009-04-19 20:31:09Z jgc $
+# Maintainer: tobias <tobias@archlinux.org>
+# Contributor: Tobias Kieslich <tobias@justdreams.de>
+
+pkgname=libgda
+pkgver=4.0.2
+pkgrel=4
+pkgdesc="data abstraction layer; with mysql, pgsql, ldap, xml, sqlite providers"
+arch=(i686 x86_64)
+license=('GPL')
+depends=('glib2>=2.20.1' 'libxslt' 'db>=4.7' 'ncurses>=5.7-2')
+makedepends=('intltool' 'pkgconfig' 'openjdk6')
+options=('!libtool')
+url="http://www.gnome-db.org"
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/4.0/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('cd79f6542cdd9477017b76b5f81c776f')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-static --with-jni=/usr/lib/jvm/java-1.6.0-openjdk/include/ --without-java || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}
diff --git a/abs/extra/libgda/bdb43.patch b/abs/extra/libgda/bdb43.patch
new file mode 100644
index 0000000..3fe6e93
--- /dev/null
+++ b/abs/extra/libgda/bdb43.patch
@@ -0,0 +1,18 @@
+diff -r -u libgda-1.2.0.old/providers/bdb/gda-bdb-recordset.c libgda-1.2.0/providers/bdb/gda-bdb-recordset.c
+--- libgda-1.2.0.old/providers/bdb/gda-bdb-recordset.c 2003-12-17 11:27:02.000000000 +0000
++++ libgda-1.2.0/providers/bdb/gda-bdb-recordset.c 2005-02-19 15:43:12.000000000 +0000
+@@ -227,10 +227,14 @@
+
+ /* get the number of records in the database */
+ ret = dbp->stat (dbp,
++#if BDB_VERSION > 40300
++ NULL,
++#endif
+ &statp,
+ #if BDB_VERSION < 40000
+ NULL,
+ #endif
++
+ 0);
+ if (ret != 0) {
+ gda_connection_add_error (cnc, gda_bdb_make_error (ret));
diff --git a/abs/extra/libgda/libgda.install b/abs/extra/libgda/libgda.install
new file mode 100644
index 0000000..6420004
--- /dev/null
+++ b/abs/extra/libgda/libgda.install
@@ -0,0 +1,16 @@
+post_install() {
+ scrollkeeper-update -q -p var/lib/scrollkeeper
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*