summaryrefslogtreecommitdiffstats
path: root/abs/extra/libproxy
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libproxy')
-rw-r--r--abs/extra/libproxy/PKGBUILD21
-rw-r--r--abs/extra/libproxy/__changelog3
-rw-r--r--abs/extra/libproxy/libproxy-0.4.7-unistd.patch40
3 files changed, 55 insertions, 9 deletions
diff --git a/abs/extra/libproxy/PKGBUILD b/abs/extra/libproxy/PKGBUILD
index 3312aba..9fb8e85 100644
--- a/abs/extra/libproxy/PKGBUILD
+++ b/abs/extra/libproxy/PKGBUILD
@@ -3,22 +3,30 @@
pkgname=libproxy
pkgver=0.4.7
-pkgrel=1
+pkgrel=2
pkgdesc="A library that provides automatic proxy configuration management"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
license=('LGPL')
depends=('gcc-libs')
-optdepends=('kdelibs3: KDE configuration module'
+optdepends=('kdelibs: KDE configuration module'
+ 'networkmanager: NetworkManager configuration module'
'perl: Perl bindings'
'python2: Python bindings')
-makedepends=('cmake' 'automoc4' 'python2' 'kdelibs3' 'perl')
+makedepends=('cmake' 'automoc4' 'python2' 'perl')
url="http://libproxy.googlecode.com"
-source=(http://libproxy.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
+source=(http://libproxy.googlecode.com/files/${pkgname}-${pkgver}.tar.gz
+ libproxy-0.4.7-unistd.patch)
options=('!libtool')
-md5sums=('509e03a488a61cd62bfbaf3ab6a2a7a5')
+md5sums=('509e03a488a61cd62bfbaf3ab6a2a7a5'
+ 'e90c03f296e553ace347b46f4fea3625')
build() {
cd "${srcdir}"
+
+ # Fix build with GCC 4.7 (patch from Fedora)
+ patch -d "${pkgname}-${pkgver}" -Np1 -i \
+ "${srcdir}/libproxy-0.4.7-unistd.patch"
+
mkdir build
cd build
cmake ../${pkgname}-${pkgver} \
@@ -37,4 +45,3 @@ package() {
cd "${srcdir}/build"
make DESTDIR="${pkgdir}" install
}
-
diff --git a/abs/extra/libproxy/__changelog b/abs/extra/libproxy/__changelog
index b61a183..8bc6f71 100644
--- a/abs/extra/libproxy/__changelog
+++ b/abs/extra/libproxy/__changelog
@@ -1,2 +1 @@
-- remove 'networkmanager' and as makedep and optdep. MH
-- change 'kdelibs' dep and optdep to 'kdelibs3' MH
+removed kdelibs -
diff --git a/abs/extra/libproxy/libproxy-0.4.7-unistd.patch b/abs/extra/libproxy/libproxy-0.4.7-unistd.patch
new file mode 100644
index 0000000..803f819
--- /dev/null
+++ b/abs/extra/libproxy/libproxy-0.4.7-unistd.patch
@@ -0,0 +1,40 @@
+--- libproxy-0.4.7/libproxy/url.cpp.orig 2012-02-28 21:05:15.572948027 +0000
++++ libproxy-0.4.7/libproxy/url.cpp 2012-02-28 21:05:45.635937474 +0000
+@@ -27,6 +27,7 @@
+ #define close _close
+ #endif
+ #include <fcntl.h> // For ::open()
++#include <unistd.h> // For ::read() and ::close()
+ #include <cstring> // For memcpy()
+ #include <sstream> // For int/string conversion (using stringstream)
+ #include <cstdio> // For sscanf()
+--- libproxy-0.4.7/libproxy/modules/config_sysconfig.cpp.orig 2012-02-28 21:06:01.552943358 +0000
++++ libproxy-0.4.7/libproxy/modules/config_sysconfig.cpp 2012-02-28 21:11:21.429953982 +0000
+@@ -18,6 +18,7 @@
+ ******************************************************************************/
+
+ #include <sys/stat.h>
++#include <unistd.h>
+ #include <cstdlib>
+ #include <map>
+ #include <fstream>
+--- libproxy-0.4.7/libproxy/modules/pacrunner_mozjs.cpp.orig 2012-02-28 21:06:11.637943033 +0000
++++ libproxy-0.4.7/libproxy/modules/pacrunner_mozjs.cpp 2012-02-28 21:11:46.560961409 +0000
+@@ -17,6 +17,7 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ ******************************************************************************/
+
++#include <unistd.h> // for ::gethostname()
+ #include <cstring> // ?
+
+ #include "../extension_pacrunner.hpp"
+--- libproxy-0.4.7/libproxy/modules/pacrunner_webkit.cpp.orig 2012-02-28 21:06:29.615943614 +0000
++++ libproxy-0.4.7/libproxy/modules/pacrunner_webkit.cpp 2012-02-28 21:12:35.530965553 +0000
+@@ -17,6 +17,7 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ ******************************************************************************/
+
++#include <unistd.h> // for ::gethostname()
+ #include "../extension_pacrunner.hpp"
+ using namespace libproxy;
+