summaryrefslogtreecommitdiffstats
path: root/abs/extra/libtorrent-rasterbar/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libtorrent-rasterbar/PKGBUILD')
-rw-r--r--abs/extra/libtorrent-rasterbar/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/libtorrent-rasterbar/PKGBUILD b/abs/extra/libtorrent-rasterbar/PKGBUILD
new file mode 100644
index 0000000..d1f4910
--- /dev/null
+++ b/abs/extra/libtorrent-rasterbar/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+
+pkgname=libtorrent-rasterbar
+pkgver=0.16.16
+pkgrel=1
+epoch=1
+pkgdesc="A C++ library that aims to be a good alternative to all the other bittorrent implementations around"
+url="http://www.rasterbar.com/products/libtorrent/"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('boost-libs' 'geoip' 'python2')
+makedepends=('boost')
+options=('!emptydirs')
+source=(http://downloads.sourceforge.net/sourceforge/libtorrent/$pkgname-$pkgver.tar.gz)
+sha1sums=('de8faed5cbc09baddb2748cb7b75edd07ab0addc')
+
+build() {
+ cd $pkgname-$pkgver
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
+ --enable-python-binding \
+ --with-libgeoip=system
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}