summaryrefslogtreecommitdiffstats
path: root/abs/extra/libwebkit/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libwebkit/PKGBUILD')
-rw-r--r--abs/extra/libwebkit/PKGBUILD75
1 files changed, 50 insertions, 25 deletions
diff --git a/abs/extra/libwebkit/PKGBUILD b/abs/extra/libwebkit/PKGBUILD
index 1c7705b..93a98cd 100644
--- a/abs/extra/libwebkit/PKGBUILD
+++ b/abs/extra/libwebkit/PKGBUILD
@@ -1,36 +1,61 @@
-# $Id: PKGBUILD 95079 2010-10-14 18:34:57Z andyrtr $
+# $Id: PKGBUILD 157142 2012-04-24 22:33:15Z ibiru $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-pkgname=libwebkit
-pkgver=1.2.5
+pkgbase=libwebkit
+pkgname=(libwebkit libwebkit3)
+pkgver=1.8.1
pkgrel=1
-pkgdesc="an opensource web content engine, derived from KHTML and KJS from KDE"
+pkgdesc="An opensource web content engine"
arch=('i686' 'x86_64')
url="http://webkitgtk.org/"
license=('custom')
-depends=('libxt' 'libxslt' 'sqlite3' 'gtk2' 'icu>=4.4' 'gstreamer0.10-base' 'libsoup' 'enchant')
-makedepends=('gperf' 'gtk-doc' 'gobject-introspection')
-provides=('webkitgtk-svn')
-conflicts=('webkitgtk-svn')
-replaces=('webkitgtk-svn')
-options=('!libtool') # '!makeflags')
-source=(http://webkitgtk.org/webkit-${pkgver}.tar.gz
- introspection.patch)
-md5sums=('09f04985665b9abf6f0d9956f86a6a31'
- 'e7e83312618cb30cc9a1567a21cd0e06')
+depends=('libxt' 'libxslt' 'sqlite' 'icu' 'gstreamer0.10-base' 'libsoup' 'enchant' 'libgl'
+ 'geoclue')
+makedepends=('gperf' 'gobject-introspection' 'python2' 'gtk2' 'gtk3' 'mesa')
+options=('!libtool' '!emptydirs')
+source=(http://webkitgtk.org/releases/webkit-$pkgver.tar.xz webkit.patch)
build() {
- cd "${srcdir}/webkit-${pkgver}"
- patch -Np0 -i "${srcdir}/introspection.patch"
- ./configure --prefix=/usr \
- --enable-video --enable-introspection \
- --with-font-backend=freetype --enable-gtk-doc \
- --enable-jit --with-unicode-backend=icu
- make
+ cd "$srcdir/webkit-$pkgver"
+ patch -Np1 < ../webkit.patch
+ mkdir build-gtk{2,3}
+
+ # clear makeflags: race during introspection.
+ # WebKit*.gir should be created before WebKit*.typelib, but isn't
+ MAKEFLAGS=
+
+ ( cd build-gtk2 && _build --with-gtk=2.0 )
+ ( cd build-gtk3 && _build --with-gtk=3.0 )
+}
+
+_build() {
+ PYTHON=/usr/bin/python2 ../configure --prefix=/usr \
+ --enable-introspection \
+ --with-font-backend=freetype \
+ --with-unicode-backend=icu \
+ --enable-spellcheck "$@"
+ make all stamp-po
}
-package() {
- cd "${srcdir}/webkit-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 WebKit/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+package_libwebkit() {
+ pkgdesc+=" (for GTK2)"
+ depends+=(gtk2)
+
+ cd "$srcdir/webkit-$pkgver/build-gtk2"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../Source/WebKit/LICENSE "$pkgdir/usr/share/licenses/libwebkit/LICENSE"
}
+
+package_libwebkit3() {
+ pkgdesc+=" (for GTK3)"
+ depends+=(gtk3)
+
+ cd "$srcdir/webkit-$pkgver/build-gtk3"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../Source/WebKit/LICENSE "$pkgdir/usr/share/licenses/libwebkit3/LICENSE"
+}
+
+
+
+md5sums=('f2f01b1fdc7262a2eede81ebed0970b2'
+ 'dab90271e918f48ed215648521d5a8a0')