summaryrefslogtreecommitdiffstats
path: root/abs/extra/meson/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/meson/PKGBUILD')
-rw-r--r--abs/extra/meson/PKGBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/abs/extra/meson/PKGBUILD b/abs/extra/meson/PKGBUILD
index dd5e7ef..3796c8c 100644
--- a/abs/extra/meson/PKGBUILD
+++ b/abs/extra/meson/PKGBUILD
@@ -1,37 +1,35 @@
-# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
pkgname=meson
-pkgver=0.49.2
-pkgrel=2
+pkgver=0.55.3
+pkgrel=1
pkgdesc='High productivity build system'
url='https://mesonbuild.com/'
arch=('any')
license=('Apache')
depends=('python-setuptools' 'ninja')
-checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt4' 'qt5-base' 'git' 'cython'
+checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' 'git' 'cython'
'gtkmm3' 'gtest' 'gmock' 'protobuf' 'wxgtk' 'python-gobject' 'gobject-introspection'
'itstool' 'gtk3' 'java-environment=8' 'gtk-doc' 'llvm' 'clang' 'sdl2' 'graphviz'
'doxygen' 'vulkan-validation-layers' 'openssh' 'mercurial' 'gtk-sharp-2' 'qt5-tools'
- 'libwmf' 'dmd' 'valgrind')
+ 'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'nasm' 'gnustep-base' 'libelf'
+ 'python-pytest-xdist' 'python2-setuptools') # 'cuda')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
- 4878.patch
+ skip-test.diff
arch-meson)
-sha512sums=('d07a5dfd699f1e4b00af39c377ec186c91718d9595cb0ab506b4b40c0c63ddd14eccbe8afb446635272c431e2a78032888be0bc8f6064044da53e8c0b5f7be3f'
+sha512sums=('afb0bb25b367e681131d920995124df4b06f6d144ae1a95ebec27be13e06fefbd95840e0287cd1d84bdbb8d9c115b589a833d847c60926f55e0f15749cf66bae'
'SKIP'
- 'ff1326c7b56da98eab615b40e07cba86d6ceee18d29e8b5c57ccf73980a7a466c8e5695cc0b96a36330cd0d51e52b8fed08456ebea6763edb736ae7116be2f4b'
+ 'fd1694e74cfa628bda81b1056061d75fa288e04d72bda733f3667be43cfb21c60f2e89455e4a101a7f6bef5754fe112dc84e18ec7a0807bc791015c34deea347'
'f451f8a7ef9cf1dd724c2ce20bb85a3f1611b87b2e7a17ef0fdbe8ab82a67389f818ea30a5adfe8413143e4eac77ea2e0b8234b5b2466b41a892e2bd0435376c')
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
prepare() {
cd ${pkgname}-${pkgver}
- # https://github.com/mesonbuild/meson/issues/4884
- patch -Np1 -i ../4878.patch
-
- # Succeeds for us?
- mv 'test cases/failing/85 gtest dependency with version' 'test cases/frameworks/'
+ # Our containers do not allow sanitizers to run
+ patch -Np1 -i ../skip-test.diff
}
build() {
@@ -41,11 +39,7 @@ build() {
check() (
cd ${pkgname}-${pkgver}
-
- # set for debug output
- #export MESON_PRINT_TEST_OUTPUT=1
-
- export LC_CTYPE=en_US.UTF-8
+ export LC_CTYPE=en_US.UTF-8 CPPFLAGS= CFLAGS= CXXFLAGS= LDFLAGS=
./run_tests.py
)
@@ -56,6 +50,7 @@ package() {
install -d "${pkgdir}/usr/share/vim/vimfiles"
cp -rt "${pkgdir}/usr/share/vim/vimfiles" data/syntax-highlighting/vim/*/
+ install -Dt "${pkgdir}/usr/share/bash-completion/completions" -m644 data/shell-completions/bash/*
install -Dt "${pkgdir}/usr/share/emacs/site-lisp" -m644 data/syntax-highlighting/emacs/*
install -Dt "${pkgdir}/usr/share/zsh/site-functions" -m644 data/shell-completions/zsh/*