summaryrefslogtreecommitdiffstats
path: root/abs/extra/ninja/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/ninja/PKGBUILD')
-rw-r--r--abs/extra/ninja/PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/abs/extra/ninja/PKGBUILD b/abs/extra/ninja/PKGBUILD
index ba37b3f..bc91cad 100644
--- a/abs/extra/ninja/PKGBUILD
+++ b/abs/extra/ninja/PKGBUILD
@@ -1,20 +1,19 @@
-# $Id$
# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
# Contributor: Filip Brcic <brcha@gna.org>
# Contributor: Mika Fischer <mika.fischer@zoopnet.de>
# Contributor: Gergely Imreh <imrehgATgmailDOTcom>
pkgname=ninja
-pkgver=1.8.2
+pkgver=1.9.0
pkgrel=1
pkgdesc='Small build system with a focus on speed'
-arch=(i686 x86_64)
+arch=(x86_64)
url='https://ninja-build.org/'
license=(Apache)
depends=(gcc-libs)
-makedepends=(python2 re2c emacs)
+makedepends=(python2 re2c emacs-nox)
source=($pkgname-$pkgver.zip::https://github.com/martine/ninja/archive/v$pkgver.zip)
-sha1sums=('7d252d8deeefd6972080f146a528fad76698616c')
+sha1sums=('8dc0fe67796e1c50a00f9542af41021286977bde')
build() {
cd ninja-$pkgver
@@ -28,7 +27,6 @@ check() {
python2 ./configure.py
./ninja ninja_test
- ./ninja_test --gtest_filter=-SubprocessTest.SetWithLots
}
package() {