summaryrefslogtreecommitdiffstats
path: root/abs/extra/openmpi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/openmpi/PKGBUILD')
-rw-r--r--abs/extra/openmpi/PKGBUILD98
1 files changed, 45 insertions, 53 deletions
diff --git a/abs/extra/openmpi/PKGBUILD b/abs/extra/openmpi/PKGBUILD
index d6aa6e1..d94e7d2 100644
--- a/abs/extra/openmpi/PKGBUILD
+++ b/abs/extra/openmpi/PKGBUILD
@@ -1,67 +1,59 @@
-# $Id$
-# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
pkgname=openmpi
-pkgver=1.10.2
-pkgrel=1
+pkgver=4.0.5
+pkgrel=2
pkgdesc='High performance message passing library (MPI)'
-arch=(i686 x86_64)
-url='http://www.open-mpi.org'
-license=(custom)
-depends=(libltdl hwloc)
-makedepends=(inetutils valgrind gcc-fortran)
+url='https://www.open-mpi.org'
+arch=('x86_64')
+license=('custom:OpenMPI')
+depends=('glibc' 'libltdl' 'hwloc' 'openssh' 'zlib' 'libnl' 'perl')
+makedepends=('inetutils' 'valgrind' 'gcc-fortran')
optdepends=('gcc-fortran: fortran support')
-options=(staticlibs)
-source=(http://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${pkgname}-${pkgver}.tar.bz2)
-sha1sums=('03934fc0a2dd0d0d2d0459d714a976eabca938fb')
+options=('staticlibs')
+source=(https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('c58f3863b61d944231077f344fe6b4b8fbb83f3d1bc93ab74640bf3e5acac009')
+b2sums=('9709dc8c251d4f2be14d0ab498c5d0d0e59f95db98fb16d9e84fe3d30af5a8e2f9636bbceaf7ae4086a3312bcd6299f0e9e1ca609d658930a1f5abe1018311e1')
build() {
- cd $pkgname-$pkgver
-
- ./autogen.pl
- ./configure --prefix=/usr \
- --sysconfdir=/etc/${pkgname} \
- --enable-mpi-fortran=all \
- --libdir=/usr/lib/${pkgname} \
- --with-threads=posix \
- --enable-smp-locks \
- --with-valgrind \
- --enable-memchecker \
- --enable-pretty-print-stacktrace \
- --without-slurm \
- --with-hwloc=/usr \
- --with-libltdl=/usr \
- FC=/usr/bin/gfortran \
- LDFLAGS="$LDFLAGS -Wl,-z,noexecstack"
-
- make
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/${pkgname} \
+ --enable-mpi-fortran=all \
+ --libdir=/usr/lib/${pkgname} \
+ --enable-builtin-atomics \
+ --enable-mpi-cxx \
+ --with-valgrind \
+ --enable-memchecker \
+ --enable-pretty-print-stacktrace \
+ --without-slurm \
+ --with-hwloc=/usr \
+ --with-libltdl=/usr \
+ FC=/usr/bin/gfortran \
+ LDFLAGS="${LDFLAGS} -Wl,-z,noexecstack"
+ make
}
check() {
- cd $pkgname-$pkgver
-
- make check
+ cd ${pkgname}-${pkgver}
+ make check
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-
- # FS#28583
- install -d -m 755 "$pkgdir"/usr/lib/pkgconfig
- for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
- ln -sf /usr/lib/openmpi/pkgconfig/$i "$pkgdir"/usr/lib/pkgconfig/
- done
-
- # Openmpi's otfinfo conflicts with the one from texlive
- mv "$pkgdir"/usr/bin/otfinfo{,mpi}
-
- # Remove dangling symlink and useless file
- rm "$pkgdir"/usr/share/vampirtrace/config.log
-
- install -d -m 755 "$pkgdir"/etc/ld.so.conf.d
- echo "/usr/lib/$pkgname" > "$pkgdir"/etc/ld.so.conf.d/$pkgname.conf
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ # FS#28583
+ install -dm 755 "${pkgdir}/usr/lib/pkgconfig"
+ for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
+ ln -sf "/usr/lib/openmpi/pkgconfig/${i}" "${pkgdir}/usr/lib/pkgconfig/"
+ done
+
+ install -dm 755 "${pkgdir}/etc/ld.so.conf.d"
+ echo "/usr/lib/${pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${pkgname}.conf
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+
+# vim: ts=2 sw=2 et: