summaryrefslogtreecommitdiffstats
path: root/abs/extra/postfix/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/postfix/PKGBUILD')
-rw-r--r--abs/extra/postfix/PKGBUILD94
1 files changed, 50 insertions, 44 deletions
diff --git a/abs/extra/postfix/PKGBUILD b/abs/extra/postfix/PKGBUILD
index 159f9eb..86b79f6 100644
--- a/abs/extra/postfix/PKGBUILD
+++ b/abs/extra/postfix/PKGBUILD
@@ -1,52 +1,58 @@
-# $Id: PKGBUILD 70372 2010-02-26 13:35:23Z paul $
+# $Id$
# Contributor: Jeff Brodnax <tullyarcher@bellsouth.net>
-# Maintainer: Paul Mattal <paul@archlinux.org>
+# Contributor: Paul Mattal <paul@archlinux.org>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
pkgname=postfix
-pkgver=2.7.1
+pkgver=2.10.2
pkgrel=1
-pkgdesc="Secure, fast, easy to administer drop in replacement for Sendmail (MTA)"
-arch=('i686' 'x86_64')
+pkgdesc='Fast, easy to administer, secure mail server'
+url='http://www.postfix.org/'
license=('custom')
-depends=('pcre' 'libsasl' 'db>=4.7')
-backup=(etc/postfix/aliases etc/postfix/virtual etc/postfix/relocated \
- etc/postfix/access etc/postfix/header_checks etc/postfix/transport \
- etc/postfix/generic etc/postfix/canonical \
- etc/postfix/main.cf etc/postfix/master.cf)
-install="${pkgname}.install"
+arch=('i686' 'x86_64')
+depends=('pcre' 'libsasl' 'db')
+backup=('etc/postfix/'{access,aliases,canonical,generic,header_checks,main.cf,master.cf,relocated,transport,virtual})
+source=("ftp://ftp.porcupine.org/mirrors/postfix-release/official/${pkgname}-${pkgver}.tar.gz"{,.sig}
+ 'aliases.patch'
+ 'service')
+sha1sums=('4721024784d071c3e663d610db17f8bd99821f3d' 'SKIP'
+ '5fc3de6c7df1e5851a0a379e825148868808318b'
+ 'dd12885d367bebaf0fc9d2e9823a7f82086b6ee9')
+
provides=('smtp-server' 'smtp-forwarder')
-replaces=('postfix-mysql' 'postfix-pgsql')
-conflicts=('postfix-mysql' 'postfix-pgsql' 'smtp-server' 'smtp-forwarder')
-url="http://www.postfix.org/"
-source=(ftp://ftp.porcupine.org/mirrors/postfix-release/official/${pkgname}-${pkgver}.tar.gz \
- ${pkgname}.patch.bz2 \
- ${pkgname})
+conflicts=('smtp-server' 'smtp-forwarder')
+
+install=install
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- make makefiles \
- CCARGS="-DUSE_SASL_AUTH -I/usr/include/sasl \
- -DUSE_CYRUS_SASL \
- -DUSE_TLS" \
- AUXLIBS="-lsasl2 -lssl -lcrypto -llber -lz -lm "
- make OPT="${CFLAGS}" || return 1
-
- sh postfix-install -non-interactive \
- install_root="${pkgdir}" \
- daemon_directory="/usr/lib/${pkgname}" \
- sample_directory="/etc/${pkgname}/sample" \
- manpage_directory="/usr/share/man"
-
- cd ${pkgdir}
- cat ${srcdir}/${pkgname}.patch |patch -Np0 || return 1
- rm -f etc/${pkgname}/main.cf~
-
- cd ${pkgdir}
- mkdir etc/rc.d
- install -m 0755 ${srcdir}/${pkgname} etc/rc.d/${pkgname}
-
- install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make makefiles DEBUG='' CCARGS=' \
+ -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl \
+ -DUSE_TLS \
+ -DDEF_COMMAND_DIR=\"/usr/bin\" \
+ -DDEF_DAEMON_DIR=\"/usr/lib/postfix\" \
+ -DDEF_SENDMAIL_PATH=\"/usr/bin/sendmail\" \
+# -DDEF_README_DIR=\"/usr/share/doc/postfix\" \
+ -DDEF_SAMPLE_DIR=\"/etc/postfix/sample\" \
+ -DDEF_MANPAGE_DIR=\"/usr/share/man\" \
+ ' AUXLIBS=' \
+ -lsasl2 \
+ -lssl -lcrypto \
+ ' OPT="${CFLAGS} ${LDFLAGS}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sh postfix-install -non-interactive install_root="${pkgdir}"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 ../service "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+
+ cd "${pkgdir}"
+ patch -p0 -i "${srcdir}"/aliases.patch
+ sed 's/^\(\$manpage[^:]*\):/\1.gz:/' -i "usr/lib/${pkgname}/postfix-files"
}
-md5sums=('b7a5c3ccd309156a65d6f8d2683d4fa1'
- 'a3c45ff23ef036143711793fcf2478c3'
- 'c847b96f08925f08b0f610468a8e21f6')