summaryrefslogtreecommitdiffstats
path: root/abs/extra/rtmpdump
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/rtmpdump')
-rw-r--r--abs/extra/rtmpdump/PKGBUILD51
1 files changed, 37 insertions, 14 deletions
diff --git a/abs/extra/rtmpdump/PKGBUILD b/abs/extra/rtmpdump/PKGBUILD
index e7432cb..44c322f 100644
--- a/abs/extra/rtmpdump/PKGBUILD
+++ b/abs/extra/rtmpdump/PKGBUILD
@@ -1,29 +1,52 @@
-# $Id: PKGBUILD 202973 2013-12-29 17:17:31Z bpiotrowski $
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# $Id$
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: xduugu
# Contributor: Elis Hughes <elishughes@googlemail.com>
pkgname=rtmpdump
-pkgver=20131205
-pkgrel=1
+pkgver=2.4.r96.fa8646d
+pkgrel=3
+epoch=1
pkgdesc='Tool to download rtmp streams'
-arch=('i686' 'x86_64')
-url='http://rtmpdump.mplayerhq.hu/'
+arch=('x86_64')
+url='https://rtmpdump.mplayerhq.hu/'
license=('GPL2' 'LGPL2.1')
-depends=('openssl')
+depends=('glibc' 'gnutls' 'zlib')
makedepends=('git')
+provides=('librtmp.so')
options=('!makeflags')
-source=(git://git.ffmpeg.org/rtmpdump#commit=dc76f0a8)
+_commit='fa8646d'
+source=("git+https://git.ffmpeg.org/rtmpdump#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd rtmpdump
+
+ _ver_name='2.4'
+ _ver_commit='c28f1bab7822de97353849e7787b59e50bbb1428'
+
+ echo "${_ver_name}.r$(git rev-list --count ${_ver_commit}..HEAD).${_commit}"
+}
build() {
- cd $pkgname
- make
+ cd rtmpdump
+ sed -e 's/^CRYPTO=OPENSSL/#CRYPTO=OPENSSL/' -e 's/#CRYPTO=GNUTLS/CRYPTO=GNUTLS/' -i Makefile -i librtmp/Makefile
+
+ make \
+ OPT="$CFLAGS" \
+ XLDFLAGS="$LDFLAGS"
}
package() {
- cd $pkgname
- make prefix=/usr sbindir=/usr/bin \
- mandir=/usr/share/man DESTDIR="$pkgdir" \
+ cd rtmpdump
+
+ make \
+ prefix='/usr' \
+ sbindir='/usr/bin' \
+ mandir='/usr/share/man' \
+ DESTDIR="${pkgdir}" \
install
}
-md5sums=('SKIP')
+
+# vim: ts=2 sw=2 et: