summaryrefslogtreecommitdiffstats
path: root/abs/extra/swig/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/swig/PKGBUILD')
-rw-r--r--abs/extra/swig/PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/abs/extra/swig/PKGBUILD b/abs/extra/swig/PKGBUILD
index 986a229..a30519f 100644
--- a/abs/extra/swig/PKGBUILD
+++ b/abs/extra/swig/PKGBUILD
@@ -1,19 +1,18 @@
-# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=swig
-pkgver=3.0.8
+pkgver=4.0.2
pkgrel=1
pkgdesc="Generate scripting interfaces to C/C++ code"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.swig.org/"
license=('custom')
depends=('pcre' 'gcc-libs')
-checkdepends=('ruby' 'python2' 'java-environment' 'tcl' 'php' 'lua' 'ocaml' 'r' 'go' 'python2-cffi' 'camlp4')
-source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-sha1sums=('1f45e96219536b3423b8d4dbd03614ffccca9c33')
+checkdepends=('ruby' 'python' 'java-environment' 'tcl' 'php' 'lua' 'r' 'go' 'boost')
+source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+sha512sums=('05e7da70ce6d9a733b96c0bcfa3c1b82765bd859f48c74759bbf4bb1467acb1809caa310cba5e2b3280cd704fca249eaa0624821dffae1d2a75097c7f55d14ed')
build() {
cd ${pkgname}-${pkgver}
@@ -23,7 +22,7 @@ build() {
check() {
cd ${pkgname}-${pkgver}
- make check || warning "Tests failed"
+ make check PY3=y
}
package() {