summaryrefslogtreecommitdiffstats
path: root/abs/extra/terminus-font
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/terminus-font')
-rw-r--r--abs/extra/terminus-font/PKGBUILD20
-rw-r--r--abs/extra/terminus-font/install.proto27
-rw-r--r--abs/extra/terminus-font/terminus-font.install21
3 files changed, 68 insertions, 0 deletions
diff --git a/abs/extra/terminus-font/PKGBUILD b/abs/extra/terminus-font/PKGBUILD
new file mode 100644
index 0000000..c3be90c
--- /dev/null
+++ b/abs/extra/terminus-font/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Vesa Kaihlavirta <vegai@iki.fi>
+# Contributor: Kristoffer Fossgård <kfs1@online.no>
+pkgname=terminus-font
+pkgver=4.30
+pkgrel=1
+pkgdesc="A superb, monospace bitmap font (for X11 and console)"
+depends=(xorg-fonts-encodings xorg-fonts-alias xorg-font-utils fontconfig)
+replaces=(xserver-terminus-fonts)
+arch=(i686 x86_64)
+source=(http://www.is-vn.bg/hamster/$pkgname-$pkgver.tar.gz)
+url="http://www.is-vn.bg/hamster/jimmy-en.html"
+install=terminus-font.install
+license=('GPL-2')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr --x11dir=/usr/share/fonts/local/ --psfdir=/usr/share/kbd/consolefonts/
+ make DESTDIR=$startdir/pkg install
+}
+md5sums=('6f8bd95b593851f9f5c210a9d33cbbf1')
diff --git a/abs/extra/terminus-font/install.proto b/abs/extra/terminus-font/install.proto
new file mode 100644
index 0000000..37f0b55
--- /dev/null
+++ b/abs/extra/terminus-font/install.proto
@@ -0,0 +1,27 @@
+# arg 1: the new package version
+ post_install() {
+ echo -n "Updating font cache... "
+ /usr/bin/fc-cache
+ cd /usr/share/fonts/local
+ /usr/bin/mkfontdir
+ /usr/bin/mkfontscale
+# cp ../encodings/encodings.dir ./encodings.dir
+ echo "done."
+ echo "Note that local fonts are now (with xorg-7.0) in /usr/share/fonts/local/"
+ }
+
+# # arg 1: the new package version
+# # arg 2: the old package version
+ post_upgrade() {
+ post_install $1
+ }
+#
+# # arg 1: the old package version
+ post_remove() {
+ /usr/bin/fc-cache
+ }
+
+op=$1
+shift
+
+$op $*
diff --git a/abs/extra/terminus-font/terminus-font.install b/abs/extra/terminus-font/terminus-font.install
new file mode 100644
index 0000000..e17fb4f
--- /dev/null
+++ b/abs/extra/terminus-font/terminus-font.install
@@ -0,0 +1,21 @@
+# arg 1: the new package version
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/local
+ mkfontdir /usr/share/fonts/local
+ echo "done."
+ echo "Note: terminus-font is in /usr/share/fonts/local/"
+}
+
+# # arg 1: the new package version
+# # arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+#
+# # arg 1: the old package version
+post_remove() {
+ post_install $1
+}
+