summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/autogen/PKGBUILD24
-rw-r--r--abs/extra/autogen/autogen.install20
-rw-r--r--abs/extra/bdf-unifont/LICENSE60
-rw-r--r--abs/extra/bdf-unifont/PKGBUILD24
-rw-r--r--abs/extra/bdf-unifont/unifont.install15
5 files changed, 143 insertions, 0 deletions
diff --git a/abs/extra/autogen/PKGBUILD b/abs/extra/autogen/PKGBUILD
new file mode 100644
index 0000000..eea072e
--- /dev/null
+++ b/abs/extra/autogen/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 54700 2009-10-11 18:35:07Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Arjan Timmerman <arjan@soufly.nl>
+# Contributor: Tor Krill
+
+pkgname=autogen
+pkgver=5.11.5
+pkgrel=1
+pkgdesc="A tool designed to simplify the creation and maintenance of programs that contain large amounts of repetitious text"
+arch=(i686 x86_64)
+url="http://autogen.sourceforge.net/"
+license=('GPL3')
+depends=('guile>=1.8.6' 'libxml2>=2.7.3' 'libtool>=2.2.6a')
+options=('!libtool' '!makeflags')
+install=autogen.install
+source=(http://downloads.sourceforge.net/autogen/${pkgname}-${pkgver}.tar.bz2)
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}
+md5sums=('51c841eab6114de22b55f77a1c4f85b8')
diff --git a/abs/extra/autogen/autogen.install b/abs/extra/autogen/autogen.install
new file mode 100644
index 0000000..181c256
--- /dev/null
+++ b/abs/extra/autogen/autogen.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(autogen.info autogen.info-1 autogen.info-2)
+
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/${file}.gz $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/${file}.gz $infodir/dir 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/bdf-unifont/LICENSE b/abs/extra/bdf-unifont/LICENSE
new file mode 100644
index 0000000..066ea16
--- /dev/null
+++ b/abs/extra/bdf-unifont/LICENSE
@@ -0,0 +1,60 @@
+CENSE
+-------
+Roman Czyborra released his work (Perl scripts and font .hex files)
+under the following terms:
+
+ All of my works you find here are freeware. You may
+ freely copy, use, quote, modify or redistribute them
+ as long as you properly attribute my contribution and
+ have given a quick thought about whether Roman might
+ perhaps be interested to read what you did with his
+ stuff. Horizontal rules don't apply.
+
+David Starner released what in this package is named "hex2bdf-split"
+under the same license as Roman Czyborra's work.
+
+License for all of Paul Hardy's work (except "johab2ucs2" and
+"blanks.hex", mentioned separately), Makefile and debian/ mods
+by Anthony Fok, and modified software from Luis Gonzalez Miranda
+(with permission granted to Paul Hardy):
+
+ These are released under the terms of the GNU General Public
+ License version 2, or (at your option) a later version.
+
+License for Fonts:
+
+ Any fonts using glyphs from the "wqy-cjk.hex" file (including
+ the default TrueType font) are bound by the terms of the Wen
+ Quan Yi font license. Those fonts are released under the terms
+ of the GNU General Public License (GPL) versionn 2, with the
+ exception that embedding the font in a document does not by
+ itself bind that document to the terms of the GNU GPL.
+
+ Any fonts that do not use glyphs from the "wqy-cjk.hex" file
+ fall under the above "License for all of Roman Czyborra's work".
+
+ The fonts in "./font/precompiled" do use wqy-cjk.hex, and so
+ are licensed under the GNU GPL version 2, with the exception
+ that embedding the font in a document does not in itself bind
+ that document to the terms of the GNU GPL. The following
+ paragraphs explaining the exception is taken from the Wen
+ Quan Yi font distribution:
+
+ ** GPL v2.0 license with font embedding exception:
+
+ As a special exception, if you create a document which
+ uses this font, and embed this font or unaltered portions
+ of this font into the document, this font does not by
+ itself cause the resulting document to be covered by
+ the GNU General Public License. This exception does not
+ however invalidate any other reasons why the document
+ might be covered by the GNU General Public License.
+ If you modify this font, you may extend this exception
+ to your version of the font, but you are not obligated
+ to do so. If you do not wish to do so, delete this
+ exception statement from your version.
+
+License for "blanks.hex":
+
+ There is one exception to the above rules: Paul Hardy earlier
+ released the "blanks.hex" file into the public domain.
diff --git a/abs/extra/bdf-unifont/PKGBUILD b/abs/extra/bdf-unifont/PKGBUILD
new file mode 100644
index 0000000..2df7993
--- /dev/null
+++ b/abs/extra/bdf-unifont/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD,v 1.5 2008/09/24 07:16:54 ronald Exp $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+
+pkgname=bdf-unifont
+pkgver=5.1.20080820
+pkgrel=1
+pkgdesc="GNU Unifont Glyphs"
+arch=('i686' 'x86_64')
+license=('custom' 'GPL2')
+url="http://unifoundry.com/unifont.html"
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=unifont.install
+source=('http://unifoundry.com/unifont-5.1.20080820.bdf.gz' 'LICENSE')
+md5sums=('6b8263ceccef33bd633aa019d74b7943'
+ '64da5a96d6789d29d485cd67a43bc547')
+
+build() {
+ install -Dm644 ${srcdir}/unifont-5.1.20080820.bdf \
+ ${pkgdir}/usr/share/fonts/misc/unifont.bdf
+
+ # install LICENSE file
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
diff --git a/abs/extra/bdf-unifont/unifont.install b/abs/extra/bdf-unifont/unifont.install
new file mode 100644
index 0000000..7d21ab5
--- /dev/null
+++ b/abs/extra/bdf-unifont/unifont.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/misc
+ mkfontdir /usr/share/fonts/misc
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}