summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/fftw/PKGBUILD99
-rw-r--r--abs/extra/fftw/fftw.install22
-rw-r--r--abs/extra/git/PKGBUILD110
-rw-r--r--abs/extra/git/git-sysusers.conf2
-rw-r--r--abs/extra/git/git.install7
-rw-r--r--abs/extra/google-chrome/PKGBUILD4
-rwxr-xr-xabs/extra/google-chrome/update_version.sh6
-rw-r--r--abs/extra/guile/PKGBUILD7
-rw-r--r--abs/extra/libburn/PKGBUILD15
-rw-r--r--abs/extra/libisoburn/PKGBUILD11
-rw-r--r--abs/extra/libisofs/PKGBUILD14
-rw-r--r--abs/extra/openmpi/PKGBUILD98
-rw-r--r--abs/extra/openmpi/system_ltdl.patch66
-rw-r--r--abs/extra/plex-media-server/PKGBUILD6
14 files changed, 191 insertions, 276 deletions
diff --git a/abs/extra/fftw/PKGBUILD b/abs/extra/fftw/PKGBUILD
index db4322f..1ab869b 100644
--- a/abs/extra/fftw/PKGBUILD
+++ b/abs/extra/fftw/PKGBUILD
@@ -1,50 +1,81 @@
-# $Id: PKGBUILD 159277 2012-05-20 10:35:50Z ronald $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: David Runge <dvzrv@archlinux.org>
# Contributor: damir <damir@archlinux.org>
pkgname=fftw
-pkgver=3.3.2
-pkgrel=1
+pkgver=3.3.8
+pkgrel=3
pkgdesc="A library for computing the discrete Fourier transform (DFT)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL2')
url="http://www.fftw.org/"
-depends=('glibc' 'bash')
+depends=('bash' 'gcc-libs' 'glibc' 'openmpi')
makedepends=('gcc-fortran')
-options=('!libtool')
+provides=('libfftw3q_threads.so' 'libfftw3q_omp.so' 'libfftw3q.so'
+'libfftw3l_threads.so' 'libfftw3l_omp.so' 'libfftw3l_mpi.so' 'libfftw3l.so'
+'libfftw3f_threads.so' 'libfftw3f_omp.so' 'libfftw3f_mpi.so' 'libfftw3f.so'
+'libfftw3_threads.so' 'libfftw3_omp.so' 'libfftw3_mpi.so' 'libfftw3.so')
+# makedepends=('gcc-fortran' 'ocaml' 'ocaml-num' 'ocamlbuild')
source=("http://www.fftw.org/${pkgname}-${pkgver}.tar.gz")
-install=fftw.install
-sha1sums=('11a8c31186ff5a7d686a79a3f21b2530888e0dc2')
-
-# notes:
-# http://www.fftw.org/fftw2_doc/fftw_6.html#SEC69
-# http://www.fftw.org/faq/section2.html#singleprec
-# http://www.fftw.org/fftw3_doc/Precision.html#Precision
+# source=("https://github.com/${pkgname}/fftw3/archive/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('ab918b742a7c7dcb56390a0a0014f517a6dff9a2e4b4591060deeb2c652bf3c6868aa74559a422a276b853289b4b701bdcbd3d4d8c08943acf29167a7be81a38')
+prepare() {
+# issue with ocaml-num
+# mv -v "fftw3-${pkgname}-${pkgver}" "${pkgname}-${pkgver}"
+# (
+# cd "$pkgname-$pkgver"
+# cp -v NEWS ChangeLog
+# autoreconf -vfi
+# )
+ cp -av "${pkgname}-${pkgver}" "${pkgname}-${pkgver}-double"
+ cp -av "${pkgname}-${pkgver}" "${pkgname}-${pkgver}-long-double"
+ cp -av "${pkgname}-${pkgver}" "${pkgname}-${pkgver}-quad"
+}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
+ export F77='gfortran'
# use upstream default CFLAGS while keeping our -march/-mtune
CFLAGS+=" -O3 -fomit-frame-pointer -malign-double -fstrict-aliasing -ffast-math"
+ # default configure call
+ _default_configure="./configure --prefix=/usr --enable-shared --enable-threads --enable-mpi --enable-openmp"
+
+ # configure single precision
+ (
+ cd "${pkgname}-${pkgver}"
+ ${_default_configure} --enable-sse --enable-avx --enable-single
+ )
+
+ # configure double precision
+ (
+ cd "${pkgname}-${pkgver}-double"
+ ${_default_configure} --enable-sse2 --enable-avx
+ )
+
+ # configure long-double precission
+ (
+ cd "${pkgname}-${pkgver}-long-double"
+ ${_default_configure} --enable-long-double
+ )
+
+ # configure quad precision
+ (
+ cd "${pkgname}-${pkgver}-quad"
+ ${_default_configure} --disable-mpi --enable-quad-precision
+ )
+
+ make -C "${pkgname}-${pkgver}"
+ make -C "${pkgname}-${pkgver}-double"
+ make -C "${pkgname}-${pkgver}-long-double"
+ make -C "${pkgname}-${pkgver}-quad"
+}
- CONFIGURE="./configure F77=gfortran --prefix=/usr \
- --enable-shared --enable-threads --enable-type-prefix"
-
- # build & install double precision
- $CONFIGURE --enable-sse2
- make
- make DESTDIR=${pkgdir} install
- make clean
-
- # build & install long double precission
- $CONFIGURE --enable-long-double
- make
- make DESTDIR=${pkgdir} install
- make clean
-
- # build & install single precision
- $CONFIGURE --enable-float --enable-sse
- make
- make DESTDIR=${pkgdir} install
+package() {
+ make DESTDIR="${pkgdir}" install -C "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install -C "${pkgname}-${pkgver}-double"
+ make DESTDIR="${pkgdir}" install -C "${pkgname}-${pkgver}-long-double"
+ make DESTDIR="${pkgdir}" install -C "${pkgname}-${pkgver}-quad"
+ cd "${pkgname}-${pkgver}"
+ install -vDm 644 {AUTHORS,ChangeLog,NEWS,README,TODO} \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
}
diff --git a/abs/extra/fftw/fftw.install b/abs/extra/fftw/fftw.install
deleted file mode 100644
index a3748aa..0000000
--- a/abs/extra/fftw/fftw.install
+++ /dev/null
@@ -1,22 +0,0 @@
-info_dir=/usr/share/info
-info_files=(fftw3.info)
-
-post_install() {
- for f in ${info_files[@]}; do
- install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install
-}
-
-pre_remove() {
- for f in ${info_files[@]}; do
- install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
- done
-}
-
-
-
-
diff --git a/abs/extra/git/PKGBUILD b/abs/extra/git/PKGBUILD
index 024b137..724fc29 100644
--- a/abs/extra/git/PKGBUILD
+++ b/abs/extra/git/PKGBUILD
@@ -1,20 +1,19 @@
-# $Id$
# Maintainer: Christian Hesse <mail@eworm.de>
# Maintainer: Dan McGee <dan@archlinux.org>
pkgname=git
-pkgver=2.16.2
+pkgver=2.29.2
pkgrel=1
-pkgdesc="the fast distributed version control system"
-arch=(x86_64)
-url="http://git-scm.com/"
+pkgdesc='the fast distributed version control system'
+arch=('x86_64')
+url='https://git-scm.com/'
license=('GPL2')
-depends=('curl' 'expat>=2.0' 'perl-error' 'perl>=5.14.0' 'openssl' 'pcre2'
- 'grep' 'shadow')
-makedepends=('python2' 'emacs' 'libgnome-keyring' 'xmlto' 'asciidoc')
+depends=('curl' 'expat' 'perl' 'perl-error' 'perl-mailtools'
+ 'openssl' 'pcre2' 'grep' 'shadow')
+makedepends=('python' 'libgnome-keyring' 'xmlto' 'asciidoc')
optdepends=('tk: gitk and git gui'
'perl-libwww: git svn'
- 'perl-term-readkey: git svn'
+ 'perl-term-readkey: git svn and interactive.singlekey setting'
'perl-mime-tools: git send-email'
'perl-net-smtp-ssl: git send-email TLS support'
'perl-authen-sasl: git send-email TLS support'
@@ -22,44 +21,55 @@ optdepends=('tk: gitk and git gui'
'perl-datetime-format-iso8601: git mediawiki support'
'perl-lwp-protocol-https: git mediawiki https support'
'perl-cgi: gitweb (web interface) support'
- 'python2: various helper scripts'
+ 'python: git svn & git p4'
'subversion: git svn'
- 'gnome-keyring: GNOME keyring credential helper')
-replaces=('git-core')
-provides=('git-core')
+ 'org.freedesktop.secrets: keyring credential helper'
+ 'libsecret: libsecret credential helper')
install=git.install
validpgpkeys=('96E07AF25771955980DAD10020D04E5A713660A7') # Junio C Hamano
source=("https://www.kernel.org/pub/software/scm/git/git-$pkgver.tar."{xz,sign}
'git-daemon@.service'
'git-daemon.socket'
'git-sysusers.conf')
-sha256sums=('5560578bd21468d98637f41515c165d32f69caff0838b8989dee5ce10022c717'
+sha256sums=('f2fc436ebe657821a1360bcd1e5f4896049610082419143d60f6fa13c2f607c1'
'SKIP'
'14c0b67cfe116b430645c19d8c4759419657e6809dfa28f438c33a005245ad91'
'ac4c90d62c44926e6d30d18d97767efc901076d4e0283ed812a349aece72f203'
- '595794856bfa6087c33826640ae7b5447832233844f36dfedc18646d47154730')
+ '7630e8245526ad80f703fac9900a1328588c503ce32b37b9f8811674fcda4a45')
+
+_make_paths=(
+ prefix='/usr'
+ gitexecdir='/usr/lib/git-core'
+ perllibdir="$(/usr/bin/perl -MConfig -wle 'print $Config{installvendorlib}')"
+)
+
+_make_options=(
+ CFLAGS="$CFLAGS"
+ LDFLAGS="$LDFLAGS"
+ INSTALL_SYMLINKS=1
+ MAN_BOLD_LITERAL=1
+ NO_PERL_CPAN_FALLBACKS=1
+ USE_LIBPCRE2=1
+)
build() {
- export PYTHON_PATH='/usr/bin/python2'
cd "$srcdir/$pkgname-$pkgver"
- make prefix=/usr gitexecdir=/usr/lib/git-core \
- CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" \
- USE_LIBPCRE2=1 \
- NO_CROSS_DIRECTORY_HARDLINKS=1 \
- MAN_BOLD_LITERAL=1 \
- all doc
- make -C contrib/emacs prefix=/usr
+ make \
+ "${_make_paths[@]}" \
+ "${_make_options[@]}" \
+ all man
+
make -C contrib/credential/gnome-keyring
make -C contrib/credential/libsecret
- make -C contrib/subtree prefix=/usr gitexecdir=/usr/lib/git-core all doc
- make -C contrib/mw-to-git prefix=/usr all
- make -C contrib/diff-highlight prefix=/usr
+ make -C contrib/subtree "${_make_paths[@]}" all man
+ make -C contrib/mw-to-git "${_make_paths[@]}" all
+ make -C contrib/diff-highlight "${_make_paths[@]}"
}
check() {
- export PYTHON_PATH='/usr/bin/python2'
cd "$srcdir/$pkgname-$pkgver"
+
local jobs
jobs=$(expr "$MAKEFLAGS" : '.*\(-j[0-9]*\).*') || true
mkdir -p /dev/shm/git-test
@@ -67,11 +77,9 @@ check() {
# which is caused by 'git rebase' trying to use builduser's SHELL inside the
# build chroot (i.e.: /usr/bin/nologin)
SHELL=/bin/sh \
- make prefix=/usr gitexecdir=/usr/lib/git-core \
- CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" \
- USE_LIBPCRE2=1 \
- NO_CROSS_DIRECTORY_HARDLINKS=1 \
- MAN_BOLD_LITERAL=1 \
+ make \
+ "${_make_paths[@]}" \
+ "${_make_options[@]}" \
NO_SVN_TESTS=y \
DEFAULT_TEST_TARGET=prove \
GIT_PROVE_OPTS="$jobs -Q" \
@@ -80,14 +88,13 @@ check() {
}
package() {
- export PYTHON_PATH='/usr/bin/python2'
cd "$srcdir/$pkgname-$pkgver"
- make prefix=/usr gitexecdir=/usr/lib/git-core \
- CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" \
- USE_LIBPCRE2=1 \
- NO_CROSS_DIRECTORY_HARDLINKS=1 \
- MAN_BOLD_LITERAL=1 \
- INSTALLDIRS=vendor DESTDIR="$pkgdir" install install-doc
+
+ make \
+ "${_make_paths[@]}" \
+ "${_make_options[@]}" \
+ DESTDIR="$pkgdir" \
+ install install-man
# bash completion
mkdir -p "$pkgdir"/usr/share/bash-completion/completions/
@@ -95,9 +102,8 @@ package() {
# fancy git prompt
mkdir -p "$pkgdir"/usr/share/git/
install -m 0644 ./contrib/completion/git-prompt.sh "$pkgdir"/usr/share/git/git-prompt.sh
- # emacs
- make -C contrib/emacs prefix=/usr DESTDIR="$pkgdir" install
- # gnome credentials helper
+ # gnome credentials helper (deprecated, but we will keep it as long there is no extra cost)
+ # https://gitlab.gnome.org/GNOME/libgnome-keyring/commit/6a5adea4aec93
install -m 0755 contrib/credential/gnome-keyring/git-credential-gnome-keyring \
"$pkgdir"/usr/lib/git-core/git-credential-gnome-keyring
make -C contrib/credential/gnome-keyring clean
@@ -106,26 +112,12 @@ package() {
"$pkgdir"/usr/lib/git-core/git-credential-libsecret
make -C contrib/credential/libsecret clean
# subtree installation
- make -C contrib/subtree prefix=/usr gitexecdir=/usr/lib/git-core DESTDIR="$pkgdir" install install-doc
+ make -C contrib/subtree "${_make_paths[@]}" DESTDIR="$pkgdir" install install-man
# mediawiki installation
- make -C contrib/mw-to-git prefix=/usr gitexecdir=/usr/lib/git-core DESTDIR="$pkgdir" install
+ make -C contrib/mw-to-git "${_make_paths[@]}" DESTDIR="$pkgdir" install
# the rest of the contrib stuff
find contrib/ -name '.gitignore' -delete
- cp -a ./contrib/* $pkgdir/usr/share/git/
-
- # scripts are for python 2.x
- sed -i 's|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|' \
- $(find "$pkgdir" -name '*.py') \
- "$pkgdir"/usr/share/git/remote-helpers/git-remote-bzr \
- "$pkgdir"/usr/share/git/remote-helpers/git-remote-hg
- sed -i 's|#![ ]*/usr/bin/python$|#!/usr/bin/python2|' \
- "$pkgdir"/usr/share/git/svn-fe/svnrdump_sim.py
-
- # perl modules from contrib/ install to site dir... move to vendor
- mv "$pkgdir"/usr/share/perl5/site_perl/Git/* "$pkgdir"/usr/share/perl5/vendor_perl/Git/
- rm -rf "$pkgdir"/usr/share/perl5/site_perl
- # remove perllocal.pod, .packlist, and empty directories.
- rm -rf "$pkgdir"/usr/lib/perl5
+ cp -a ./contrib/* "$pkgdir"/usr/share/git/
# git-daemon via systemd socket activation
install -D -m 0644 "$srcdir"/git-daemon@.service "$pkgdir"/usr/lib/systemd/system/git-daemon@.service
diff --git a/abs/extra/git/git-sysusers.conf b/abs/extra/git/git-sysusers.conf
index 2141c70..8189065 100644
--- a/abs/extra/git/git-sysusers.conf
+++ b/abs/extra/git/git-sysusers.conf
@@ -1 +1 @@
-u git - "git daemon user" /
+u git - "git daemon user" / /usr/bin/git-shell
diff --git a/abs/extra/git/git.install b/abs/extra/git/git.install
index 24bc5d7..453050d 100644
--- a/abs/extra/git/git.install
+++ b/abs/extra/git/git.install
@@ -5,13 +5,6 @@ post_install() {
if ! grep -qe '^/usr/bin/git-shell$' etc/shells; then
echo '/usr/bin/git-shell' >> etc/shells
fi
-
- # make sure the user exists...
- systemd-sysusers git.conf
-
- # ... and change the shell. This is done only once in post-install
- # function, so an administrative change is persistent.
- chsh --shell /usr/bin/git-shell git > /dev/null
}
# do not modify user settings (shell) in post-upgrade function!
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index 7958ecc..c875010 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -6,7 +6,7 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=80.0.3987.122
+pkgver=86.0.4240.111
pkgrel=1
pkgdesc="The popular and trusted web browser by Google (Stable Channel)"
arch=('x86_64')
@@ -26,7 +26,7 @@ _channel=stable
source=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb"
'eula_text.html'
"google-chrome-$_channel.sh")
-sha512sums=('dc9e6ab4cda866e19b13f90613efb8915993346dc8dfa00aba84e200b9a90633759226788cc18105a8d240951b17a7c753f9f380fceb8ce0beaed7315c6ba47a'
+sha512sums=('354efe5e248b3bd15faa8ac6107756004b75a105cd1d98087cd35a84ae6ee1b3a4140b50cff3a732e4bb7350a72d9c9d1ccba653ebdec62f84a55017671a66de'
'a225555c06b7c32f9f2657004558e3f996c981481dbb0d3cd79b1d59fa3f05d591af88399422d3ab29d9446c103e98d567aeafe061d9550817ab6e7eb0498396'
'351ccec932eea30d8f73071854370978594442c0ab2f5faf4df965b430f9124689e5b70dc64142faefb7f0603904bccac24e23d553d3b692ed6e61b9ec53a79c')
diff --git a/abs/extra/google-chrome/update_version.sh b/abs/extra/google-chrome/update_version.sh
index 5b32577..467a57b 100755
--- a/abs/extra/google-chrome/update_version.sh
+++ b/abs/extra/google-chrome/update_version.sh
@@ -27,8 +27,8 @@ fi
#makepkg --printsrcinfo >.SRCINFO
# Build
-mpv2.py --rmold
+#mpv2.py --rmold
# Commit changes
-git add PKGBUILD
-git commit -m "google-chrome: update to v${VER}"
+#git add PKGBUILD
+#git commit -m "google-chrome: update to v${VER}"
diff --git a/abs/extra/guile/PKGBUILD b/abs/extra/guile/PKGBUILD
index 73ff747..a081865 100644
--- a/abs/extra/guile/PKGBUILD
+++ b/abs/extra/guile/PKGBUILD
@@ -1,11 +1,10 @@
-# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=guile
-pkgver=2.2.3
-pkgrel=1
+pkgver=2.2.6
+pkgrel=2
pkgdesc='Portable, embeddable Scheme implementation written in C'
url='https://www.gnu.org/software/guile/'
arch=(x86_64)
@@ -15,7 +14,7 @@ source=(https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz{,.sig})
validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5' # Ludovic Courtès <ludo@gnu.org>
'FF478FB264DE32EC296725A3DDC0F5358812F8F2' # Andy Wingo
'4FD4D288D445934E0A14F9A5A8803732E4436885') # Andy Wingo <wingo@pobox.com>"
-sha256sums=('87ee07caef33c97ddc74bf3c29ce7628cfac12061f573e4a29a3a1176754610a'
+sha256sums=('08c0e7487777740b61cdd97949b69e8a5e2997d8c2fe6c7e175819eb18444506'
'SKIP')
build() {
diff --git a/abs/extra/libburn/PKGBUILD b/abs/extra/libburn/PKGBUILD
index 2bd7725..de3f1fa 100644
--- a/abs/extra/libburn/PKGBUILD
+++ b/abs/extra/libburn/PKGBUILD
@@ -1,29 +1,28 @@
-# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Contributor: William Rea <sillywilly@gmail.com>
pkgname=libburn
-pkgver=1.4.8 # .pl01
-pkgrel=1
+pkgver=1.5.2 # .pl01
+pkgrel=2
pkgdesc="Library for reading, mastering and writing optical discs"
arch=('x86_64')
url="https://dev.lovelyhq.com/libburnia"
license=('GPL')
depends=('glibc')
+# https://dev.lovelyhq.com/libburnia/web/wikis/Releases
source=(http://files.libburnia-project.org/releases/${pkgname}-${pkgver}.tar.gz{,.sig})
options=('!emptydirs')
-sha256sums=('3e81a2e359376c38d96239a9c9967be715f706d150d89c337de0fc85ecb79da6'
+sha256sums=('7b32db1719d7f6516cce82a9d00dfddfb3581725db732ea87d41ea8ef0ce5227'
'SKIP')
validpgpkeys=('44BC9FD0D688EB007C4DD029E9CBDFC0ABC0A854') # Thomas Schmitt <scdbackup@gmx.net>
build() {
- cd ${pkgname}-${pkgver/.pl01/}
+ cd "${pkgname}"-${pkgver/.pl01/}
./configure --prefix=/usr --disable-static
make
}
package() {
- cd ${pkgname}-${pkgver/.pl01/}
- make DESTDIR=${pkgdir} install
+ cd "${pkgname}"-${pkgver/.pl01/}
+ make DESTDIR="${pkgdir}" install
}
-
diff --git a/abs/extra/libisoburn/PKGBUILD b/abs/extra/libisoburn/PKGBUILD
index c094ee0..313d758 100644
--- a/abs/extra/libisoburn/PKGBUILD
+++ b/abs/extra/libisoburn/PKGBUILD
@@ -1,9 +1,8 @@
-# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Gour <Gour <gour@mail.inet.hr>
pkgname=libisoburn
-pkgver=1.4.8 #.pl01
+pkgver=1.5.2 #.pl01
pkgrel=2
pkgdesc="frontend for libraries libburn and libisofs"
url="https://dev.lovelyhq.com/libburnia"
@@ -14,17 +13,17 @@ optdepends=('tk: for xorriso-tcltk frontend')
#'bwidget: for xorriso-tcltk frontend') # AUR
provides=('xorriso' 'xorriso-tcltk')
source=(http://files.libburnia-project.org/releases/${pkgname}-${pkgver}.tar.gz{,.sig})
-sha256sums=('91cf50473f0f19400629515974bda441545aaae29862dcbbdb28d87b821ca5a5'
+sha256sums=('cc720bc9511d8e0b09365e2c8b0e40817986be308cd96ca2705c807c955590ec'
'SKIP')
validpgpkeys=('44BC9FD0D688EB007C4DD029E9CBDFC0ABC0A854') # Thomas Schmitt <scdbackup@gmx.net>
build() {
- cd ${pkgname}-${pkgver/.pl01/}
+ cd "${pkgname}"-${pkgver/.pl01/}
./configure --prefix=/usr
make
}
package() {
- cd ${pkgname}-${pkgver/.pl01/}
- make DESTDIR=${pkgdir} install
+ cd "${pkgname}"-${pkgver/.pl01/}
+ make DESTDIR="${pkgdir}" install
}
diff --git a/abs/extra/libisofs/PKGBUILD b/abs/extra/libisofs/PKGBUILD
index 6c5e0fc..3e5d030 100644
--- a/abs/extra/libisofs/PKGBUILD
+++ b/abs/extra/libisofs/PKGBUILD
@@ -1,30 +1,28 @@
-# $Id$
# Maintainer: AndyRTR <andyrtr@archlinux.org>
# Contributor: Hugo Doria <hugodoria@gmail.com>
# Contributor: Bjorn Martensen
pkgname=libisofs
-pkgver=1.4.8
-pkgrel=1
+pkgver=1.5.2
+pkgrel=2
pkgdesc="Library to pack up hard disk files and directories into a ISO 9660 disk image"
arch=('x86_64')
url="https://dev.lovelyhq.com/libburnia"
license=('GPL')
depends=('acl' 'zlib')
source=(http://files.libburnia-project.org/releases/${pkgname}-${pkgver}.tar.gz{,.sig})
-sha256sums=('dc9de9df366c27cf03d31d860c83a08ddad9028fe192801ee344602ccec29b69'
+sha256sums=('ef5a139600b3e688357450e52381e40ec26a447d35eb8d21524598c7b1675500'
'SKIP')
validpgpkeys=('44BC9FD0D688EB007C4DD029E9CBDFC0ABC0A854') # Thomas Schmitt <scdbackup@gmx.net>
build() {
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}"-${pkgver}
./configure --prefix=/usr \
--enable-libacl --enable-xattr --disable-static
make
}
package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd "${pkgname}"-${pkgver}
+ make DESTDIR="${pkgdir}" install
}
-
diff --git a/abs/extra/openmpi/PKGBUILD b/abs/extra/openmpi/PKGBUILD
index d6aa6e1..d94e7d2 100644
--- a/abs/extra/openmpi/PKGBUILD
+++ b/abs/extra/openmpi/PKGBUILD
@@ -1,67 +1,59 @@
-# $Id$
-# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
pkgname=openmpi
-pkgver=1.10.2
-pkgrel=1
+pkgver=4.0.5
+pkgrel=2
pkgdesc='High performance message passing library (MPI)'
-arch=(i686 x86_64)
-url='http://www.open-mpi.org'
-license=(custom)
-depends=(libltdl hwloc)
-makedepends=(inetutils valgrind gcc-fortran)
+url='https://www.open-mpi.org'
+arch=('x86_64')
+license=('custom:OpenMPI')
+depends=('glibc' 'libltdl' 'hwloc' 'openssh' 'zlib' 'libnl' 'perl')
+makedepends=('inetutils' 'valgrind' 'gcc-fortran')
optdepends=('gcc-fortran: fortran support')
-options=(staticlibs)
-source=(http://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${pkgname}-${pkgver}.tar.bz2)
-sha1sums=('03934fc0a2dd0d0d2d0459d714a976eabca938fb')
+options=('staticlibs')
+source=(https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('c58f3863b61d944231077f344fe6b4b8fbb83f3d1bc93ab74640bf3e5acac009')
+b2sums=('9709dc8c251d4f2be14d0ab498c5d0d0e59f95db98fb16d9e84fe3d30af5a8e2f9636bbceaf7ae4086a3312bcd6299f0e9e1ca609d658930a1f5abe1018311e1')
build() {
- cd $pkgname-$pkgver
-
- ./autogen.pl
- ./configure --prefix=/usr \
- --sysconfdir=/etc/${pkgname} \
- --enable-mpi-fortran=all \
- --libdir=/usr/lib/${pkgname} \
- --with-threads=posix \
- --enable-smp-locks \
- --with-valgrind \
- --enable-memchecker \
- --enable-pretty-print-stacktrace \
- --without-slurm \
- --with-hwloc=/usr \
- --with-libltdl=/usr \
- FC=/usr/bin/gfortran \
- LDFLAGS="$LDFLAGS -Wl,-z,noexecstack"
-
- make
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/${pkgname} \
+ --enable-mpi-fortran=all \
+ --libdir=/usr/lib/${pkgname} \
+ --enable-builtin-atomics \
+ --enable-mpi-cxx \
+ --with-valgrind \
+ --enable-memchecker \
+ --enable-pretty-print-stacktrace \
+ --without-slurm \
+ --with-hwloc=/usr \
+ --with-libltdl=/usr \
+ FC=/usr/bin/gfortran \
+ LDFLAGS="${LDFLAGS} -Wl,-z,noexecstack"
+ make
}
check() {
- cd $pkgname-$pkgver
-
- make check
+ cd ${pkgname}-${pkgver}
+ make check
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-
- # FS#28583
- install -d -m 755 "$pkgdir"/usr/lib/pkgconfig
- for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
- ln -sf /usr/lib/openmpi/pkgconfig/$i "$pkgdir"/usr/lib/pkgconfig/
- done
-
- # Openmpi's otfinfo conflicts with the one from texlive
- mv "$pkgdir"/usr/bin/otfinfo{,mpi}
-
- # Remove dangling symlink and useless file
- rm "$pkgdir"/usr/share/vampirtrace/config.log
-
- install -d -m 755 "$pkgdir"/etc/ld.so.conf.d
- echo "/usr/lib/$pkgname" > "$pkgdir"/etc/ld.so.conf.d/$pkgname.conf
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ # FS#28583
+ install -dm 755 "${pkgdir}/usr/lib/pkgconfig"
+ for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
+ ln -sf "/usr/lib/openmpi/pkgconfig/${i}" "${pkgdir}/usr/lib/pkgconfig/"
+ done
+
+ install -dm 755 "${pkgdir}/etc/ld.so.conf.d"
+ echo "/usr/lib/${pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${pkgname}.conf
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+
+# vim: ts=2 sw=2 et:
diff --git a/abs/extra/openmpi/system_ltdl.patch b/abs/extra/openmpi/system_ltdl.patch
deleted file mode 100644
index 300da38..0000000
--- a/abs/extra/openmpi/system_ltdl.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/config/ltdl.m4 b/config/ltdl.m4
-index ea76f4d..2f1cbfe 100644
---- a/config/ltdl.m4
-+++ b/config/ltdl.m4
-@@ -162,6 +162,8 @@ m4_defun([_LTDL_INSTALLABLE],
- fi
- fi
-
-+enable_ltdl_install=no
-+
- # If configure.ac declared an installable ltdl, and the user didn't override
- # with --disable-ltdl-install, we will install the shipped libltdl.
- case $enable_ltdl_install in
-diff --git a/ompi/debuggers/Makefile.am b/ompi/debuggers/Makefile.am
-index 2adf3fd..5b22a91 100644
---- a/ompi/debuggers/Makefile.am
-+++ b/ompi/debuggers/Makefile.am
-@@ -46,8 +46,7 @@ headers = \
- # Simple checks to ensure that the DSOs are functional
-
- dlopen_test_SOURCES = dlopen_test.c
--dlopen_test_CPPFLAGS = -I$(top_srcdir)/opal/libltdl
--dlopen_test_LDADD = $(top_builddir)/opal/libltdl/libltdlc.la
-+dlopen_test_LDADD = -lltdl
-
- predefined_gap_test_SOURCES = predefined_gap_test.c
- predefined_gap_test_LDFLAGS = $(WRAPPER_EXTRA_LDFLAGS)
-diff --git a/ompi/debuggers/dlopen_test.c b/ompi/debuggers/dlopen_test.c
-index 029a4ee..023afb8 100644
---- a/ompi/debuggers/dlopen_test.c
-+++ b/ompi/debuggers/dlopen_test.c
-@@ -13,7 +13,7 @@
- #include <string.h>
- #include <stdlib.h>
-
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
-
- static int do_test(void);
-
-diff --git a/test/support/components.c b/test/support/components.c
-index 41c4345..6b4b464 100644
---- a/test/support/components.c
-+++ b/test/support/components.c
-@@ -24,7 +24,7 @@
-
- #include "opal/constants.h"
- #include "opal/mca/mca.h"
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
-
- #include "components.h"
-
-diff --git a/test/support/components.h b/test/support/components.h
-index 6db1f0d..fc8dfc5 100644
---- a/test/support/components.h
-+++ b/test/support/components.h
-@@ -20,7 +20,7 @@
- #ifndef OMPI_SUPPORT_COMPONENTS_H
- #define OMPI_SUPPORT_COMPONENTS_H
-
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
- #include "opal/mca/mca.h"
-
- BEGIN_C_DECLS
diff --git a/abs/extra/plex-media-server/PKGBUILD b/abs/extra/plex-media-server/PKGBUILD
index 041b824..3e081b2 100644
--- a/abs/extra/plex-media-server/PKGBUILD
+++ b/abs/extra/plex-media-server/PKGBUILD
@@ -9,8 +9,8 @@
# Contributor: Praekon <praekon@googlemail.com>
pkgname=plex-media-server
-pkgver=1.18.2.2058
-_pkgsum=e67a4e892
+pkgver=1.24.2.4973
+_pkgsum=2b1b51db9
pkgrel=1
pkgdesc='Plex Media Server'
arch=('x86_64')
@@ -59,4 +59,4 @@ md5sums=('16f212dc586df577fa116d80adf1ebf6'
'b926b4b845120bd37b640a4982a667dc'
'f70da65876e2caac21dc463df234c726'
'af6d0a81c7821b2eddb1bc137310ca1b')
-md5sums_x86_64=('2244982ed6e033c916e3104c4c606893')
+md5sums_x86_64=('4e263044e0eea7619191410471ef7668')