summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/wayland-protocols/PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/abs/extra/wayland-protocols/PKGBUILD b/abs/extra/wayland-protocols/PKGBUILD
index 88b7dd1..2c721cc 100644
--- a/abs/extra/wayland-protocols/PKGBUILD
+++ b/abs/extra/wayland-protocols/PKGBUILD
@@ -1,8 +1,7 @@
-# $Id$
# Maintainer: Sébastien Luttringer <seblu@seblu.net>
pkgname=wayland-protocols
-pkgver=1.12
+pkgver=1.17
pkgrel=1
pkgdesc='Specifications of extended Wayland protocols'
arch=('any')
@@ -12,9 +11,13 @@ makedepends=('wayland')
validpgpkeys=('8307C0A224BABDA1BABD0EB9A6EEEC9E0136164A' # Jonas Ådahl
'A66D805F7C9329B4C5D82767CCC4F07FAC641EFF') # Daniel Stone
source=("https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"{,.sig})
-sha1sums=('ac908e91c6c5e7802c0af48f55725ad683017e72'
+sha1sums=('7d2569c838c776545e3eb1b1049b9c37178aae24'
'SKIP')
+prepare() {
+ cd $pkgname-$pkgver
+}
+
build() {
cd $pkgname-$pkgver
@@ -22,11 +25,17 @@ build() {
make
}
+check() {
+ cd $pkgname-$pkgver
+
+ make check
+}
+
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
- install -Dm 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m 644 COPYING
}
# vim:set ts=2 sw=2 et: