summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/libbluray-git/PKGBUILD38
-rw-r--r--abs/extra/libdvdcss/PKGBUILD14
-rw-r--r--abs/extra/libdvdnav/PKGBUILD26
-rw-r--r--abs/extra/libdvdnav/deadlock.patch17
-rw-r--r--abs/extra/libdvdread/DVDFileStat.patch238
-rw-r--r--abs/extra/libdvdread/PKGBUILD36
-rw-r--r--abs/extra/libva/PKGBUILD34
-rw-r--r--abs/extra/libva/libva-dont-install-tests.patch45
-rw-r--r--abs/extra/libva/patch1.patch11
-rw-r--r--abs/extra/libvpx/PKGBUILD28
-rw-r--r--abs/extra/mpg123/PKGBUILD33
-rw-r--r--abs/extra/opencore-amr/PKGBUILD24
-rw-r--r--abs/extra/orc/PKGBUILD24
-rw-r--r--abs/extra/rtmpdump/PKGBUILD41
-rw-r--r--abs/extra/schroedinger/PKGBUILD29
15 files changed, 610 insertions, 28 deletions
diff --git a/abs/extra/libbluray-git/PKGBUILD b/abs/extra/libbluray-git/PKGBUILD
new file mode 100644
index 0000000..c83dce3
--- /dev/null
+++ b/abs/extra/libbluray-git/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andrew Cook <ariscop@gmail.com>
+
+pkgname=libbluray-git
+pkgver=20101110
+pkgrel=1
+pkgdesc="Blu-Ray access library"
+arch=('i686' 'x86_64')
+depends=('doxygen')
+license=('LGPL')
+url="http://www.videolan.org/developers/libbluray.html"
+makedepends=('git')
+source=()
+md5sums=()
+provides=('libbluray')
+conflicts=('libbluray')
+
+_gitroot="git://git.videolan.org/libbluray.git"
+_gitname="libbluray"
+
+build() {
+ msg "Connecting to GIT server..."
+
+ if [ -d ${srcdir}/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ cd ${srcdir}/libbluray
+ ./bootstrap
+ ./configure --prefix=/
+ make || return 1
+ make DESTDIR=${pkgdir}/usr install || return 1
+}
diff --git a/abs/extra/libdvdcss/PKGBUILD b/abs/extra/libdvdcss/PKGBUILD
index 9b5253e..80772fa 100644
--- a/abs/extra/libdvdcss/PKGBUILD
+++ b/abs/extra/libdvdcss/PKGBUILD
@@ -1,22 +1,24 @@
-# $Id: PKGBUILD 14403 2008-10-06 08:19:39Z douglas $
+# $Id: PKGBUILD 37036 2009-04-30 04:50:40Z eric $
# Maintainer: arjan <arjan@archlinux.org>
# Contributor Sarah Hay <sarahhay@mb.sympatico.ca>
pkgname=libdvdcss
pkgver=1.2.10
-pkgrel=1
+pkgrel=1.1
pkgdesc="libdvdcss is a cross-platform library for transparent DVD device access with on-the-fly CSS decryption."
arch=('i686' 'x86_64')
+license=('GPL')
depends=('glibc')
options=('!libtool')
source=(http://download.videolan.org/pub/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2)
+md5sums=('ebd5370b79ac5a83e5c61b24a214cf74')
url="http://www.videolan.org/libdvdcss/"
-md5sums=('ebd5370b79ac5a83e5c61b24a214cf74')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
make || return 1
- make DESTDIR=$startdir/pkg install
+ make DESTDIR=$pkgdir install || return 1
}
+
diff --git a/abs/extra/libdvdnav/PKGBUILD b/abs/extra/libdvdnav/PKGBUILD
index 4e9e3ca..67c56e4 100644
--- a/abs/extra/libdvdnav/PKGBUILD
+++ b/abs/extra/libdvdnav/PKGBUILD
@@ -1,22 +1,30 @@
-# $Id: PKGBUILD 927 2008-04-24 21:34:43Z jgc $
+# $Id: PKGBUILD 69820 2010-02-22 22:23:44Z giovanni $
# Maintainer: arjan <arjan@archlinux.org>
# contributor Sarah Hay <sarahhay@mb.sympatico.ca>
pkgname=libdvdnav
-pkgver=0.1.10
-pkgrel=3
+pkgver=4.1.3
+pkgrel=2
pkgdesc="The library for xine-dvdnav plugin."
arch=(i686 x86_64)
license=('GPL')
-url="http://dvd.sourceforge.net/index.shtml"
-depends=('glibc')
+url="http://www.mplayerhq.hu/MPlayer/releases/dvdnav/"
+depends=('libdvdread>=4.1.3')
options=(!libtool)
-source=(http://downloads.sourceforge.net/sourceforge/dvd/${pkgname}-${pkgver}.tar.gz)
-md5sums=('c8ddee96ba1182d73447eaf0bb6fde81')
+source=(http://www.mplayerhq.hu/MPlayer/releases/dvdnav/${pkgname}-${pkgver}.tar.bz2
+ deadlock.patch)
+md5sums=('d62383c45b28816771e283515f2c27fa'
+ '864529165a1136ae4c1ccbc7b43cdb1a')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 -i ${srcdir}/deadlock.patch || return 1
+
./autogen.sh --prefix=/usr || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ make DESTDIR="${pkgdir}" install || return 1
}
+
+md5sums=('d62383c45b28816771e283515f2c27fa'
+ 'd26d9ab9d705e4e3fa16e0592ad33c79')
diff --git a/abs/extra/libdvdnav/deadlock.patch b/abs/extra/libdvdnav/deadlock.patch
new file mode 100644
index 0000000..2a58240
--- /dev/null
+++ b/abs/extra/libdvdnav/deadlock.patch
@@ -0,0 +1,17 @@
+--- a/src/dvdnav.c 2009-11-08 16:58:25.000000000 +0300
++++ b/src/dvdnav.c 2009-11-08 16:58:52.000000000 +0300
+@@ -180,12 +180,13 @@
+ pthread_mutex_unlock(&this->vm_lock);
+ return DVDNAV_STATUS_ERR;
+ }
++ pthread_mutex_unlock(&this->vm_lock);
++
+ #ifdef LOG_DEBUG
+ fprintf(MSG_OUT, "libdvdnav: clearing dvdnav\n");
+ #endif
+ result = dvdnav_clear(this);
+
+- pthread_mutex_unlock(&this->vm_lock);
+ return result;
+ }
+
diff --git a/abs/extra/libdvdread/DVDFileStat.patch b/abs/extra/libdvdread/DVDFileStat.patch
new file mode 100644
index 0000000..04d06f7
--- /dev/null
+++ b/abs/extra/libdvdread/DVDFileStat.patch
@@ -0,0 +1,238 @@
+diff -pruN libdvdread-4.1.3/src/dvd_reader.c libdvdread-4.1.3.new/src/dvd_reader.c
+--- libdvdread-4.1.3/src/dvd_reader.c 2008-09-06 23:55:51.000000000 +0200
++++ libdvdread-4.1.3.new/src/dvd_reader.c 2009-02-28 01:36:20.000000000 +0100
+@@ -889,6 +889,187 @@ void DVDCloseFile( dvd_file_t *dvd_file
+ }
+ }
+
++static int DVDFileStatVOBUDF(dvd_reader_t *dvd, int title,
++ int menu, dvd_stat_t *statbuf)
++{
++ char filename[ MAX_UDF_FILE_NAME_LEN ];
++ uint32_t size;
++ off_t tot_size;
++ off_t parts_size[9];
++ int nr_parts = 0;
++ int n;
++
++ if( title == 0 ) {
++ sprintf( filename, "/VIDEO_TS/VIDEO_TS.VOB" );
++ } else {
++ sprintf( filename, "/VIDEO_TS/VTS_%02d_%d.VOB", title, menu ? 0 : 1 );
++ }
++ if(!UDFFindFile( dvd, filename, &size )) {
++ return -1;
++ }
++ tot_size = size;
++ nr_parts = 1;
++ parts_size[0] = size;
++
++ if( !menu ) {
++ int cur;
++
++ for( cur = 2; cur < 10; cur++ ) {
++ sprintf( filename, "/VIDEO_TS/VTS_%02d_%d.VOB", title, cur );
++ if( !UDFFindFile( dvd, filename, &size ) ) {
++ break;
++ }
++ parts_size[nr_parts] = size;
++ tot_size += size;
++ nr_parts++;
++ }
++ }
++
++ statbuf->size = tot_size;
++ statbuf->nr_parts = nr_parts;
++ for(n = 0; n < nr_parts; n++) {
++ statbuf->parts_size[n] = parts_size[n];
++ }
++ return 0;
++}
++
++
++static int DVDFileStatVOBPath( dvd_reader_t *dvd, int title,
++ int menu, dvd_stat_t *statbuf )
++{
++ char filename[ MAX_UDF_FILE_NAME_LEN ];
++ char full_path[ PATH_MAX + 1 ];
++ struct stat fileinfo;
++ off_t tot_size;
++ off_t parts_size[9];
++ int nr_parts = 0;
++ int n;
++
++
++
++ if( title == 0 ) {
++ sprintf( filename, "VIDEO_TS.VOB" );
++ } else {
++ sprintf( filename, "VTS_%02d_%d.VOB", title, menu ? 0 : 1 );
++ }
++ if( !findDVDFile( dvd, filename, full_path ) ) {
++ return -1;
++ }
++
++ if( stat( full_path, &fileinfo ) < 0 ) {
++ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
++ return -1;
++ }
++
++
++ tot_size = fileinfo.st_size;
++ nr_parts = 1;
++ parts_size[0] = fileinfo.st_size;
++
++ if( !menu ) {
++ int cur;
++
++ for( cur = 2; cur < 10; cur++ ) {
++
++ sprintf( filename, "VTS_%02d_%d.VOB", title, cur );
++ if( !findDVDFile( dvd, filename, full_path ) ) {
++ break;
++ }
++
++ if( stat( full_path, &fileinfo ) < 0 ) {
++ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
++ break;
++ }
++
++ parts_size[nr_parts] = fileinfo.st_size;
++ tot_size += parts_size[nr_parts];
++ nr_parts++;
++ }
++ }
++
++ statbuf->size = tot_size;
++ statbuf->nr_parts = nr_parts;
++ for(n = 0; n < nr_parts; n++) {
++ statbuf->parts_size[n] = parts_size[n];
++ }
++ return 0;
++}
++
++
++int DVDFileStat(dvd_reader_t *dvd, int titlenum,
++ dvd_read_domain_t domain, dvd_stat_t *statbuf)
++{
++ char filename[ MAX_UDF_FILE_NAME_LEN ];
++ char full_path[ PATH_MAX + 1 ];
++ struct stat fileinfo;
++ uint32_t size;
++
++ /* Check arguments. */
++ if( dvd == NULL || titlenum < 0 ) {
++ errno = EINVAL;
++ return -1;
++ }
++
++ switch( domain ) {
++ case DVD_READ_INFO_FILE:
++ if( titlenum == 0 ) {
++ sprintf( filename, "/VIDEO_TS/VIDEO_TS.IFO" );
++ } else {
++ sprintf( filename, "/VIDEO_TS/VTS_%02i_0.IFO", titlenum );
++ }
++ break;
++ case DVD_READ_INFO_BACKUP_FILE:
++ if( titlenum == 0 ) {
++ sprintf( filename, "/VIDEO_TS/VIDEO_TS.BUP" );
++ } else {
++ sprintf( filename, "/VIDEO_TS/VTS_%02i_0.BUP", titlenum );
++ }
++ break;
++ case DVD_READ_MENU_VOBS:
++ if( dvd->isImageFile ) {
++ return DVDFileStatVOBUDF( dvd, titlenum, 1, statbuf );
++ } else {
++ return DVDFileStatVOBPath( dvd, titlenum, 1, statbuf );
++ }
++ break;
++ case DVD_READ_TITLE_VOBS:
++ if( titlenum == 0 ) {
++ return -1;
++ }
++ if( dvd->isImageFile ) {
++ return DVDFileStatVOBUDF( dvd, titlenum, 0, statbuf );
++ } else {
++ return DVDFileStatVOBPath( dvd, titlenum, 0, statbuf );
++ }
++ break;
++ default:
++ fprintf( stderr, "libdvdread: Invalid domain for file stat.\n" );
++ errno = EINVAL;
++ return -1;
++ }
++
++ if( dvd->isImageFile ) {
++ if( UDFFindFile( dvd, filename, &size ) ) {
++ statbuf->size = size;
++ statbuf->nr_parts = 1;
++ statbuf->parts_size[0] = size;
++ return 0;
++ }
++ } else {
++ if( findDVDFile( dvd, filename, full_path ) ) {
++ if( stat( full_path, &fileinfo ) < 0 ) {
++ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
++ } else {
++ statbuf->size = fileinfo.st_size;
++ statbuf->nr_parts = 1;
++ statbuf->parts_size[0] = statbuf->size;
++ return 0;
++ }
++ }
++ }
++ return -1;
++}
++
+ /* Internal, but used from dvd_udf.c */
+ int UDFReadBlocksRaw( dvd_reader_t *device, uint32_t lb_number,
+ size_t block_count, unsigned char *data,
+diff -pruN libdvdread-4.1.3/src/dvd_reader.h libdvdread-4.1.3.new/src/dvd_reader.h
+--- libdvdread-4.1.3/src/dvd_reader.h 2008-09-06 23:55:51.000000000 +0200
++++ libdvdread-4.1.3.new/src/dvd_reader.h 2009-02-28 01:36:49.000000000 +0100
+@@ -115,6 +115,42 @@ typedef enum {
+ } dvd_read_domain_t;
+
+ /**
++ *
++ */
++typedef struct {
++ off_t size; /**< Total size of file in bytes */
++ int nr_parts; /**< Number of file parts */
++ off_t parts_size[9]; /**< Size of each part in bytes */
++} dvd_stat_t;
++
++/**
++ * Stats a file on the DVD given the title number and domain.
++ * The information about the file is stored in a dvd_stat_t
++ * which contains information about the size of the file and
++ * the number of parts in case of a multipart file and the respective
++ * sizes of the parts.
++ * A multipart file is for instance VTS_02_1.VOB, VTS_02_2.VOB, VTS_02_3.VOB
++ * The size of VTS_02_1.VOB will be stored in stat->parts_size[0],
++ * VTS_02_2.VOB in stat->parts_size[1], ...
++ * The total size (sum of all parts) is stored in stat->size and
++ * stat->nr_parts will hold the number of parts.
++ * Only DVD_READ_TITLE_VOBS (VTS_??_[1-9].VOB) can be multipart files.
++ *
++ * This function is only of use if you want to get the size of each file
++ * in the filesystem. These sizes are not needed to use any other
++ * functions in libdvdread.
++ *
++ * @param dvd A dvd read handle.
++ * @param titlenum Which Video Title Set should be used, VIDEO_TS is 0.
++ * @param domain Which domain.
++ * @param stat Pointer to where the result is stored.
++ * @return If successful 0, otherwise -1.
++ *
++ * int DVDFileStat(dvd, titlenum, domain, stat);
++ */
++int DVDFileStat(dvd_reader_t *, int, dvd_read_domain_t, dvd_stat_t *);
++
++/**
+ * Opens a file on the DVD given the title number and domain.
+ *
+ * If the title number is 0, the video manager information is opened
+
diff --git a/abs/extra/libdvdread/PKGBUILD b/abs/extra/libdvdread/PKGBUILD
new file mode 100644
index 0000000..edbdaa4
--- /dev/null
+++ b/abs/extra/libdvdread/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 80196 2010-05-13 15:59:09Z andrea $
+# Maintainer:
+# Contributor: Thomas Baechler <thomas@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=libdvdread
+pkgver=4.1.3
+pkgrel=2
+pkgdesc="Provides a simple foundation for reading DVD video disks"
+arch=(i686 x86_64)
+url="http://www.mplayerhq.hu/MPlayer/releases/dvdnav/"
+license=('GPL')
+depends=('glibc')
+makedepends=('libdvdcss')
+optdepends=('libdvdcss: for decoding encrypted DVDs')
+options=('!libtool')
+source=("http://www.mplayerhq.hu/MPlayer/releases/dvdnav/${pkgname}-${pkgver}.tar.bz2"
+ 'DVDFileStat.patch')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # http://lists.mplayerhq.hu/pipermail/dvdnav-discuss/2009-February/000986.html (FS#19324)
+ patch -Np1 -i ${srcdir}/DVDFileStat.patch || return 1
+
+ ./autogen.sh --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums=('6dc068d442c85a3cdd5ad3da75f6c6e8'
+ '140d02afbf66bfbf034549157ed4f7ad')
diff --git a/abs/extra/libva/PKGBUILD b/abs/extra/libva/PKGBUILD
new file mode 100644
index 0000000..16cb53c
--- /dev/null
+++ b/abs/extra/libva/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 96203 2010-10-19 09:46:04Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+pkgname=libva
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="Video Acceleration (VA) API for Linux"
+arch=('i686' 'x86_64')
+url="http://freedesktop.org/wiki/Software/vaapi"
+license=('MIT')
+depends=('libgl' 'libdrm' 'libxfixes')
+makedepends=('mesa')
+optdepends=('vdpau-video: VDPAU backend for VA API')
+options=('!libtool')
+source=(http://cgit.freedesktop.org/libva/snapshot/${pkgname}-${pkgver}.tar.bz2)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --enable-i965-driver \
+ --enable-glx
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -m644 -D COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('c4680eb0d9004c72cd6e4de45cf479cf'
+ '88f1142a1f437f2de7d8e9fd50c5b33c')
+md5sums=('c4680eb0d9004c72cd6e4de45cf479cf')
diff --git a/abs/extra/libva/libva-dont-install-tests.patch b/abs/extra/libva/libva-dont-install-tests.patch
new file mode 100644
index 0000000..0c3d120
--- /dev/null
+++ b/abs/extra/libva/libva-dont-install-tests.patch
@@ -0,0 +1,45 @@
+--- test/basic/Makefile.am~ 2010-02-12 09:42:10.000000000 -0500
++++ test/basic/Makefile.am 2010-03-10 13:36:50.449834525 -0500
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = test_01 test_02 test_03 test_04 test_05 test_06 \
++check_PROGRAMS = test_01 test_02 test_03 test_04 test_05 test_06 \
+ test_07 test_08 test_09 test_10 test_11
+
+ AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+--- test/decode/Makefile.am~ 2010-02-12 09:42:10.000000000 -0500
++++ test/decode/Makefile.am 2010-03-10 13:37:09.636843464 -0500
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = mpeg2vldemo
++check_PROGRAMS = mpeg2vldemo
+
+ AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+
+--- test/encode/Makefile.am~ 2010-02-12 09:42:10.000000000 -0500
++++ test/encode/Makefile.am 2010-03-10 13:37:26.701846294 -0500
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = h264encode
++check_PROGRAMS = h264encode
+
+ AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+
+--- test/putsurface/Makefile.am~ 2010-03-10 13:18:55.270697040 -0500
++++ test/putsurface/Makefile.am 2010-03-10 13:38:08.106713556 -0500
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = putsurface
++check_PROGRAMS = putsurface
+
+ AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+
+
diff --git a/abs/extra/libva/patch1.patch b/abs/extra/libva/patch1.patch
new file mode 100644
index 0000000..b455857
--- /dev/null
+++ b/abs/extra/libva/patch1.patch
@@ -0,0 +1,11 @@
+--- test/basic/Makefile.am.orig 2010-11-10 00:34:13.000000000 +0000
++++ test/basic/Makefile.am 2010-11-10 00:34:54.000000000 +0000
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = test_01 test_02 test_03 test_04 test_05 test_06 \
++check_PROGRAMS = test_01 test_02 test_03 test_04 test_05 test_06 \
+ test_07 test_08 test_09 test_10 test_11
+
+ AM_CFLAGS = -I$(top_srcdir)/va -I$(top_srcdir)/src/x11
diff --git a/abs/extra/libvpx/PKGBUILD b/abs/extra/libvpx/PKGBUILD
new file mode 100644
index 0000000..1f00831
--- /dev/null
+++ b/abs/extra/libvpx/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 97641 2010-10-31 21:07:06Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+pkgname=libvpx
+pkgver=0.9.5
+pkgrel=1
+pkgdesc="The VP8 Codec SDK"
+arch=('i686' 'x86_64')
+url="http://www.webmproject.org/"
+license=('BSD')
+depends=('glibc')
+makedepends=('yasm')
+source=(http://webm.googlecode.com/files/${pkgname}-v${pkgver}.tar.bz2)
+sha1sums=('223965ff16737251afb3377c0800d1f8b5f84379')
+
+build() {
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ ./configure --enable-vp8 \
+ --enable-runtime-cpu-detect \
+ --enable-shared \
+ --enable-postproc \
+ --enable-pic \
+ --disable-install-docs \
+ --disable-install-srcs
+ make
+ make DIST_DIR="$pkgdir/usr" install
+ install -D -m 0644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/abs/extra/mpg123/PKGBUILD b/abs/extra/mpg123/PKGBUILD
new file mode 100644
index 0000000..5b1b335
--- /dev/null
+++ b/abs/extra/mpg123/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 85300 2010-07-11 18:52:51Z eric $
+# Maintainer: Hugo Doria <hugo@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+pkgname=mpg123
+pkgver=1.12.3
+pkgrel=1
+pkgdesc="A console based real time MPEG Audio Player for Layer 1, 2 and 3"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/mpg123"
+license=('GPL2' 'LGPL2.1')
+depends=('glibc' 'libtool' 'alsa-lib')
+makedepends=('esound' 'sdl')
+optdepends=('esound: for additional audio support' 'sdl: for additional audio support')
+conflicts=('mpg321')
+provides=('mpg321')
+replaces=('mpg321')
+options=('libtool')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('c1568be2d1715786bd6b1a89ec6fa7ef')
+sha1sums=('5e92d3c918f6095264089f711a9f38a5d2168b31')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --with-audio="alsa esd sdl"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/abs/extra/opencore-amr/PKGBUILD b/abs/extra/opencore-amr/PKGBUILD
new file mode 100644
index 0000000..2c569d8
--- /dev/null
+++ b/abs/extra/opencore-amr/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 62600 2010-01-10 14:06:30Z ibiru $
+# Maintainer: Ionut Biru <ionut@archlinux.ro>
+# Contributor: WAntilles <wantilles@adslgr.com>
+
+pkgname=opencore-amr
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Open source implementation of the Adaptive Multi Rate (AMR) speech codec"
+arch=('i686' 'x86_64')
+license=('APACHE')
+url="http://opencore-amr.sourceforge.net/"
+depends=('gcc-libs')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+options=('!libtool')
+md5sums=('8e8b8b253eb046340ff7b6bf7a6ccd3e')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR=${pkgdir}/ install || return 1
+}
+
diff --git a/abs/extra/orc/PKGBUILD b/abs/extra/orc/PKGBUILD
new file mode 100644
index 0000000..659bc47
--- /dev/null
+++ b/abs/extra/orc/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 98440 2010-11-08 23:53:36Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+pkgname=orc
+pkgver=0.4.11
+pkgrel=1
+pkgdesc="The Oild Runtime Compiler"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://code.entropywave.com/projects/orc/"
+depends=('glibc')
+options=('!libtool')
+source=(http://code.entropywave.com/download/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('b8b0b148d319422c3ad250c29483b3c4')
+
+build () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr \
+ --disable-static
+ make
+ make DESTDIR=${pkgdir} install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
diff --git a/abs/extra/rtmpdump/PKGBUILD b/abs/extra/rtmpdump/PKGBUILD
index 33d90b1..ee3c007 100644
--- a/abs/extra/rtmpdump/PKGBUILD
+++ b/abs/extra/rtmpdump/PKGBUILD
@@ -1,19 +1,34 @@
-# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
-# Maintainer: Cecil Watson<knoppmyth@gmail.com>
-
+# Maintainer: xduugu
+# Contributor: Elis Hughes <elishughes@googlemail.com>
pkgname=rtmpdump
-pkgver=1.2a
+pkgver=2.3
pkgrel=2
-pkgdesc="A small dumper for media content streamed over the RTMP protocol."
+pkgdesc="A tool to download rtmp:// and rtmpe:// streams"
arch=('i686' 'x86_64')
-license=('GPL2')
-url="http://sourceforge.net/projects/rtmpdump/"
-depends=('boost')
-source=('http://garr.dl.sourceforge.net/sourceforge/rtmpdump/rtmpdump-v1.2a.tar.gz')
+url="http://rtmpdump.mplayerhq.hu/"
+license=('LGPL')
+depends=('openssl')
+source=(
+ http://mirrors.kernel.org/gentoo/distfiles/$pkgname-$pkgver.tgz
+ # Upstream is not accessible from Vodafone/Germany
+ #http://rtmpdump.mplayerhq.hu/download/$pkgname-$pkgver.tgz
+)
+md5sums=('eb961f31cd55f0acf5aad1a7b900ef59')
+sha256sums=('ef38b7a99d82ce6912063d21063aeaf28185341b3df486e24bffce5354224b2c')
+
+#if [[ ! -e "$SRCDEST/${source[0]##*/}" ]]; then
+ #cd "$SRCDEST"
+ #download_file "$(get_downloadclient "$(get_url "${source[0]}")")" "$(get_url "${source[0]}")" "$(get_filename "${source[0]}")" \
+ #|| download_file "$(get_downloadclient "$(get_url "${source[1]}")")" "$(get_url "${source[1]}")" "$(get_filename "${source[1]}")"
+ #cd "$OLDPWD"
+#fi
build() {
- cd $startdir/src/rtmpdump
- make
- mkdir -p $startdir/pkg/usr/bin
- cp -p rtmpdump $startdir/pkg/usr/bin
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's/^install_so.0:.*/& install_base/' librtmp/Makefile
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make prefix=/usr MANDIR="$pkgdir/usr/share/man" DESTDIR="$pkgdir" install
}
diff --git a/abs/extra/schroedinger/PKGBUILD b/abs/extra/schroedinger/PKGBUILD
new file mode 100644
index 0000000..0de2d23
--- /dev/null
+++ b/abs/extra/schroedinger/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 79531 2010-05-04 09:01:27Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Timm Preetz <timm@preetz.us>
+# Contributor: rabyte <rabyte__gmail>
+pkgname=schroedinger
+pkgver=1.0.9
+pkgrel=1
+pkgdesc="An implemenation of the Dirac video codec in ANSI C code"
+arch=('i686' 'x86_64')
+url="http://www.diracvideo.org/"
+license=('GPL2' 'LGPL2' 'MPL' 'MIT')
+depends=('orc>=0.4.3')
+makedepends=('pkgconfig')
+options=(!libtool)
+source=(http://www.diracvideo.org/download/schroedinger/$pkgname-$pkgver.tar.gz)
+md5sums=('d67ec48b7c506db8c8b49156bf409e60')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
+ ./configure --prefix=/usr
+
+ make || return 1
+ make DESTDIR=$pkgdir install
+
+ install -m644 -D COPYING.MIT $pkgdir/usr/share/licenses/$pkgname/COPYING.MIT
+}
+