summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/google-chrome/PKGBUILD14
-rw-r--r--abs/extra/plex-media-server/PKGBUILD6
-rw-r--r--abs/extra/web-on-linhes/PKGBUILD16
-rw-r--r--abs/extra/web-on-linhes/web-on-linhes.sh5
-rwxr-xr-xabs/extra/web-on-linhes/web-on-linhes_is.conf10
-rwxr-xr-xabs/extra/web-on-linhes/wol-custom-cmds.sh13
6 files changed, 47 insertions, 17 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index e7d9eb5..86f6124 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,9 +5,9 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=62.0.3202.75
+pkgver=63.0.3239.108
pkgrel=1
-pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
+pkgdesc="The popular and trusted web browser by Google (Stable Channel)"
arch=('x86_64')
url="https://www.google.com/chrome"
license=('custom:chrome')
@@ -22,8 +22,8 @@ options=('!emptydirs' '!strip')
install=$pkgname.install
_channel=stable
source=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb"
- "$url/browser/privacy/eula_text.html"
- 'google-chrome-stable.sh')
+ 'eula_text.html'
+ "google-chrome-$_channel.sh")
package() {
msg2 "Extracting the data.tar.xz..."
@@ -41,7 +41,9 @@ package() {
done
# Man page
- gzip "$pkgdir"/usr/share/man/man1/google-chrome.1
+ if [[ -f "$pkgdir"/usr/share/man/man1/google-chrome.1 ]]; then
+ gzip "$pkgdir"/usr/share/man/man1/google-chrome.1
+ fi
# License
install -Dm644 eula_text.html "$pkgdir"/usr/share/licenses/google-chrome/eula_text.html
@@ -53,6 +55,6 @@ package() {
rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/opt/google/chrome/cron/
rm "$pkgdir"/opt/google/chrome/product_logo_*.png
}
-md5sums=('dde31453425d80944f304ed84746dbab'
+md5sums=('cc36f3a115e3e213a2bedb8b8fbe08ba'
'd50d8f0a6940791eabc41c4f64e6a3cf'
'ed4cf73982461af7d0d944c1cbf9f4e8')
diff --git a/abs/extra/plex-media-server/PKGBUILD b/abs/extra/plex-media-server/PKGBUILD
index 23fc75e..276b2c5 100644
--- a/abs/extra/plex-media-server/PKGBUILD
+++ b/abs/extra/plex-media-server/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: Praekon <praekon@googlemail.com>
pkgname=plex-media-server
-pkgver=1.9.7.4460
-_pkgsum=a39b25852
+pkgver=1.10.1.4602
+_pkgsum=f54242b6b
pkgrel=1
pkgdesc='Plex Media Server'
arch=('x86_64')
@@ -45,4 +45,4 @@ md5sums=('dfd6778f5c0d3d64c2c3a71dca02b7cc'
'97241861f2c0b7c82d1945a6c5de8e35'
'506ec15815bba749a743780edd2323c8'
'af6d0a81c7821b2eddb1bc137310ca1b')
-md5sums_x86_64=('19b81df06592416bcc9e90d536156e10')
+md5sums_x86_64=('ba3d53cb049edf368383154ae0d89ca5')
diff --git a/abs/extra/web-on-linhes/PKGBUILD b/abs/extra/web-on-linhes/PKGBUILD
index 0a28e81..0746933 100644
--- a/abs/extra/web-on-linhes/PKGBUILD
+++ b/abs/extra/web-on-linhes/PKGBUILD
@@ -2,22 +2,26 @@
# Maintainer: Cecil Watson<knoppmyth@gmail.com>
pkgname=web-on-linhes
-pkgver=1.3
-pkgrel=3
+pkgver=1.4
+pkgrel=1
pkgdesc="Added multiple websites with 10' UIs to Play Online Streams."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.linhes.org/"
depends=('google-chrome')
install=web-on-linhes.install
-source=('web-on-linhes.sh' 'web-on-linhes_is.conf')
+source=('web-on-linhes.sh' 'web-on-linhes_is.conf' 'wol-custom-cmds.sh')
+backup=('home/mythtv/.wol-custom-cmds.sh')
package() {
cd ${srcdir}
install -d ${pkgdir}/usr/LH/bin
- install -D -m755 *.sh ${pkgdir}/usr/LH/bin
+ install -D -m755 web-on-linhes.sh ${pkgdir}/usr/LH/bin
#add in file for gen_is.xml
install -D -m0744 ${srcdir}/web-on-linhes_is.conf ${pkgdir}/etc/gen_is_xml.d/web-on-linhes_is.conf
+ #add wol-custom-cmds file
+ install -D -o1000 -g1000 -m755 ${srcdir}/wol-custom-cmds.sh ${pkgdir}/home/mythtv/.wol-custom-cmds.sh
}
-md5sums=('3691faa7118ac1251c959d3bcfcba85f'
- '61cafa7e7a11b1387202b6ef908105a7')
+md5sums=('f37e208b713ee5b5b3ac54b63597f39f'
+ '7eb75860715a84e7e75b804e159adf35'
+ '9f59fabdf944a7381919d4c8407ac21c')
diff --git a/abs/extra/web-on-linhes/web-on-linhes.sh b/abs/extra/web-on-linhes/web-on-linhes.sh
index 48414e9..3c458dd 100644
--- a/abs/extra/web-on-linhes/web-on-linhes.sh
+++ b/abs/extra/web-on-linhes/web-on-linhes.sh
@@ -7,7 +7,10 @@ irxPID=$!
stop_xss.sh &
xssPID=$!
#Launches chrome in full screen
-(sleep 1; wmctrl -r "Google Chrome" -b add,fullscreen) &
+(sleep 3; wmctrl -r "Google Chrome" -b add,fullscreen) &
+#Launches file to run any custom cmds
+(sleep 4; /home/mythtv/.wol-custom-cmds.sh $@) &
+#Launch chrome
google-chrome --no-first-run --kiosk $@
#Once done, stops irxevent and stop_xss.sh
kill $irxPID
diff --git a/abs/extra/web-on-linhes/web-on-linhes_is.conf b/abs/extra/web-on-linhes/web-on-linhes_is.conf
index 982bd8e..2913ec0 100755
--- a/abs/extra/web-on-linhes/web-on-linhes_is.conf
+++ b/abs/extra/web-on-linhes/web-on-linhes_is.conf
@@ -1,6 +1,14 @@
<!--#WebOnTV-->
<button>
<type>STREAM</type>
+ <text>ESPN</text>
+ <action>EXEC /usr/LH/bin/web-on-linhes.sh http://www.espn.com/watch</action>
+ </button>
+ <!--#WebOnTV-->
+
+ <!--#WebOnTV-->
+ <button>
+ <type>STREAM</type>
<text>NetFlix</text>
<action>EXEC /usr/LH/bin/web-on-linhes.sh http://netflix.com/WiHome</action>
</button>
@@ -17,7 +25,7 @@
<!--#WebOnTV-->
<button>
<type>STREAM</type>
- <text>TuneIn </text>
+ <text>TuneIn</text>
<action>EXEC /usr/LH/bin/web-on-linhes.sh http://tv.tunein.com/</action>
</button>
<!--#WebOnTV-->
diff --git a/abs/extra/web-on-linhes/wol-custom-cmds.sh b/abs/extra/web-on-linhes/wol-custom-cmds.sh
new file mode 100755
index 0000000..2386378
--- /dev/null
+++ b/abs/extra/web-on-linhes/wol-custom-cmds.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+# Launch commands to control a web page
+# $@ contains the website that was opened
+# The espn example moves the mouse and clicks to make the player active
+# Then the f key is pressed to make the video fullscreen
+
+if [[ $@ == *"espn.com"* ]];
+then
+ sleep 7
+ xdotool mousemove 722 531 click 1 click 1
+ xdotool key f
+fi