summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/qscintilla/PKGBUILD52
-rw-r--r--abs/extra/qtwebkit/PKGBUILD38
-rw-r--r--abs/extra/qtwebkit/python2-path.patch29
-rw-r--r--abs/extra/sip/PKGBUILD55
4 files changed, 137 insertions, 37 deletions
diff --git a/abs/extra/qscintilla/PKGBUILD b/abs/extra/qscintilla/PKGBUILD
index 9ba5a39..f002166 100644
--- a/abs/extra/qscintilla/PKGBUILD
+++ b/abs/extra/qscintilla/PKGBUILD
@@ -1,25 +1,23 @@
-# $Id: PKGBUILD 46926 2009-07-22 04:56:17Z pierre $
+# $Id$
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
-# Contributor: Michal Krenek <mikos@sg1.cz>
-# Contributor: DaNiMoTh <jjdanimoth.aur@gmail.com>
pkgbase=qscintilla
-pkgname=(qscintilla python-qscintilla)
-pkgver=2.4.5
-pkgrel=4
+pkgname=('qscintilla' 'python2-qscintilla')
+pkgver=2.5.1
+pkgrel=2
license=('GPL')
arch=('i686' 'x86_64')
url="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-makedepends=('pyqt')
-source=(http://riverbankcomputing.com/static/Downloads/QScintilla2/QScintilla-gpl-${pkgver}.tar.gz
- configure.py-objdir-support.diff)
-md5sums=('8063f8f933513959432c27c5ffecf56b'
+makedepends=('python2-pyqt')
+source=("http://riverbankcomputing.com/static/Downloads/QScintilla2/QScintilla-gpl-${pkgver}.tar.gz"
+ 'configure.py-objdir-support.diff')
+md5sums=('dd7edef5ff674d307057a3c12dbd8fce'
'8cf9c06252e2f11ab00e62848e322fd3')
build() {
- cd $srcdir/QScintilla-gpl-$pkgver
+ cd "${srcdir}/QScintilla-gpl-${pkgver}"
patch -Np1 -i "${srcdir}/configure.py-objdir-support.diff"
cd Qt4
@@ -30,31 +28,41 @@ build() {
qmake designer.pro INCLUDEPATH+=../Qt4 QMAKE_LIBDIR+=../Qt4
make
- cd ../Python
- python2 configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
+ cd ../
+ cp -rf Python Python2
+ cd Python
+ python configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
make
+
+ cd ../Python2
+ python2 configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
+ make
}
package_qscintilla() {
pkgdesc="A port to Qt4 of Neil Hodgson's Scintilla C++ editor class"
- provides=('qscintilla2')
- conflicts=('qscintilla2')
- replaces=('qscintilla2' 'qscintilla')
depends=('qt')
- cd ${srcdir}/QScintilla-gpl-${pkgver}/Qt4
+ cd "${srcdir}/QScintilla-gpl-${pkgver}/Qt4"
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
- cd ${srcdir}/QScintilla-gpl-${pkgver}/designer-Qt4
+ cd "${srcdir}/QScintilla-gpl-${pkgver}/designer-Qt4"
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
}
package_python-qscintilla() {
- pkgdesc="Python bindings for QScintilla2"
- conflicts=('python-qscintilla2')
- replaces=('python-qscintilla2')
- depends=('qscintilla' 'pyqt')
+ pkgdesc="Python 3 bindings for QScintilla2"
+ depends=('pyqt' 'qscintilla')
cd "${srcdir}/QScintilla-gpl-${pkgver}/Python"
+ install -Dm755 Qsci.so \
+ "${pkgdir}/usr/lib/python3.2/site-packages/PyQt4/Qsci.so"
+}
+
+package_python2-qscintilla() {
+ pkgdesc="Python 2 bindings for QScintilla2"
+ depends=('python-qscintilla' 'python2-pyqt')
+
+ cd "${srcdir}/QScintilla-gpl-${pkgver}/Python2"
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
}
diff --git a/abs/extra/qtwebkit/PKGBUILD b/abs/extra/qtwebkit/PKGBUILD
new file mode 100644
index 0000000..30f1c84
--- /dev/null
+++ b/abs/extra/qtwebkit/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=qtwebkit
+pkgver=2.2.0
+pkgrel=3
+arch=('i686' 'x86_64')
+url='http://trac.webkit.org/wiki/QtWebKit'
+pkgdesc='An open source web browser engine (Qt port)'
+license=('LGPL2.1' 'GPL3')
+depends=('qt' 'gperf' 'bison' 'phonon' 'gstreamer0.10-base')
+makedepends=('python2' 'mesa' 'chrpath')
+conflicts=('qt<4.7')
+source=("http://get.qt.nokia.com/${pkgname}/QtWebKit-${pkgver}.tar.gz"
+ 'python2-path.patch')
+sha1sums=('3582f3a8b593140af004a19479f5ec19693b3df7'
+ 'b0ef3d5596171e3900a685df9bcfac3068ad6330')
+
+build() {
+ cd "${srcdir}"/QtWebKit-${pkgver}
+
+ patch -p1 -i "${srcdir}"/python2-path.patch
+
+ cd Tools/Scripts
+ ./build-webkit --qt \
+ --prefix=/usr \
+ --makeargs="${MAKEFLAGS}" \
+ --release \
+ --3d-canvas
+}
+
+package() {
+ cd "${srcdir}"/QtWebKit-${pkgver}
+ make INSTALL_ROOT="${pkgdir}" -C WebKitBuild/Release install
+
+ # Fix RPATH
+ chrpath -r /usr/lib/ "${pkgdir}"/usr/lib/qt/imports/QtWebKit/libqmlwebkitplugin.so
+}
diff --git a/abs/extra/qtwebkit/python2-path.patch b/abs/extra/qtwebkit/python2-path.patch
new file mode 100644
index 0000000..2e270e6
--- /dev/null
+++ b/abs/extra/qtwebkit/python2-path.patch
@@ -0,0 +1,29 @@
+--- QtWebKit-2.2.0/Source/JavaScriptCore/DerivedSources.pro~ 2011-10-20 22:39:56.044519075 +0000
++++ QtWebKit-2.2.0/Source/JavaScriptCore/DerivedSources.pro 2011-10-20 22:41:21.302047082 +0000
+@@ -88,5 +88,5 @@
+ retgen.output = $$JSC_GENERATED_SOURCES_DIR/RegExpJitTables.h
+ retgen.wkScript = $$PWD/create_regex_tables
+ retgen.input = retgen.wkScript
+-retgen.commands = python $$retgen.wkScript > ${QMAKE_FILE_OUT}
++retgen.commands = python2 $$retgen.wkScript > ${QMAKE_FILE_OUT}
+ addExtraCompiler(retgen)
+--- QtWebKit-2.2.0/Source/WebCore/CodeGenerators.pri~ 2011-10-20 22:44:23.827225580 +0000
++++ QtWebKit-2.2.0/Source/WebCore/CodeGenerators.pri 2011-10-20 22:44:38.550707819 +0000
+@@ -640,7 +640,7 @@
+ inspectorJSON.output = $${WC_GENERATED_SOURCES_DIR}/Inspector.idl
+ inspectorJSON.input = INSPECTOR_JSON
+ inspectorJSON.wkScript = $$PWD/inspector/generate-inspector-idl
+-inspectorJSON.commands = python $$inspectorJSON.wkScript -o $${WC_GENERATED_SOURCES_DIR}/Inspector.idl $$PWD/inspector/Inspector.json
++inspectorJSON.commands = python2 $$inspectorJSON.wkScript -o $${WC_GENERATED_SOURCES_DIR}/Inspector.idl $$PWD/inspector/Inspector.json
+ inspectorJSON.depends = $$PWD/inspector/generate-inspector-idl
+ inspectorJSON.wkAddOutputToSources = false
+ addExtraCompiler(inspectorJSON)
+@@ -723,7 +723,7 @@
+ entities.output = $${WC_GENERATED_SOURCES_DIR}/HTMLEntityTable.cpp
+ entities.input = HTML_ENTITIES
+ entities.wkScript = $$PWD/html/parser/create-html-entity-table
+-entities.commands = python $$entities.wkScript -o $${WC_GENERATED_SOURCES_DIR}/HTMLEntityTable.cpp $$HTML_ENTITIES
++entities.commands = python2 $$entities.wkScript -o $${WC_GENERATED_SOURCES_DIR}/HTMLEntityTable.cpp $$HTML_ENTITIES
+ entities.clean = ${QMAKE_FILE_OUT}
+ entities.depends = $$PWD/html/parser/create-html-entity-table
+ addExtraCompiler(entities)
diff --git a/abs/extra/sip/PKGBUILD b/abs/extra/sip/PKGBUILD
index b17f34b..f50d054 100644
--- a/abs/extra/sip/PKGBUILD
+++ b/abs/extra/sip/PKGBUILD
@@ -1,30 +1,55 @@
-# $Id: PKGBUILD 96646 2010-10-23 10:39:10Z andrea $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# $Id$
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
-pkgname=sip
-pkgver=4.11.2
-pkgrel=2
-pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
+pkgbase=sip
+pkgname=('sip' 'python2-sip')
+pkgver=4.13
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.riverbankcomputing.com/software/sip/"
license=('custom:"sip"')
-depends=('python2' 'gcc-libs')
-source=("http://www.riverbankcomputing.com/static/Downloads/sip4/${pkgname}-${pkgver}.tar.gz")
-md5sums=('d799804ca0a88bd76c6c2cdf8935c3cb')
+makedepends=('python' 'python2')
+source=("http://www.riverbankcomputing.com/static/Downloads/sip4/${pkgbase}-${pkgver}.tar.gz")
+md5sums=('21b4e2cad56e4156df2220143264b8ff')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}"
+ cp -r ${pkgbase}-${pkgver} python2-${pkgbase}-${pkgver}
- python2 configure.py
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python configure.py CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
+ make
+
+ ### Python2 version ###
+ cd "${srcdir}/python2-${pkgbase}-${pkgver}"
+ python2 configure.py CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
make
}
-package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+package_sip() {
+ pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
+ depends=('python')
+ replaces=('python-sip')
+ provides=('python-sip')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+package_python2-sip() {
+ pkgdesc="A tool that makes it easy to create Python2 bindings for C and C++ libraries"
+ depends=('sip' 'python2')
+
+ cd "${srcdir}/python2-${pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Provided by sip
+ rm "${pkgdir}/usr/bin/sip"
+}