summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/ghosd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/ghosd/PKGBUILD')
-rwxr-xr-xabs/mv-core/ghosd/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/mv-core/ghosd/PKGBUILD b/abs/mv-core/ghosd/PKGBUILD
new file mode 100755
index 0000000..e954ef9
--- /dev/null
+++ b/abs/mv-core/ghosd/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=ghosd
+pkgver=0.0.1
+pkgrel=18
+pkgdesc="notification program like xosd"
+depends=('cairo' 'perl' 'pango')
+makedepends=('pkgconfig')
+arch=('i686')
+source=(osdClient.pl osdServer.config osdServer.pl green800.png red800.png blue800.png yellow800.png 'grey800.png')
+
+
+build() {
+ cd $startdir/src
+ cp -rp $startdir/$pkgname-$pkgver .
+ cd $startdir/src/$pkgname-$pkgver
+ make distclean
+ make clean
+ ./configure --prefix=/usr --disable-shared
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+ #install -D -m755 ./examples/.libs/image $startdir/pkg/usr/bin/imageGhosd
+ install -D -m755 ./examples/image $startdir/pkg/usr/bin/imageGhosd
+
+ cd $startdir/src
+ install -D -m755 osdClient.pl $startdir/pkg/usr/bin/osdClient.pl
+ install -D -m755 osdServer.pl $startdir/pkg/usr/bin/osdServer.pl
+ install -D -m755 osdServer.config $startdir/pkg/etc/osdServer.config
+ install -D -m755 green800.png $startdir/pkg/usr/share/green800.png
+ install -D -m755 red800.png $startdir/pkg/usr/share/red800.png
+ install -D -m755 blue800.png $startdir/pkg/usr/share/blue800.png
+ install -D -m755 yellow800.png $startdir/pkg/usr/share/yellow800.png
+ install -D -m755 grey800.png $startdir/pkg/usr/share/grey800.png
+}
+