summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD')
-rw-r--r--abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD
new file mode 100644
index 0000000..d572df1
--- /dev/null
+++ b/abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=mythgame-release-fixes
+pkgver=17719
+pkgrel=4
+pkgdesc="Emulation plugin for MythTV"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-release-fixes' 'zlib')
+conflicts=('mythtv-plugins-release-fixes')
+groups=('mythtv-all-plugins-release-fixes')
+license="GPL"
+source=()
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svnmod=mythplugins
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+PLUGIN=mythgame
+grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+if [ $? != 0 ]
+then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ export QMAKESPEC='linux-g++'
+ make distclean
+ ./configure --disable-all --enable-opengl --enable-mythgame
+
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+