summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD')
-rw-r--r--abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
index de26f57..bfb1de5 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
@@ -5,12 +5,15 @@ pkgdesc="Music playing plugin for MythTV"
url="http://www.mythtv.org"
arch=('i686' 'x86_64')
-depends=('mythtv-release-fixes ' 'libid3tag' 'flac>=1.1.4 ' 'a52dec' 'libcdaudio' 'libcddb' 'libdvdread' 'libid3tag' 'libmad' 'libogg' 'libtheora' 'libvorbis' 'taglib' 'libvisual' 'cdparanoia' 'sdl' 'faad2' 'lame' 'fftw2')
+
+depends=("mythtv-release-fixes>=${pkgver}" 'libid3tag' 'libmad' 'libvorbis' 'flac>=1.1.4' 'libcdaudio' \
+ 'cdparanoia' 'fftw2' 'sdl' 'faad2>=2.6.1' 'lame' 'taglib' \
+ 'libvisual-plugins' 'libvisual-projectm')
conflicts=('mythtv-plugins-release-fixes')
groups=('mythtv-all-plugins-release-fixes')
license="GPL"
-source=(gcc4.3.patch)
+source=()
_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
_svnmod=mythplugins
@@ -20,20 +23,17 @@ build() {
echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
cd $startdir/src/mythplugins/mythmusic
- patch -p1 < ../../gcc4.3.patch
+# patch -p1 < ../../gcc4.3.patch
cd $startdir/src/mythplugins
- ./configure --disable-all --enable-mythmusic --enable-fftw --enable-sdl --disable-aac --enable-opengl
-PLUGIN=mythmusic
-grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
-if [ $? != 0 ]
-then
+ ./configure --disable-all --enable-mythmusic --enable-fftw --enable-sdl --disable-aac --enable-opengl --prefix=/usr
+ PLUGIN=mythmusic
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
msg "appending program lib"
- fi
-
-# ./configure --disable-all --enable-mythmusic
+ fi
make || return 1
-
make INSTALL_ROOT=$startdir/pkg install
}