summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/stable/mythflix/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/myth/stable/mythflix/PKGBUILD')
-rw-r--r--abs/mv-core/myth/stable/mythflix/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/mv-core/myth/stable/mythflix/PKGBUILD b/abs/mv-core/myth/stable/mythflix/PKGBUILD
new file mode 100644
index 0000000..a417a28
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythflix/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=mythflix-release-fixes
+pkgver=21228
+pkgrel=1
+pkgdesc="Netflix access plugin for MythTV"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-release-fixes')
+conflicts=('mythtv-plugins-release-fixes')
+groups=('mythtv-all-plugins-release-fixes')
+license="GPL"
+source=()
+#_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svnmod=mythplugins
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+ PLUGIN=mythflix
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ make distclean
+ ./configure --prefix=/usr --disable-all --enable-opengl --enable-mythflix
+
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}