summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/stable/mythvideo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/myth/stable/mythvideo/PKGBUILD')
-rw-r--r--abs/mv-core/myth/stable/mythvideo/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/mv-core/myth/stable/mythvideo/PKGBUILD b/abs/mv-core/myth/stable/mythvideo/PKGBUILD
new file mode 100644
index 0000000..5afee6a
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythvideo/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=mythvideo-release-fixes
+pkgver=21228
+pkgrel=1
+pkgdesc="Video playback and browsing plugin for MythTV"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-release-fixes' 'perlxml' 'perl-libwww' 'perl-uri' 'perl-xml-simple' 'ffmpeg')
+license="GPL"
+conflicts=('mythtv-plugins-release-fixes')
+groups=('mythtv-all-plugins-release-fixes')
+
+source=()
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svnmod=mythplugins
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+ make distclean
+ PLUGIN=mythvideo
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ ./configure --prefix=/usr --disable-all --enable-mythvideo --enable-transcode
+
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+md5sums=('2a9fbf45ae58a3a35857ce8d7c4d12db')