summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/stable/mythweather/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/myth/stable/mythweather/PKGBUILD')
-rw-r--r--abs/mv-core/myth/stable/mythweather/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/abs/mv-core/myth/stable/mythweather/PKGBUILD b/abs/mv-core/myth/stable/mythweather/PKGBUILD
new file mode 100644
index 0000000..dae89df
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythweather/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=mythweather-release-fixes
+pkgver=21228
+pkgrel=1
+pkgdesc="Weather checking plugin for MythTV"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-release-fixes' 'wget' 'perl-xml-sax' 'perl-soap-lite' 'perl-image-size' 'imagemagick')
+conflicts=('mythtv-plugins-release-fixes')
+groups=('mythtv-all-plugins-release-fixes')
+license="GPL"
+source=()
+#_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svnmod=mythplugins
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+ make distclean
+ PLUGIN=mythweather
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ ./configure --enable-opengl --disable-all --enable-mythweather --prefix=/usr
+
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+md5sums=('2a9fbf45ae58a3a35857ce8d7c4d12db')