summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/lshw
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/lshw')
-rw-r--r--abs/not_built/core/lshw/PKGBUILD34
-rw-r--r--abs/not_built/core/lshw/abi_stdlib.diff23
2 files changed, 57 insertions, 0 deletions
diff --git a/abs/not_built/core/lshw/PKGBUILD b/abs/not_built/core/lshw/PKGBUILD
new file mode 100644
index 0000000..6d76925
--- /dev/null
+++ b/abs/not_built/core/lshw/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 29087 2010-10-10 07:47:30Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Stefano Zamprogno <stefano dot zamprogno at gmail dot com>
+# Contributor: Chuck Yang <Chuck.Yang@gmail.com>
+
+pkgname=lshw
+pkgver=B.02.15
+pkgrel=1
+pkgdesc="A small tool to provide detailed information on the hardware configuration of the machine."
+url="http://ezix.org/project/wiki/HardwareLiSter"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('gcc-libs')
+optdepends=('gtk2')
+makedepends=('gcc')
+source=(http://ezix.org/software/files/lshw-$pkgver.tar.gz
+ abi_stdlib.diff)
+md5sums=('970bd9eb05fa3ae139a24a417465c54c'
+ '7adcdd7a2be2feba956a9832cf36abdf')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+# patch -Np1 -i ../abi_stdlib.diff || return 1
+
+ make || return 1
+ make gui || return 1
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir/ install || return 1
+ make DESTDIR=$pkgdir/ install-gui || return 1
+}
+
diff --git a/abs/not_built/core/lshw/abi_stdlib.diff b/abs/not_built/core/lshw/abi_stdlib.diff
new file mode 100644
index 0000000..ffe88d1
--- /dev/null
+++ b/abs/not_built/core/lshw/abi_stdlib.diff
@@ -0,0 +1,23 @@
+diff -wbBur lshw-B.02.14/src/core/abi.cc lshw-B.02.14.my//src/core/abi.cc
+--- lshw-B.02.14/src/core/abi.cc 2009-02-12 22:53:09.000000000 +0000
++++ lshw-B.02.14.my//src/core/abi.cc 2010-05-24 14:30:18.000000000 +0000
+@@ -10,6 +10,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <dirent.h>
++#include <stdlib.h>
+
+ __ID("@(#) $Id: mem.cc 1352 2006-05-27 23:54:13Z ezix $");
+
+diff -wbBur lshw-B.02.14/src/core/scsi.cc lshw-B.02.14.my//src/core/scsi.cc
+--- lshw-B.02.14/src/core/scsi.cc 2009-02-12 22:53:09.000000000 +0000
++++ lshw-B.02.14.my//src/core/scsi.cc 2010-05-24 14:32:13.000000000 +0000
+@@ -842,7 +842,7 @@
+
+ if (!controller)
+ {
+- controller = node.addChild(hwNode::hwNode("scsi", hw::storage));
++ controller = node.addChild(hwNode("scsi", hw::storage));
+ if (controller)
+ {
+ controller->setLogicalName(host_logicalname(number));