summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/ntfsprogs
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/ntfsprogs')
-rw-r--r--abs/not_built/core/ntfsprogs/PKGBUILD24
-rw-r--r--abs/not_built/core/ntfsprogs/ntfsprogs.install24
2 files changed, 48 insertions, 0 deletions
diff --git a/abs/not_built/core/ntfsprogs/PKGBUILD b/abs/not_built/core/ntfsprogs/PKGBUILD
new file mode 100644
index 0000000..56bf765
--- /dev/null
+++ b/abs/not_built/core/ntfsprogs/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 48342 2009-08-01 14:46:45Z jgc $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+
+pkgname=ntfsprogs
+pkgver=2.0.0
+pkgrel=4
+depends=('glibc' 'fuse' 'util-linux-ng>=2.16')
+makedepends=('pkgconfig')
+pkgdesc="NTFS filesystem utilities"
+arch=(i686 x86_64)
+license=('GPL')
+source=(http://downloads.sourceforge.net/sourceforge/linux-ntfs/${pkgname}-${pkgver}.tar.gz)
+url="http://www.linux-ntfs.org/"
+options=(!libtool)
+md5sums=('2c402b647bb7aeb1d3f8ce1cc354fd68')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-gnome-vfs \
+ --mandir=/usr/share/man || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
diff --git a/abs/not_built/core/ntfsprogs/ntfsprogs.install b/abs/not_built/core/ntfsprogs/ntfsprogs.install
new file mode 100644
index 0000000..a58d672
--- /dev/null
+++ b/abs/not_built/core/ntfsprogs/ntfsprogs.install
@@ -0,0 +1,24 @@
+ # arg 1: the new package version
+post_install() {
+cat << EOF
+NOTE:
+==> There is a good guide to use the ntfsresize utility at:
+ 'http://mlf.linux.rulez.org/mlf/ezaz/ntfsresize.html'
+
+WARNING:
+==> This program "can" cause dataloss if you don't use it right!
+==> Make a backup of your files! You have been warned !!!
+EOF
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+post_install $1
+}
+
+
+op=$1
+shift
+$op $* \ No newline at end of file