summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/abs
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/abs')
-rw-r--r--abs/not_built/extra/abs/PKGBUILD31
-rw-r--r--abs/not_built/extra/abs/abs.install12
2 files changed, 43 insertions, 0 deletions
diff --git a/abs/not_built/extra/abs/PKGBUILD b/abs/not_built/extra/abs/PKGBUILD
new file mode 100644
index 0000000..4273e8a
--- /dev/null
+++ b/abs/not_built/extra/abs/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 65230 2010-01-25 13:11:11Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+
+pkgname=abs
+pkgver=2.3.4.1
+pkgrel=1
+pkgdesc="Utilities to download and work with the Arch Build System (ABS)"
+arch=('i686' 'x86_64')
+url="http://projects.archlinux.org/abs.git/"
+license=('GPL')
+depends=('bash' 'rsync')
+backup=(etc/abs.conf)
+install=abs.install
+source=(ftp://ftp.archlinux.org/other/abs/${pkgname}-${pkgver}.tar.gz)
+md5sums=('286825d64f19f801d510ff1f7cc05ea6')
+
+build() {
+ cd ${srcdir}/${pkgname}
+
+ make CONFDIR=/etc/ || return 1
+ make CONFDIR=/etc/ DESTDIR=${pkgdir} install || return 1
+
+ # Add readme file, and make base /var/abs path
+ install -dm0755 ${pkgdir}/var/abs/local/
+ install -Dm0644 ${srcdir}/abs/README ${pkgdir}/var/abs/README
+
+ # change ABS tags for x86_64 to correct values
+ if [ "$CARCH" = "x86_64" ]; then
+ sed -i 's|"i686"|"x86_64"|g' ${pkgdir}/etc/abs.conf
+ fi
+}
diff --git a/abs/not_built/extra/abs/abs.install b/abs/not_built/extra/abs/abs.install
new file mode 100644
index 0000000..c16a8d7
--- /dev/null
+++ b/abs/not_built/extra/abs/abs.install
@@ -0,0 +1,12 @@
+pre_upgrade() {
+ if [ "$(vercmp $2 2.3.2-1)" -lt 0 ]; then
+ echo "==> Fixing potential ABS tree permission issues (this may take a while...)"
+
+ for dir in core extra community testing; do
+ if [ -d /var/abs/$dir ]; then
+ find /var/abs/$dir -type d -exec chown root:root {} \;
+ find /var/abs/$dir -type d -exec chmod 755 {} \;
+ fi
+ done
+ fi
+}