summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/pmount
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/pmount')
-rw-r--r--abs/not_built/extra/pmount/PKGBUILD22
-rw-r--r--abs/not_built/extra/pmount/pmount-dbus-close.patch11
2 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/extra/pmount/PKGBUILD b/abs/not_built/extra/pmount/PKGBUILD
new file mode 100644
index 0000000..bbdb957
--- /dev/null
+++ b/abs/not_built/extra/pmount/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 119797 2011-04-15 09:29:18Z jgc $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=pmount
+pkgver=0.9.23
+pkgrel=2
+pkgdesc="mount removable devices as normal user"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://pmount.alioth.debian.org/"
+backup=('etc/pmount.allow')
+depends=('sysfsutils>=2.0.0-1' 'bash')
+makedepends=('intltool')
+source=(https://alioth.debian.org/frs/download.php/3310/pmount-0.9.23.tar.bz2)
+md5sums=('db19f5bf3151b1b41705ec7bafa439d3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-hal
+ make
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/abs/not_built/extra/pmount/pmount-dbus-close.patch b/abs/not_built/extra/pmount/pmount-dbus-close.patch
new file mode 100644
index 0000000..06ffa2b
--- /dev/null
+++ b/abs/not_built/extra/pmount/pmount-dbus-close.patch
@@ -0,0 +1,11 @@
+diff -ruN pmount-0.9.13/src/pmount-hal.c pmount-0.9.13-new/src/pmount-hal.c
+--- pmount-0.9.13/src/pmount-hal.c 2006-08-15 22:31:02.000000000 +0200
++++ pmount-0.9.13-new/src/pmount-hal.c 2007-02-05 12:01:09.000000000 +0100
+@@ -361,7 +361,6 @@
+ /* shut down hal connection */
+ libhal_ctx_shutdown( hal_ctx, &error );
+ libhal_ctx_free( hal_ctx );
+- dbus_connection_close( dbus_conn );
+ dbus_connection_unref( dbus_conn );
+
+ /* go */