summaryrefslogtreecommitdiffstats
path: root/linhes/clean-chroot-manager/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/clean-chroot-manager/PKGBUILD')
-rw-r--r--linhes/clean-chroot-manager/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/linhes/clean-chroot-manager/PKGBUILD b/linhes/clean-chroot-manager/PKGBUILD
new file mode 100644
index 0000000..f4dfed8
--- /dev/null
+++ b/linhes/clean-chroot-manager/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: graysky <therealgraysky AT protonmail DOT com>
+
+pkgname=clean-chroot-manager
+pkgver=2.226
+pkgrel=1
+pkgdesc='Wrapper for managing clean chroot builds with local repo therein.'
+arch=('any')
+url='https://github.com/graysky2/clean-chroot-manager'
+license=('MIT')
+depends=('devtools>=1:1.0.0-1' 'rsync' 'libarchive>=3.3.3' 'pacman>=6.0.2-7')
+conflicts=('clean_chroot_manager')
+replaces=('clean_chroot_manager')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/graysky2/clean-chroot-manager/archive/v$pkgver.tar.gz")
+b2sums=('fce60c3f94aa07b32fd9da8436e228a3ae79db2fe8164593578543e777280cf6bed5803bb43068d95029c68880a2dfb0c964d944f43077a72f96f16620066ffc')
+install=ccm.install
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}