summaryrefslogtreecommitdiffstats
path: root/linhes/linhes-web/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/linhes-web/PKGBUILD')
-rw-r--r--linhes/linhes-web/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/linhes/linhes-web/PKGBUILD b/linhes/linhes-web/PKGBUILD
new file mode 100644
index 0000000..4fe3c49
--- /dev/null
+++ b/linhes/linhes-web/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=linhes-web
+pkgver=9.0.0
+pkgrel=13
+conflicts=()
+pkgdesc="LinHES local website"
+depends=('lighttpd' 'php-cgi')
+makedepends=()
+arch=('x86_64')
+license=('GPL')
+source=('linhes-web.conf' 'website.tar.gz')
+sha256sums=('e39ce02bde5eb3d359f1286b41751aa715961cf2b2d9a1243c7f01d20ed9c993'
+ '128b325b92818681151e8a1727e091b72dc3c14904976db11a5015c67f237e5d')
+
+package() {
+ mkdir -p $pkgdir/data/srv/httpd/htdocs/
+ cp -rp $srcdir/website/contents/* $pkgdir/data/srv/httpd/htdocs
+ chmod -R 755 $pkgdir/data/srv/httpd/htdocs
+
+ #lighttpd files
+ install -Dm644 $srcdir/linhes-web.conf $pkgdir/etc/lighttpd/conf.d/linhes-web.conf
+}