summaryrefslogtreecommitdiffstats
path: root/linhes/mythplugins/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/mythplugins/PKGBUILD')
-rw-r--r--linhes/mythplugins/PKGBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/linhes/mythplugins/PKGBUILD b/linhes/mythplugins/PKGBUILD
index 0b4c53c..98b2ca0 100644
--- a/linhes/mythplugins/PKGBUILD
+++ b/linhes/mythplugins/PKGBUILD
@@ -5,7 +5,6 @@
pkgbase=mythplugins
pkgname=('mythplugins-mytharchive'
- 'mythplugins-mythbrowser'
'mythplugins-mythgame'
'mythplugins-mythmusic'
'mythplugins-mythnetvision'
@@ -13,9 +12,9 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythweather'
'mythplugins-mythweb'
'mythplugins-mythzoneminder')
-br=fixes/33
+br=fixes/34
t="${br#*/}+${br%/[0-9][0-9]}"
-pkgver=33+fixes.20230313.7f288be6
+pkgver=34+fixes.20240220.a88dd47b
pkgrel=1
epoch=0
arch=('any')
@@ -25,14 +24,13 @@ makedepends=('dvdauthor' 'dvd+rw-tools' 'mesa-libgl' "mythtv>=$pkgver" 'git'
'perl-datetime-format-iso8601' 'perl-date-manip' 'perl-image-size' 'perl-cgi'
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-simple' 'perl-xml-xpath' 'libhdhomerun'
'python-pillow' 'python-pycurl' 'python-oauthlib' 'gdb' 'mariadb-libs' 'minizip'
- 'python-lxml' 'perl-xml-xpath' 'python-urllib3' 'libcdio-paranoia')
+ 'python-lxml' 'perl-xml-xpath' 'python-urllib3' 'libcdio-paranoia' 'libdiscid' 'libmusicbrainz5'
+ 'libcoverart')
source=("git+https://github.com/MythTV/mythweb#branch=$br"
"git+https://github.com/MythTV/mythtv#branch=$br"
- '001-mythnetvision-configure.patch'
)
sha256sums=('SKIP'
- 'SKIP'
- '51c9fb042a3f2acf4ab9682cb48e9a123cf8f0e312fd8b25dd187bb56e0d701a')
+ 'SKIP')
pkgver() {
cd "${srcdir}/mythtv/$pkgbase"
@@ -42,8 +40,6 @@ pkgver() {
prepare() {
cd "$srcdir/mythtv/$pkgbase"
- patch -Np1 < "../../001-mythnetvision-configure.patch"
-
cd "$srcdir/mythweb"
sed -re 's@/usr/local.*/usr/share@/usr/share@' -i 'mythweb.php'
@@ -66,14 +62,6 @@ package_mythplugins-mytharchive() {
make INSTALL_ROOT="$pkgdir" install
}
-package_mythplugins-mythbrowser() {
- pkgdesc="Mini web browser for MythTV"
- depends=('mythtv')
-
- cd "$srcdir/mythtv/$pkgbase/mythbrowser"
- make INSTALL_ROOT="$pkgdir" install
-}
-
package_mythplugins-mythgame() {
pkgdesc="Game emulator plugin for MythTV"
depends=('mythtv' 'minizip')