summaryrefslogtreecommitdiffstats
path: root/linhes/mythplugins/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/mythplugins/PKGBUILD')
-rw-r--r--linhes/mythplugins/PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/linhes/mythplugins/PKGBUILD b/linhes/mythplugins/PKGBUILD
index 16a196d..559281a 100644
--- a/linhes/mythplugins/PKGBUILD
+++ b/linhes/mythplugins/PKGBUILD
@@ -15,7 +15,7 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythzoneminder')
br=fixes/32
t="${br#*/}+${br%/[0-9][0-9]}"
-pkgver=32+fixes.20221129.44f88ed4
+pkgver=32+fixes.20221229.e74f587d
pkgrel=1
epoch=0
arch=('any')
@@ -118,19 +118,14 @@ package_mythplugins-mythweather() {
package_mythplugins-mythweb() {
pkgdesc="Web interface for the MythTV scheduler"
- depends=('mythtv' 'perl-cgi')
- optdepends=('lighttpd'
- 'php7-apache'
- 'php7-fpm'
- 'nginx')
+ depends=('mythtv' 'perl-cgi' 'lighttpd')
sed -i 's/unix.*-fpm\.sock;/unix:\/var\/run\/php-fpm7\/php-fpm\.sock;/' "$srcdir/mythweb/mythweb.conf.nginx"
- mkdir -p "$pkgdir/var/lib/mythtv/mythweb"/{image_cache,php_sessions}
- cp -R "$srcdir/mythweb"/* "$pkgdir/var/lib/mythtv/mythweb"
- chown -R http:http "$pkgdir/var/lib/mythtv/mythweb"
- chmod g+rw "$pkgdir/var/lib/mythtv/mythweb"/{image_cache,php_sessions}
-
+ mkdir -p "$pkgdir/data/srv/httpd/mythweb"/{image_cache,php_sessions}
+ cp -R "$srcdir/mythweb"/* "$pkgdir/data/srv/httpd/mythweb"
+ chown -R http:http "$pkgdir/data/srv/httpd/mythweb"
+ chmod g+rw "$pkgdir/data/srv/httpd/mythweb"/{image_cache,php_sessions}
}
package_mythplugins-mythzoneminder() {