summaryrefslogtreecommitdiffstats
path: root/linhes/mythtv/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/mythtv/PKGBUILD')
-rw-r--r--linhes/mythtv/PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/linhes/mythtv/PKGBUILD b/linhes/mythtv/PKGBUILD
index fbf3dcc..437a144 100644
--- a/linhes/mythtv/PKGBUILD
+++ b/linhes/mythtv/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=mythtv
-pkgver=32+fixes.20221122.987da09e
+pkgver=32+fixes.20221129.44f88ed4
pkgrel=1
pkgdesc="A Homebrew PVR project"
arch=('x86_64')
@@ -87,14 +87,12 @@ source=(
'99-mythbackend.rules'
'sysusers.d'
)
-sha256sums=(
- 'SKIP'
- '3c356d030c8e5fb8cbe7bc01041848c4e8073b0a696c0f34a3e3cc0fd83ecf0b'
- '3fd2018d0d5aaa7d530835305dac80d4ca7d8fc991cdf9e1cebadebd86e25c03'
- '12cb52bf9b084a4f16419c9370fef0450ce6a11308b0c3f7240f4f83df7e2ab6'
- 'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
- '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae'
-)
+sha256sums=('SKIP'
+ '3c356d030c8e5fb8cbe7bc01041848c4e8073b0a696c0f34a3e3cc0fd83ecf0b'
+ '3fd2018d0d5aaa7d530835305dac80d4ca7d8fc991cdf9e1cebadebd86e25c03'
+ '12cb52bf9b084a4f16419c9370fef0450ce6a11308b0c3f7240f4f83df7e2ab6'
+ 'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
+ '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae')
pkgver() {
cd "${srcdir}/mythtv/mythtv"
@@ -104,6 +102,10 @@ pkgver() {
build() {
cd "${srcdir}/mythtv/mythtv"
+ CFLAGS="${CFLAGS/flto=auto/fPIC}"
+ CXXFLAGS="${CXXFLAGS/flto=auto/fPIC}"
+ LDFLAGS="${LDFLAGS/flto=auto/fPIC}"
+
ARCH="${CARCH/_/-}"
./configure --prefix=/usr \
--cpu="$ARCH" \
@@ -119,6 +121,7 @@ build() {
--with-bindings=python \
--with-bindings=perl \
--perl-config-opts=INSTALLDIRS=vendor
+ echo "###### STARTING MAKE ####"
make
}