summaryrefslogtreecommitdiffstats
path: root/linhes/python-timeout-decorator/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/python-timeout-decorator/PKGBUILD')
-rw-r--r--linhes/python-timeout-decorator/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/linhes/python-timeout-decorator/PKGBUILD b/linhes/python-timeout-decorator/PKGBUILD
new file mode 100644
index 0000000..19bb182
--- /dev/null
+++ b/linhes/python-timeout-decorator/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: robertfoster
+
+_name=timeout-decorator
+pkgname=python-${_name}
+pkgver=0.5.0
+pkgrel=2
+pkgdesc="Timeout decorator for Python"
+arch=('i686' 'x86_64' 'armv6')
+depends=('python')
+makedepends=('python-setuptools')
+url="https://github.com/pnpnpn/timeout-decorator"
+license=('MIT')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/t/${_name}/${_name}-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ python setup.py install \
+ --root="$pkgdir" \
+ --optimize=1
+}
+
+md5sums=('8545649e70b3ca43bcff11f08a996c3e')